summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Price2022-10-15 21:23:59 -0700
committerChristopher Price2022-10-15 21:36:31 -0700
commit83d2a242d85a45a21f19b4a49d2ccf224acd0efa (patch)
treeb598a4d3f70685b454ea5caf3505996de22f8bf1
parent3b26443a0e8917fc9cff871c6173b3709f772718 (diff)
downloadaur-83d2a242d85a45a21f19b4a49d2ccf224acd0efa.tar.gz
follow ocaml package guidelines
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD31
2 files changed, 11 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5d6592a15cb..be9d92c5be6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,6 @@ pkgbase = google-drive-ocamlfuse
pkgrel = 1
url = https://astrada.github.io/google-drive-ocamlfuse/
arch = x86_64
- arch = i686
license = MIT
depends = ocaml>=4.04.0
depends = ocaml-findlib>=1.2.7
@@ -13,6 +12,7 @@ pkgbase = google-drive-ocamlfuse
depends = ocaml-sqlite3>=1.6.1
makedepends = dune
makedepends = ocaml-ounit
+ options = !strip
options = staticlibs
source = google-drive-ocamlfuse-0.7.30.tar.gz::https://github.com/astrada/google-drive-ocamlfuse/archive/v0.7.30.tar.gz
sha256sums = 3fe3f0d4051f1a81e37f6da9e8a492eb3c81f7450c6b43fee81a7fd94249bfa0
diff --git a/PKGBUILD b/PKGBUILD
index 847dae8d4f8c..651ca8af4e2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname=google-drive-ocamlfuse
pkgver=0.7.30
pkgrel=1
pkgdesc='FUSE-based file system backed by Google Drive, written in OCaml'
-arch=('x86_64' 'i686')
+arch=('x86_64')
url='https://astrada.github.io/google-drive-ocamlfuse/'
license=('MIT')
depends=(
@@ -18,35 +18,24 @@ makedepends=(
'dune'
'ocaml-ounit'
)
-options=('staticlibs')
+options=('!strip' 'staticlibs')
source=("$pkgname-$pkgver.tar.gz::https://github.com/astrada/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('3fe3f0d4051f1a81e37f6da9e8a492eb3c81f7450c6b43fee81a7fd94249bfa0')
build() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
- # Old method requires ocamlbuild instead of jbuilder/dune
- #ocaml setup.ml -configure --prefix /usr --destdir "$pkgdir" --exec-prefix "/usr"
- #ocaml setup.ml -build
+ export OCAMLPATH="$(ocamlfind printconf destdir)"
- #dune build --debug-backtraces --debug-dependency-path --debug-findlib --no-buffer --verbose @install
- dune build @install
+ dune build -p "$pkgname"
}
-#check() {
-# cd "$srcdir/$pkgname-$pkgver"
-#
-# ocaml setup.ml -test
-#}
-
package() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ dune install "$pkgname" --destdir="${pkgdir}" --prefix="/usr" --libdir="$(ocamlfind printconf destdir)"
- #export OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)"
- #ocaml setup.ml -install
+ install -dm755 "${pkgdir}/usr/share/"
- mkdir -p "$pkgdir/usr"
- mkdir -p "$pkgdir/$(ocamlfind printconf destdir)"
-
- dune install --prefix="$pkgdir/usr" --libdir="$pkgdir/$(ocamlfind printconf destdir)"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}