summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-11-10 06:51:30 +1300
committercaltlgin2020-11-10 06:51:30 +1300
commit83d4fbbc812c38427c33b2fa4d31cf43b9471806 (patch)
treecbc20f7b5ea2cdd2db237c69525d9dc79e4f3edf
parentdc1cab947fcd66c1c7bde07d34fc1960a8be5c82 (diff)
downloadaur-83d4fbbc812c38427c33b2fa4d31cf43b9471806.tar.gz
Update to v700
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76c07760c48c..963c9362e9a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,22 @@
pkgbase = unetbootin
pkgdesc = Create bootable Live USB drives
- pkgver = 681
- pkgrel = 2
+ pkgver = 700
+ pkgrel = 1
url = https://unetbootin.github.io
arch = x86_64
license = GPL3
+ makedepends = qt5-tools
makedepends = setconf
+ depends = hicolor-icon-theme
depends = mtools
depends = p7zip
- depends = qt4
+ depends = qt5-base
depends = syslinux
optdepends = polkit: run unetbootin directly from menu
- source = unetbootin-681::https://github.com/unetbootin/unetbootin/archive/681.tar.gz
+ source = unetbootin-700::https://github.com/unetbootin/unetbootin/archive/700.tar.gz
source = unetbootin.sh
source = org.archlinux.pkexec.unetbootin.policy
- sha256sums = ec62a6321c39203a096d6a778b2f1518da815ece135e5eb95ba1e42e28ec240a
+ sha256sums = 709f1ccc9f72c664d85fbaccce38c17cb8861261e2447f2000d0d753f5ffcbd0
sha256sums = 6b99405a78ac4de80e3a20e766ce993f22c8a01e4ab50f952a10bdcc26effd3f
sha256sums = 118f154e2772ff0d50d22735418fb37c9a03ecd0a1bbf2c8a4a8ed48da64160c
diff --git a/PKGBUILD b/PKGBUILD
index ba944046fc34..872556d92bec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,20 +7,20 @@
# Contributor: Michai Coman <mihai@m1x.ro>
pkgname='unetbootin'
-pkgver=681
-pkgrel=2
+pkgver=700
+pkgrel=1
pkgdesc='Create bootable Live USB drives'
arch=('x86_64')
url='https://unetbootin.github.io'
_url_source='https://github.com/unetbootin/unetbootin'
license=('GPL3')
-depends=('mtools' 'p7zip' 'qt4' 'syslinux')
-makedepends=('setconf')
+depends=('hicolor-icon-theme' 'mtools' 'p7zip' 'qt5-base' 'syslinux')
+makedepends=('qt5-tools' 'setconf')
optdepends=('polkit: run unetbootin directly from menu')
source=("${pkgname}-${pkgver}::${_url_source}/archive/${pkgver}.tar.gz"
"${pkgname}.sh"
"org.archlinux.pkexec.${pkgname}.policy")
-sha256sums=('ec62a6321c39203a096d6a778b2f1518da815ece135e5eb95ba1e42e28ec240a'
+sha256sums=('709f1ccc9f72c664d85fbaccce38c17cb8861261e2447f2000d0d753f5ffcbd0'
'6b99405a78ac4de80e3a20e766ce993f22c8a01e4ab50f952a10bdcc26effd3f'
'118f154e2772ff0d50d22735418fb37c9a03ecd0a1bbf2c8a4a8ed48da64160c')
@@ -32,9 +32,9 @@ prepare() {
build() {
cd "${pkgname}-${pkgver}/src/${pkgname}"
- lupdate-qt4 "${pkgname}.pro"
- lrelease-qt4 "${pkgname}.pro"
- qmake-qt4 "${pkgname}.pro" -config release "DEFINES += NOSTATIC" "RESOURCES -= ${pkgname}.qrc"
+ lupdate-qt5 "${pkgname}.pro"
+ lrelease-qt5 "${pkgname}.pro"
+ qmake-qt5 "${pkgname}.pro" -config release "DEFINES += NOSTATIC" "RESOURCES -= ${pkgname}.qrc"
make
}