summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-10-01 19:01:15 +0200
committersL1pKn072022-10-01 19:01:15 +0200
commit83d7de960ae85d5e3d61efc0cf7bd28e09db03ff (patch)
tree11dbfd954e110b27830f59c69241dafc876806e4
parentd62a531de8ca85aa0e0b06bba5466065dad4d6d0 (diff)
downloadaur-83d7de960ae85d5e3d61efc0cf7bd28e09db03ff.tar.gz
bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7fa0dbfdd9ee..20f7ed65dfef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vapoursynth-plugin-inpaint-git
pkgdesc = Plugin for Vapoursynth: inpaint (GIT version)
pkgver = r2.dafa5b5
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/invisiblearts/VapourSynth-Inpaint
arch = x86_64
license = GPL
@@ -10,8 +10,8 @@ pkgbase = vapoursynth-plugin-inpaint-git
depends = opencv
provides = vapoursynth-plugin-inpaint
conflicts = vapoursynth-plugin-inpaint
+ options = debug
source = inpaint::git+https://github.com/invisiblearts/VapourSynth-Inpaint.git
sha256sums = SKIP
pkgname = vapoursynth-plugin-inpaint-git
-
diff --git a/PKGBUILD b/PKGBUILD
index efdb0ea5e9cf..535450aad21e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
_plug=inpaint
pkgname=vapoursynth-plugin-${_plug}-git
pkgver=r2.dafa5b5
-pkgrel=2
+pkgrel=3
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/invisiblearts/VapourSynth-Inpaint'
@@ -16,6 +16,7 @@ provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/invisiblearts/VapourSynth-Inpaint.git")
sha256sums=('SKIP')
+options=('debug')
pkgver() {
cd "${_plug}"
@@ -32,7 +33,7 @@ prepare(){
echo "all:
g++ -c -std=gnu++11 -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) $(pkg-config --cflags opencv4) -o Inpaint.o Inpaint.cpp
- g++ -shared -fPIC ${LDFLAGS} -o lib${_plug}.so Inpaint.o" > Makefile
+ g++ -shared $(pkg-config --libs opencv4) -fPIC ${LDFLAGS} -o lib${_plug}.so Inpaint.o" > Makefile
}
build() {
@@ -40,6 +41,5 @@ build() {
}
package() {
- cd "${_plug}"
- install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+ install -Dm755 "${_plug}/lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
}