summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormclang2017-05-12 10:59:14 +0300
committermclang2017-05-12 10:59:14 +0300
commit83dd2291822b059fb4e6041e2672f2d7a1d2ea5d (patch)
tree4141af4cca244d65212644f4c41b4b5c9075a13f
downloadaur-83dd2291822b059fb4e6041e2672f2d7a1d2ea5d.tar.gz
Version 3.6.1 of NUnit3 console runner
-rw-r--r--.SRCINFO13
-rw-r--r--.wakatime-project1
-rw-r--r--PKGBUILD36
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e9d507b9159
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = nunit3-console
+ pkgdesc = NUnit 3 console runner
+ pkgver = 3.6.1
+ pkgrel = 1
+ url = http://www.nunit.com
+ arch = any
+ license = custom
+ depends = mono
+ source = https://github.com/nunit/nunit-console/releases/download/3.6.1/NUnit.Console-3.6.1.zip
+ sha256sums = 3a177506699282d5c9e720be8bab8f9c0cb925e0e78acd335fbf6798b7095648
+
+pkgname = nunit3-console
+
diff --git a/.wakatime-project b/.wakatime-project
new file mode 100644
index 000000000000..b83c8622cedc
--- /dev/null
+++ b/.wakatime-project
@@ -0,0 +1 @@
+AUR: Nunit3 Console
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdcc83480c8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+#
+# Maintainer: Jani Lång <jani . long at gmail dot com>
+# Contributor: Patrik Plihal <patrik.plihal at gmail dot com>
+#
+pkgname=nunit3-console
+pkgver=3.6.1
+pkgrel=1
+pkgdesc="NUnit 3 console runner"
+arch=('any')
+license=('custom')
+url="http://www.nunit.com"
+depends=('mono')
+
+source=("https://github.com/nunit/nunit-console/releases/download/${pkgver}/NUnit.Console-${pkgver}.zip")
+sha256sums=('3a177506699282d5c9e720be8bab8f9c0cb925e0e78acd335fbf6798b7095648')
+
+package() {
+ # copy files, except the link to the original zip file
+ mkdir -p "${pkgdir}/usr/lib/${pkgname}"
+ cp -r -p * "${pkgdir}/usr/lib/${pkgname}"
+ rm -f "${pkgdir}/usr/lib/${pkgname}/NUnit.Console-${pkgver}.zip"
+
+ # install license and icon
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+ install -Dm644 nunit.ico "${pkgdir}/usr/share/icons/${pkgname}/nunit.ico"
+
+ # create wrapper script for launching console runner with mono
+ # using '<<-' trims leading tabs (but not spaces!)
+ mkdir -p "${pkgdir}/usr/bin/"
+ cat <<-EOF > "$pkgdir/usr/bin/nunit3-console"
+ #!/bin/sh
+ # Wrapper script for NUnit 3 console runner
+ exec $(which mono) --debug /usr/lib/${pkgname}/nunit3-console.exe "\$@"
+EOF
+ chmod +x "${pkgdir}/usr/bin/nunit3-console"
+}