summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Kuehler2019-09-17 21:16:01 -0700
committerKevin Kuehler2019-09-17 21:16:01 -0700
commit83e40eb0226d73b0f12549612fc526f76d67f951 (patch)
tree637e55e93f392f166c59102bd5b93b8c1eca6d5e
parent71b5ed7483b958ae63bce233b6bdb5cdc8ee9188 (diff)
downloadaur-83e40eb0226d73b0f12549612fc526f76d67f951.tar.gz
Use our DESTDIR Makefile patch
https://github.com/arzzen/git-quick-stats/pull/72
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d3b201be047..fdbfcbd6ae45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = git-quick-stats
pkgdesc = `git-quick-stats` is a simple and efficient way to access various statistics in git repository.
pkgver = 2.0.9
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/arzzen/git-quick-stats
arch = x86_64
license = MIT
- depends = git
- depends = gawk
+ depends = bash
depends = coreutils
- depends = util-linux
+ depends = gawk
+ depends = git
depends = grep
depends = ncurses
+ depends = util-linux
provides = git-quick-stats
conflicts = git-quick-stats
source = git-quick-stats::git+https://github.com/arzzen/git-quick-stats#tag=2.0.9
diff --git a/PKGBUILD b/PKGBUILD
index 35b20e2b8065..9c027a53f447 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,19 @@
pkgname='git-quick-stats'
pkgver='2.0.9'
-pkgrel=2
+pkgrel=3
pkgdesc='`git-quick-stats` is a simple and efficient way to access various statistics in git repository.'
arch=('x86_64')
url="https://github.com/arzzen/$pkgname"
license=('MIT')
depends=(
- 'git'
- 'gawk'
+ 'bash'
'coreutils'
- 'util-linux'
+ 'gawk'
+ 'git'
'grep'
'ncurses'
+ 'util-linux'
)
makedepends=()
provides=('git-quick-stats')
@@ -28,6 +29,6 @@ check() {
package() {
cd "$srcdir/$pkgname"
- make PREFIX="$pkgdir/usr" install
+ make DESTDIR="$pkgdir" PREFIX=/usr install
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}