summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGenues2021-02-17 19:29:31 +0300
committerGenues2021-02-17 19:29:31 +0300
commit83f35937edad26c778c9168e89ec706571549ef9 (patch)
tree43d5227691d8fef3eb49570e3a763fb65f060bc8
downloadaur-83f35937edad26c778c9168e89ec706571549ef9.tar.gz
Append first version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0bc7a3ca156d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = opensmtpd-filter-replace-from_reply
+ pkgdesc = This is a simple OpenSMTPD filter for overwriting the email address in the MAIL FROM command, in the header in all sent messages, as well as for substituting the original MAIL FROM address in the Reply-To field
+ pkgver = 1.0.0
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ depends = glibc
+ source = https://github.com/Genues/opensmtpd-filter-replace-from_reply/archive/main.zip
+ sha512sums = SKIP
+
+pkgname = opensmtpd-filter-replace-from_reply
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c90e7ca2a97
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Evgeniy <genues@gmail.com>
+pkgname=opensmtpd-filter-replace-from_reply
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='This is a simple OpenSMTPD filter for overwriting the email address in the MAIL FROM command, in the header in all sent messages, as well as for substituting the original MAIL FROM address in the Reply-To field'
+license=("MIT")
+arch=(i686 x86_64)
+depends=(glibc)
+makedepends=(go)
+source=('https://github.com/Genues/opensmtpd-filter-replace-from_reply/archive/main.zip')
+sha512sums=('SKIP')
+
+build() {
+cd "$_pkgname-$pkgver"
+go build -buildmode pie -ldflags "-extldflags $LDFLAGS" -trimpath "$_pkgname.go"
+}
+
+package() {
+cd "$_pkgname-$pkgver"
+
+install -D filter-senderscore -t "$pkgdir"/usr/lib/smtpd/opensmtpd
+install -Dm644 README.md -t "$pkgdir"/usr/share/doc/$pkgname
+install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
+} \ No newline at end of file