summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2023-11-11 19:51:57 +0100
committerbartus2023-11-11 19:51:57 +0100
commit83f746862dbbb5dea197b569f0670767cc0c609e (patch)
tree44a4111af4d6dba0fbd91ae18b0c66c401540f89
parent019d8a8fb59cb6c8d1e763e67cbdada9de75db1d (diff)
downloadaur-83f746862dbbb5dea197b569f0670767cc0c609e.tar.gz
Refactor PKGBUILD.in script: expose deps ver
-rw-r--r--PKGBUILD.in26
1 files changed, 20 insertions, 6 deletions
diff --git a/PKGBUILD.in b/PKGBUILD.in
index 11eb97429fa1..d8659100c31b 100644
--- a/PKGBUILD.in
+++ b/PKGBUILD.in
@@ -15,12 +15,26 @@ pkgdesc="Graph based image processing framework"
arch=('i686' 'x86_64')
url="https://www.gegl.org"
license=('GPL3' 'LGPL3')
-depends=('babl>=@_babl_version@' 'libspiro' 'json-glib' 'sdl2') #'mrg'
-makedepends=('git' 'meson' 'intltool' 'python' 'ruby' 'luajit'
- 'libraw' 'openexr' 'ffmpeg' 'librsvg' 'jasper'
- 'libtiff' 'libnsgif' 'exiv2' 'libgexiv2' 'lensfun'
- 'vala' 'python-gobject'
- 'suitesparse' 'gobject-introspection')
+depends=('babl>=@_babl_version@'
+ 'libspiro>=@_libspiro_version@'
+ 'json-glib>=@_json-glib_version@'
+ 'sdl2>=@_sdl2_version@') #'mrg'
+makedepends=('git' 'meson' 'intltool' 'python' 'ruby'
+ 'luajit>=@_luajit_version@'
+ 'libraw>=@_libraw_version@'
+ 'openexr>=@_openexr_version@'
+ 'ffmpeg'
+ 'librsvg>=@_librsvg_version@'
+ 'jasper>=@_jasper_version@'
+ 'libtiff>=@_libtiff_version@'
+ 'libnsgif'
+ 'exiv2'
+ 'libgexiv2>=@_gexiv2_version@'
+ 'lensfun>=@_lensfun_version@'
+ 'vala'
+ 'python-gobject>=@_pygobject_version@'
+ 'suitesparse'
+ 'gobject-introspection')
optdepends=('openexr: for using the openexr plugin'
'ffmpeg: for using the ffmpeg plugin'
'librsvg: for using the svg plugin'