summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuan Simon2020-01-25 11:24:59 +0100
committerJuan Simon2020-01-25 11:24:59 +0100
commit8409c4706542cda591b435faed432b010f5833e9 (patch)
treed68e6efc91c7d011187388047a8b979e5bac5d6e
parent193c93cab7af7bc6218a742112d5221e701d382e (diff)
downloadaur-8409c4706542cda591b435faed432b010f5833e9.tar.gz
Update version 8.048.00
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--kernel-5.4.patch12
3 files changed, 9 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e6cd25d449c..b350b8c642c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = r8168-dkms
pkgdesc = A kernel module for Realtek 8168 network cards
- pkgver = 8.047.05
- pkgrel = 2
+ pkgver = 8.048.00
+ pkgrel = 1
url = https://github.com/mtorromeo/r8168
install = r8168-dkms.install
arch = i686
@@ -13,12 +13,10 @@ pkgbase = r8168-dkms
optdepends = linux-lts-headers: Needed for build the module for LTS Arch kernel
optdepends = linux-zen-headers: Needed for build the module for ZEN Arch kernel
conflicts = r8168
- source = https://github.com/mtorromeo/r8168/archive/8.047.05/r8168-dkms-8.047.05.tar.gz
+ source = https://github.com/mtorromeo/r8168/archive/8.048.00/r8168-dkms-8.048.00.tar.gz
source = dkms.conf
- source = kernel-5.4.patch
- sha256sums = 1344bf3d8a1d01a1be8805b48940be1b946b5e694ca75bd14ed1c76fd4c3d67b
+ sha256sums = 0aacba20d985ba5e67e21bdad89a099e102f7bef3027adb647ffbb80b01ac8d0
sha256sums = e33abcbc8fbe3129459ebc60be3b2f8ed55ddc53755f4956d6feb16c61c43250
- sha256sums = be79c151c6323bb4d340e31e44fae25a36a93d317812fe5d75c54649ed2508b0
pkgname = r8168-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 90ecc6298dff..7c1363eceab3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: angelsl
_pkgbase=r8168
pkgname=${_pkgbase}-dkms
-pkgver=8.047.05
-pkgrel=2
+pkgver=8.048.00
+pkgrel=1
pkgdesc="A kernel module for Realtek 8168 network cards"
url="https://github.com/mtorromeo/r8168"
license=("GPL")
@@ -15,16 +15,9 @@ optdepends=('linux-headers: Needed for build the module for Arch kernel'
'linux-lts-headers: Needed for build the module for LTS Arch kernel'
'linux-zen-headers: Needed for build the module for ZEN Arch kernel')
source=(https://github.com/mtorromeo/r8168/archive/$pkgver/$pkgname-$pkgver.tar.gz
- dkms.conf
- kernel-5.4.patch)
+ dkms.conf)
install=r8168-dkms.install
-prepare() {
- cd "r8168-$pkgver"
- patch -Np1 -i "${srcdir}/kernel-5.4.patch"
-}
-
-
package() {
install -Dm644 dkms.conf "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/dkms.conf"
@@ -36,6 +29,5 @@ package() {
rm src/Makefile_linux24x
cp -dr --no-preserve='ownership' src "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/src"
}
-sha256sums=('1344bf3d8a1d01a1be8805b48940be1b946b5e694ca75bd14ed1c76fd4c3d67b'
- 'e33abcbc8fbe3129459ebc60be3b2f8ed55ddc53755f4956d6feb16c61c43250'
- 'be79c151c6323bb4d340e31e44fae25a36a93d317812fe5d75c54649ed2508b0')
+sha256sums=('0aacba20d985ba5e67e21bdad89a099e102f7bef3027adb647ffbb80b01ac8d0'
+ 'e33abcbc8fbe3129459ebc60be3b2f8ed55ddc53755f4956d6feb16c61c43250')
diff --git a/kernel-5.4.patch b/kernel-5.4.patch
deleted file mode 100644
index f59265e8bc97..000000000000
--- a/kernel-5.4.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -u -r r8168-8.047.05/src/r8168_n.c r8168-8.047.05-5.4/src/r8168_n.c
---- r8168-8.047.05/src/r8168_n.c 2019-11-25 18:01:38.000000000 +0000
-+++ r8168-8.047.05-5.4/src/r8168_n.c 2019-11-25 23:36:15.427988367 +0000
-@@ -56,7 +56,7 @@
- #include <linux/rtnetlink.h>
- #include <linux/completion.h>
-
--#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,26)
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,26) && LINUX_VERSION_CODE < KERNEL_VERSION(5,4,0)
- #include <linux/pci-aspm.h>
- #endif
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,4,37)