summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchrisjbillington2020-02-06 14:43:06 -0500
committerchrisjbillington2020-02-06 14:43:06 -0500
commit842e6cd05e931e1a54a5c99838b60d7a1901e057 (patch)
tree78dd1e419185d669a58c18fae601ec67cf435733
downloadaur-842e6cd05e931e1a54a5c99838b60d7a1901e057.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..950e2b6585ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-mercurial
+ pkgdesc = Mercurial for python 3 - python modules only
+ pkgver = 5.3
+ pkgrel = 0
+ url = https://www.mercurial-scm.org/
+ arch = x86_64
+ license = GPL
+ depends = python
+ provides = mercurial=5.3
+ source = https://www.mercurial-scm.org/release/mercurial-5.3.tar.gz
+ sha256sums = e57ff61d6b67695149dd451922b40aa455ab02e01711806a131a1e95c544f9b9
+
+pkgname = python-mercurial
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7110dc6cca58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Chris Billington <chrisjbillington@gmail.com>
+pkgname=python-mercurial
+_pkgname=mercurial
+pkgver=5.3
+pkgrel=0
+pkgdesc='Mercurial for python 3 - python modules only'
+arch=(x86_64)
+url="https://www.mercurial-scm.org/"
+license=(GPL)
+provides=(mercurial=$pkgver)
+depends=(python)
+source=(https://www.mercurial-scm.org/release/${_pkgname}-${pkgver}.tar.gz)
+sha256sums=('e57ff61d6b67695149dd451922b40aa455ab02e01711806a131a1e95c544f9b9')
+
+package() {
+ cd $_pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+ rm -rf "$pkgdir"/usr/bin
+}