summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2015-10-04 10:19:09 +0200
committerValHue2015-10-04 10:19:09 +0200
commit8446029aaf3bb51654b0ca83eea29d085475ae16 (patch)
tree1e79768aead9ceba5a949cad1861f420d0ec8c47
downloadaur-8446029aaf3bb51654b0ca83eea29d085475ae16.tar.gz
Adopted, intial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e223afb9af6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = imagination
+ pkgdesc = Imagination is a lightweight and simple DVD slideshow maker in GTK+2.
+ pkgver = 3.0
+ pkgrel = 4
+ url = http://imagination.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = docbook-xsl
+ depends = gtk2
+ depends = ffmpeg
+ depends = sox
+ provides = imagination
+ source = http://downloads.sourceforge.net/imagination/imagination-3.0.tar.gz
+ sha256sums = 417d8586d9c85109b87d30b9c196d63531a637cbc2ffb3c12b48a873bfcb4b1e
+
+pkgname = imagination
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c7a14d51ca2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+# https://github.com/ValHue/AUR-PKGBUILDs
+#
+# Contributor: Asa Marco <marcoasa90[at]gmail[dot]com>
+#
+pkgname="imagination"
+pkgver="3.0"
+pkgrel="4"
+pkgdesc="Imagination is a lightweight and simple DVD slideshow maker in GTK+2."
+arch=('i686' 'x86_64')
+url="http://imagination.sourceforge.net/"
+license=('GPL')
+depends=('gtk2' 'ffmpeg' 'sox')
+makedepends=('intltool' 'docbook-xsl')
+provides=('imagination')
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz)
+sha256sums=('417d8586d9c85109b87d30b9c196d63531a637cbc2ffb3c12b48a873bfcb4b1e')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ sed -i 's/PLUGINS_INSTALLED 0/PLUGINS_INSTALLED 1/g' src/support.h
+ LDFLAGS="-lm -lgmodule-2.0" ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=4 sw=2 ft=sh et: