summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2022-10-04 14:10:04 +0200
committerKlaus Alexander Seistrup2022-10-04 14:10:04 +0200
commit844e00df5e5aee9dea73475344f174ed2b5b60ee (patch)
tree7448dd526f1768836bc4abd5c4a515ac0e4fb41c
downloadaur-844e00df5e5aee9dea73475344f174ed2b5b60ee.tar.gz
Initial AUR commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e276083e3bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = filenote-git
+ pkgdesc = Attach a comment to a file or directory (development version)
+ pkgver = r39.315f06c
+ pkgrel = 1
+ url = https://codeberg.org/kas/filenote
+ arch = any
+ license = GPL3
+ depends = python
+ provides = filenote
+ conflicts = filenote
+ source = git+https://codeberg.org/kas/filenote
+ sha256sums = SKIP
+
+pkgname = filenote-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..737c02076e79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Klaus Alexander Seistrup <klaus@seistrup.dk>
+# -*- sh -*-
+
+pkgname='filenote-git'
+_pkgname="${pkgname%-git}"
+pkgver=r39.315f06c
+pkgrel=1
+pkgdesc='Attach a comment to a file or directory (development version)'
+arch=('any')
+url='https://codeberg.org/kas/filenote'
+license=('GPL3')
+depends=('python')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname" || exit 1
+
+ # See https://wiki.archlinux.org/title/VCS_package_guidelines
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname" || exit 1
+
+ make "DESTDIR=$pkgdir" "PREFIX=/usr" install
+
+ install -Dm0644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}
+
+# eof