summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Silva2022-07-17 12:59:24 +0100
committerRafael Silva2022-07-17 12:59:24 +0100
commit844f9c11dca0f1f2c10312c0c9a748dee6bfb4a8 (patch)
tree95d3b16000ce97ebb36877d9f96fad640241d2f8
parent40a0ba5134f9b1f9da4f5cae71262c7ed3cb951b (diff)
downloadaur-844f9c11dca0f1f2c10312c0c9a748dee6bfb4a8.tar.gz
wxWidgets 3.2
Signed-off-by: Rafael Silva <perigoso@riseup.net>
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--PKGBUILD.in4
3 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2601550088e8..1f85f21f7454 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,7 +14,7 @@ pkgbase = kicad-nightly
makedepends = ninja
makedepends = tar
makedepends = gzip
- depends = wxgtk3
+ depends = wxwidgets-gtk3
depends = python
depends = boost-libs
depends = glew
diff --git a/PKGBUILD b/PKGBUILD
index b9553c0f6f6e..ad73e43a9266 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgdesc='Electronic schematic and printed circuit board (PCB) design tools'
arch=('x86_64')
url='http://kicad.org/'
license=('GPL')
-depends=('wxgtk3' 'python' 'boost-libs' 'glew' 'curl' 'glm' 'ngspice' 'opencascade' 'python-wxpython')
+depends=('wxwidgets-gtk3' 'python' 'boost-libs' 'glew' 'curl' 'glm' 'ngspice' 'opencascade' 'python-wxpython')
makedepends=('git' 'cmake' 'zlib' 'mesa' 'boost' 'swig' 'ninja' 'tar' 'gzip')
options=('!strip')
optdepends=(
@@ -52,10 +52,10 @@ build()
-DCMAKE_INSTALL_LIBDIR=/usr/lib/kicad-nightly/lib \
-DCMAKE_EXECUTABLE_SUFFIX=-nightly \
-DKICAD_USE_OCC=ON \
+ -DKICAD_USE_EGL=ON \
-DKICAD_SCRIPTING_WXPYTHON=ON \
-DKICAD_BUILD_I18N=ON \
-DKICAD_DATA=/usr/share/kicad-nightly \
- -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 \
-Wno-dev
ninja
}
diff --git a/PKGBUILD.in b/PKGBUILD.in
index 1e5dad0ba18e..f6b82ae69195 100644
--- a/PKGBUILD.in
+++ b/PKGBUILD.in
@@ -8,7 +8,7 @@ pkgdesc='Electronic schematic and printed circuit board (PCB) design tools'
arch=('x86_64')
url='http://kicad.org/'
license=('GPL')
-depends=('wxgtk3' 'python' 'boost-libs' 'glew' 'curl' 'glm' 'ngspice' 'opencascade' 'python-wxpython')
+depends=('wxwidgets-gtk3' 'python' 'boost-libs' 'glew' 'curl' 'glm' 'ngspice' 'opencascade' 'python-wxpython')
makedepends=('git' 'cmake' 'zlib' 'mesa' 'boost' 'swig' 'ninja' 'tar' 'gzip')
options=('!strip')
optdepends=(
@@ -52,10 +52,10 @@ build()
-DCMAKE_INSTALL_LIBDIR=/usr/lib/kicad-nightly/lib \
-DCMAKE_EXECUTABLE_SUFFIX=-nightly \
-DKICAD_USE_OCC=ON \
+ -DKICAD_USE_EGL=ON \
-DKICAD_SCRIPTING_WXPYTHON=ON \
-DKICAD_BUILD_I18N=ON \
-DKICAD_DATA=/usr/share/kicad-nightly \
- -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 \
-Wno-dev
ninja
}