summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-02-01 09:39:45 +0000
committerAntonio Rojas2020-02-01 09:39:45 +0000
commit8453ea545cb1960015aa2d857277b97c39d272fa (patch)
tree1abf4d0d643e095595bcf3678991f638fc779e1a
downloadaur-8453ea545cb1960015aa2d857277b97c39d272fa.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
-rw-r--r--gemrb.install17
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03702ab80db9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gemrb
+ pkgdesc = OSS implementation of Bioware's Infinity Engine which supports eg. Baldur's Gate
+ pkgver = 0.8.6
+ pkgrel = 1
+ url = http://www.gemrb.org/
+ install = gemrb.install
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = python2
+ depends = sdl2
+ depends = sdl2_mixer
+ depends = openal
+ depends = hicolor-icon-theme
+ depends = libpng
+ depends = freetype2
+ source = https://downloads.sourceforge.net/sourceforge/gemrb/gemrb-0.8.6.tar.gz
+ sha1sums = 251885fdc831ca59bfdad92cce0f204d0070afbb
+
+pkgname = gemrb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..090a43233290
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+pkgname=gemrb
+pkgver=0.8.6
+pkgrel=1
+pkgdesc="OSS implementation of Bioware's Infinity Engine which supports eg. Baldur's Gate"
+arch=('x86_64')
+url="http://www.gemrb.org/"
+license=('GPL')
+depends=('python2' 'sdl2' 'sdl2_mixer' 'openal' 'hicolor-icon-theme' 'libpng' 'freetype2')
+makedepends=('cmake')
+install=gemrb.install
+source=("https://downloads.sourceforge.net/sourceforge/gemrb/$pkgname-$pkgver.tar.gz")
+sha1sums=('251885fdc831ca59bfdad92cce0f204d0070afbb')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ cmake ../$pkgname-$pkgver \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}
+
diff --git a/gemrb.install b/gemrb.install
new file mode 100644
index 000000000000..624a31fc7e74
--- /dev/null
+++ b/gemrb.install
@@ -0,0 +1,17 @@
+post_install() {
+ cat << EOF
+
+Installing the games
+--------------------
+ 1. Install the game(s) (eg using wine or Unshield)
+ 2. Copy /etc/gemrb/GemRB.cfg.sample to ~/.gemrb/gemrb.cfg or to /etc/gemrb/gemrb.cfg
+ 3. Edit gemrb.cfg, mainly to set up the path to the game's data files. It is crucial to get this right.
+ 4. Now You can start the game by executing "gemrb" at the command line prompt
+
+EOF
+}
+
+post_remove() {
+ echo "Don't forget to remove game data files."
+}
+