summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Spradling2015-06-09 22:43:11 -0400
committerMichael Spradling2015-06-09 22:43:11 -0400
commit847a85441515a8c57aeb5ec06f1d3595789dd5a0 (patch)
treec51ac6302c321a4821c9515153c54130a0c98baf
downloadaur-847a85441515a8c57aeb5ec06f1d3595789dd5a0.tar.gz
aur4 inital commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD16
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe2b2ed0e899
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-easyprocess
+ pkgdesc = EasyProcess is an easy to use python subprocess interface.
+ pkgver = 0.1.6
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/EasyProcess
+ arch = any
+ license = BSD
+ depends = python>=3.2
+ depends = python-setuptools
+ source = https://pypi.python.org/packages/source/E/EasyProcess/EasyProcess-0.1.6.tar.gz
+ md5sums = 8719886c7962bfea97a7d82fccd657a9
+
+pkgname = python-easyprocess
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63ddb5e4f417
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Michael Spradling <mike@mspradling.com>
+pkgname=python-easyprocess
+pkgver=0.1.6
+pkgrel=1
+pkgdesc="EasyProcess is an easy to use python subprocess interface."
+arch=(any)
+url="https://pypi.python.org/pypi/EasyProcess"
+license=('BSD')
+depends=('python>=3.2' 'python-setuptools')
+source=(https://pypi.python.org/packages/source/E/EasyProcess/EasyProcess-${pkgver}.tar.gz)
+md5sums=('8719886c7962bfea97a7d82fccd657a9')
+
+build() {
+cd "${srcdir}/EasyProcess-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 || exit 1
+}