summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2021-12-23 09:06:07 +0100
committerhaawda2021-12-23 09:06:07 +0100
commit84c60af175fa98c40a4f0af8031010d90965adf3 (patch)
tree113e74e05f12c7447dd8decb3b7af8deebdf97e6
parent31435fd9237a28a510ce5c517de484603a4516bf (diff)
downloadaur-84c60af175fa98c40a4f0af8031010d90965adf3.tar.gz
decouple plugin download
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--aiksaurus-plugin.m446
-rw-r--r--command-plugin.m447
4 files changed, 99 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c7cbf653d1e..22744678b00b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = abiword-git
pkgdesc = Fully-featured word processor from official gnome gitlab mirror
- pkgver = 3.1.0.20711.857cd86de
+ pkgver = 3.1.0.20713.7f124ca95
pkgrel = 1
epoch = 1
url = http://www.abisource.com
@@ -33,8 +33,8 @@ pkgbase = abiword-git
conflicts = abiword
conflicts = abiword-plugins
source = git+https://gitlab.gnome.org/World/AbiWord.git
- source = aiksaurus-plugin.m4::https://git.archlinux.org/svntogit/packages.git/plain/trunk/aiksaurus-plugin.m4?h=packages/abiword
- source = command-plugin.m4::https://git.archlinux.org/svntogit/packages.git/plain/trunk/command-plugin.m4?h=packages/abiword
+ source = aiksaurus-plugin.m4
+ source = command-plugin.m4
source = null.patch
sha256sums = SKIP
sha256sums = 5f80a2f94f9929cdba9809c5e1a87cd5d537a2518bb879bfb9eab51a71c8dac1
diff --git a/PKGBUILD b/PKGBUILD
index 6c2c232504b0..862018bd03a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=abiword-git
-pkgver=3.1.0.20711.857cd86de
+pkgver=3.1.0.20713.7f124ca95
pkgrel=1
epoch=1
pkgdesc="Fully-featured word processor from official gnome gitlab mirror"
@@ -18,8 +18,8 @@ makedepends=('git' 'asio' 'boost' 'gobject-introspection' 'python2' 'libwpd' 'au
provides=('abiword' 'abiword-plugins')
conflicts=('abiword' 'abiword-plugins')
source=("git+https://gitlab.gnome.org/World/AbiWord.git"
- 'aiksaurus-plugin.m4::https://git.archlinux.org/svntogit/packages.git/plain/trunk/aiksaurus-plugin.m4?h=packages/abiword'
- 'command-plugin.m4::https://git.archlinux.org/svntogit/packages.git/plain/trunk/command-plugin.m4?h=packages/abiword' null.patch)
+ 'aiksaurus-plugin.m4'
+ 'command-plugin.m4' null.patch)
sha256sums=('SKIP'
'5f80a2f94f9929cdba9809c5e1a87cd5d537a2518bb879bfb9eab51a71c8dac1'
'2f26826e9d59d80dacd0dae4aceb815804eaa75954e47507a0897794f33e45be'
diff --git a/aiksaurus-plugin.m4 b/aiksaurus-plugin.m4
new file mode 100644
index 000000000000..c70a00383656
--- /dev/null
+++ b/aiksaurus-plugin.m4
@@ -0,0 +1,46 @@
+
+aiksaurus_pkgs="aiksaurus-1.0"
+aiksaurus_gtk_pkgs="aiksaurusgtk3-1.0"
+aiksaurus_deps="no"
+
+if test "$enable_aiksaurus" != ""; then
+
+PKG_CHECK_EXISTS([ $aiksaurus_pkgs ],
+[
+ aiksaurus_deps="yes"
+], [
+ test "$enable_aiksaurus" = "auto" && AC_MSG_WARN([aiksaurus plugin: dependencies not satisfied - $aiksaurus_pkgs])
+])
+
+fi
+
+if test "$enable_aiksaurus" = "yes" || \
+ test "$aiksaurus_deps" = "yes"; then
+
+use_builtin_aiksaurus_gtk="no"
+if test "$TOOLKIT" = "gtk"; then
+PKG_CHECK_EXISTS([ $aiksaurus_gtk_pkgs ],
+[
+ aiksaurus_pkgs="$aiksaurus_pkgs $aiksaurus_gtk_pkgs"
+], [use_builtin_aiksaurus_gtk="yes"])
+fi
+
+if test "$enable_aiksaurus_builtin" = "yes"; then
+AC_MSG_ERROR([aiksaurus plugin: static linking not supported])
+fi
+
+PKG_CHECK_MODULES(AIKSAURUS,[ $aiksaurus_pkgs ])
+
+
+test "$enable_aiksaurus" = "auto" && PLUGINS="$PLUGINS aiksaurus"
+
+AIKSAURUS_CFLAGS="$AIKSAURUS_CFLAGS "'${PLUGIN_CFLAGS}'
+AIKSAURUS_LIBS="$AIKSAURUS_LIBS "'${PLUGIN_LIBS}'
+
+fi
+
+AM_CONDITIONAL([WITH_BUILTIN_AIKSAURUS_GTK],[ test "x$use_builtin_aiksaurus_gtk" = "xyes" ])
+
+AC_SUBST([AIKSAURUS_CFLAGS])
+AC_SUBST([AIKSAURUS_LIBS])
+
diff --git a/command-plugin.m4 b/command-plugin.m4
new file mode 100644
index 000000000000..dd010adf6dd9
--- /dev/null
+++ b/command-plugin.m4
@@ -0,0 +1,47 @@
+command_deps="no"
+
+if test "$enable_command" != ""; then
+ if test "$TOOLKIT" != "gtk"; then
+ command_deps="no"
+ AC_MSG_WARN([command plugin: only supported on UNIX/gtk platforms])
+ else
+ # stolen from the original plugin.m4 in abiword-plugins
+ AC_CHECK_HEADER(readline/readline.h,[
+ AC_CHECK_HEADER(readline/history.h,[
+ AC_CHECK_LIB(readline,readline,[
+ command_deps="yes"
+ ],[ AC_CHECK_LIB(readline,rl_initialize,[
+ command_deps="yes"
+
+ ],,)
+ ],)
+ ])
+ ])
+ fi
+fi
+
+if test "$enable_command" = "yes" || \
+ test "$command_deps" = "yes"; then
+
+if test "$enable_command_builtin" = "yes"; then
+AC_MSG_ERROR([command plugin: static linking not supported])
+fi
+
+AC_MSG_CHECKING([command plugin: for readline and friends])
+if test "$command_deps" != "yes"; then
+ AC_MSG_ERROR([no])
+else
+ AC_MSG_RESULT([yes])
+ COMMAND_LIBS="-lreadline -lhistory $COMMAND_LIBS"
+fi
+
+test "$enable_command" = "auto" && PLUGINS="$PLUGINS command"
+
+COMMAND_CFLAGS="$COMMAND_CFLAGS "'${PLUGIN_CFLAGS}'
+COMMAND_LIBS="$COMMAND_LIBS "'${PLUGIN_LIBS}'
+
+fi
+
+AC_SUBST([COMMAND_CFLAGS])
+AC_SUBST([COMMAND_LIBS])
+