summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkballen2020-01-06 17:21:19 +0000
committerkballen2020-01-06 17:21:19 +0000
commit84edbbde6b16910718f8001a2c115108601b51cc (patch)
tree9f75efca0dd1ccf0ef44863c4dad19fa25f27038
downloadaur-84edbbde6b16910718f8001a2c115108601b51cc.tar.gz
Initial version
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD52
-rw-r--r--xrdp-script.conf2
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c13f83bd784
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = pulseaudio-module-xrdp-git
+ pkgdesc = PulseAudio modules for xrdp
+ pkgver = 0.4.r4.ge9f78c4
+ pkgrel = 1
+ url = https://github.com/neutrinolabs/pulseaudio-module-xrdp
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ depends = pulseaudio
+ depends = xrdp
+ provides = pulseaudio-module-xrdp
+ conflicts = pulseaudio-module-xrdp
+ source = pulseaudio-module-xrdp-git::git+https://github.com/neutrinolabs/pulseaudio-module-xrdp.git#branch=devel
+ source = git+https://github.com/pulseaudio/pulseaudio.git
+ source = xrdp-script.conf
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 4c6e9c0b1eaf66ea6b8574570d89b292b8554d318ad324f3763f837013b9f44f
+
+pkgname = pulseaudio-module-xrdp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..820091e6ef68
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: kballen <ken@kballentine.net>
+
+pkgname=pulseaudio-module-xrdp-git
+pkgver=0.4.r4.ge9f78c4
+pkgrel=1
+pkgdesc="PulseAudio modules for xrdp"
+arch=('i686' 'x86_64')
+url="https://github.com/neutrinolabs/pulseaudio-module-xrdp"
+license=('Apache')
+depends=('pulseaudio' 'xrdp')
+makedepends=('git')
+conflicts=('pulseaudio-module-xrdp')
+provides=('pulseaudio-module-xrdp')
+
+source=("$pkgname::git+https://github.com/neutrinolabs/pulseaudio-module-xrdp.git#branch=devel"
+ "git+https://github.com/pulseaudio/pulseaudio.git"
+ "xrdp-script.conf")
+sha256sums=('SKIP'
+ 'SKIP'
+ '4c6e9c0b1eaf66ea6b8574570d89b292b8554d318ad324f3763f837013b9f44f')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags --long|sed -E 's,^[^0-9]*,,;s,([0-9]*-g),r\1,;s,-,.,g'
+}
+
+prepare() {
+ cd "$srcdir/pulseaudio"
+ git checkout v`pkg-config libpulse --modversion|sed 's/[^0-9.]*\([0-9.]*\).*/\1/'`
+ NOCONFIGURE=1 ./bootstrap.sh
+ ./configure
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./bootstrap
+ ./configure "PULSE_DIR=$srcdir/pulseaudio"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" install
+
+ # This package installs a global drop-in conf for pulseaudio.service to use the xrdp default.pa script instead of
+ # the script from the pulseaudio package. If your only desktop sessions will be via xrdp, this should be fine. But
+ # if you want to start local sessions too, this will prevent the real audio devices from being detected. If this is
+ # a problem for you, delete the drop-in conf file and roll your own solution for loading the xrdp modules for xrdp
+ # sessions only (maybe add PULSE_SCRIPT to the user systemd's environment in startwm.sh and create a drop-in for
+ # pulseaudio.service that adds PassEnvironment=PULSE_SCRIPT).
+ install -Dm644 "$srcdir"/xrdp-script.conf "$pkgdir"/usr/lib/systemd/user/pulseaudio.service.d/xrdp-script.conf
+}
diff --git a/xrdp-script.conf b/xrdp-script.conf
new file mode 100644
index 000000000000..beb893ab169f
--- /dev/null
+++ b/xrdp-script.conf
@@ -0,0 +1,2 @@
+[Service]
+Environment=PULSE_SCRIPT=/etc/xrdp/pulse/default.pa