summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Bernardoff2015-06-27 09:51:38 +0200
committerVincent Bernardoff2015-06-27 09:51:38 +0200
commit84f0f4d575a2620f328ea50816db835fc299ea08 (patch)
tree79f6c3849b22a2ac1b4343125a82d350ba1cdc91
downloadaur-84f0f4d575a2620f328ea50816db835fc299ea08.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD38
-rw-r--r--opam-git.install3
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e93f3ee202ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = opam-git
+ pkgdesc = OCaml Package Manager
+ pkgver = 1.1.0.484.g692cf53
+ pkgrel = 1
+ url = https://opam.ocaml.org
+ install = opam-git.install
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL
+ makedepends = git
+ makedepends = curl
+ depends = ocaml
+ depends = aspcud
+ provides = opam
+ conflicts = opam
+ source = opam-git::git+git://github.com/ocaml/opam
+ source = opam-git.install
+ md5sums = SKIP
+ md5sums = e26e35d3f858c0b5474b778821f9d2e8
+
+pkgname = opam-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a4b80bc1d88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Vincent Bernardoff <vb@luminar.eu.org>
+# Contributor: Raphaƫl Proust <raphlalou@gmail.com>
+
+pkgname=opam-git
+pkgver=1.1.0.484.g692cf53
+pkgrel=1
+pkgdesc="OCaml Package Manager"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://opam.ocaml.org"
+license=('GPL')
+depends=('ocaml' 'aspcud')
+makedepends=('git' 'curl')
+provides=('opam')
+conflicts=('opam')
+install='opam-git.install'
+source=("$pkgname"::'git+git://github.com/ocaml/opam' 'opam-git.install')
+md5sums=('SKIP'
+ 'e26e35d3f858c0b5474b778821f9d2e8')
+
+pkgver() {
+ cd "$pkgname"
+ local ver="$(git describe --always)"
+ printf "%s" "${ver//-/.}"
+}
+
+build() {
+ cd "$pkgname"
+ ./configure --prefix=/usr
+ make lib-ext -j 1
+ make -j 1
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/opam-git.install b/opam-git.install
new file mode 100644
index 000000000000..446f743299ca
--- /dev/null
+++ b/opam-git.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "You can now run 'opam init'"
+} \ No newline at end of file