summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Margiani2015-06-10 23:16:49 +0400
committerGabriel Margiani2015-06-10 23:16:49 +0400
commit850008abcc4c7634acda5bb6839e6311f3995b93 (patch)
treedbffd084b70c0ee213222efa2fa53d5b4830767e
downloadaur-850008abcc4c7634acda5bb6839e6311f3995b93.tar.gz
initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD61
-rw-r--r--changelog15
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ed4ac61fad7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = widelands-bzr
+ pkgdesc = A realtime strategy game with emphasis on economy and transport - development version
+ pkgver = r7282
+ pkgrel = 2
+ url = http://wl.widelands.org
+ changelog = changelog
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = bzr
+ makedepends = cmake
+ makedepends = python
+ makedepends = boost
+ depends = glew
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = sdl2_net
+ depends = sdl2_ttf
+ provides = widelands
+ conflicts = widelands
+ conflicts = widelands-data
+ source = changelog
+ sha1sums = SKIP
+
+pkgname = widelands-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6704740c79c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+#Maintainer: Gabriel Margiani (gamag) <gabriel _strange_curved_character_ margiani · ch>
+#Contributor: matthiaskrgr <matthias · krueger _strange_curved_character_ famsike · de>
+
+pkgname=widelands-bzr
+pkgver=r7282
+pkgrel=2
+pkgdesc="A realtime strategy game with emphasis on economy and transport - development version"
+arch=(i686 x86_64)
+license=('GPL2')
+depends=('glew' 'sdl2_image' 'sdl2_mixer' 'sdl2_net' 'sdl2_ttf')
+makedepends=('bzr' 'cmake' 'python' 'boost')
+provides=('widelands')
+conflicts=('widelands' 'widelands-data')
+url="http://wl.widelands.org"
+changelog=changelog
+source=("changelog")
+sha1sums=('SKIP')
+
+# HACK: Use Prepare to make a lightweight checkout, since it is a little faster
+# than a full branch, as pacman would do it. If you have a better solution,
+# just tell me.
+prepare() {
+ cd "$srcdir"
+
+ if test -d "$pkgname/.bzr"; then
+ cd "$pkgname"
+ msg2 "Updating bzr checkout"
+ bzr update
+ else
+ # don't use lp: to avoid bzr asking for ssh passphrase to authenticate
+ # on launchpad
+ msg2 "Making lightweight checkout. This may take some time."
+ bzr checkout --lightweight "http://bazaar.launchpad.net/~widelands-dev/widelands/trunk" "$pkgname"
+ fi
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+
+ test -d build/locale || mkdir -p build/locale
+ test -e locale || ln -s build/locale
+
+ cd build
+
+ msg2 "Running cmake..."
+ # if this failes on an existing build because of an mismatch of src and build cmake files, just delete build and try again.
+ cmake .. -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr/bin \
+ -DWL_INSTALL_DATADIR=/usr/share/widelands
+ msg2 "Running make..."
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname/build"
+ make DESTDIR="$pkgdir" install
+}
+
+pkgver() {
+ printf "r%s" "$(bzr revno "http://bazaar.launchpad.net/~widelands-dev/widelands/trunk" -q)"
+}
diff --git a/changelog b/changelog
new file mode 100644
index 000000000000..961351025dae
--- /dev/null
+++ b/changelog
@@ -0,0 +1,15 @@
+Version r7282-2
+ * Remove sdl2_gfx dependency.
+
+Version r7282-1
+ * Update to new path management in build system
+
+Version r7261-1
+ * Total rework to use pacmans bzr capabilities and new widelands-data
+ dependencies introduced/changed after build 18
+
+Version 6346-2
+ * we need to conflict with widelands-data as well, not only with widelands
+
+Version 6346
+ * Initial version