summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 23:28:35 -0600
committerBrian Bidulock2015-06-10 23:28:35 -0600
commit851bdc7cd62b5c294b20713bf065c62b7c1055a7 (patch)
tree703888b38e7274de5e8ee99560ce6dab22d985fc
downloadaur-851bdc7cd62b5c294b20713bf065c62b7c1055a7.tar.gz
initial version
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD58
-rw-r--r--xgalaga.desktop9
-rw-r--r--xgalaga.install7
-rw-r--r--xgalaga.patch72
-rw-r--r--xgalaga.pngbin0 -> 780 bytes
6 files changed, 168 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0cd42724f3dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = xgalaga
+ pkgdesc = An open source remake of the classic arcade game Galaga
+ pkgver = 2.1.1.0
+ pkgrel = 4
+ url = http://rumsey.org/xgal.html
+ install = xgalaga.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libxmu
+ depends = libxpm
+ source = http://downloads.sourceforge.net/xgalaga/xgalaga-2.1.1.0.tar.gz
+ source = xgalaga.patch
+ source = xgalaga.png
+ source = xgalaga.desktop
+ md5sums = f37c3377b245d2d53b33eb489966bf28
+ md5sums = f96b73645d1ebbb12d8b3de5d4ec94fc
+ md5sums = 3168c3fec9bd8345946ac93c6b9d7b32
+ md5sums = e8fbde4e6049202a087ebc7daf0f0170
+
+pkgname = xgalaga
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b754ba1d5378
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+
+pkgname=xgalaga
+pkgver=2.1.1.0
+pkgrel=4
+pkgdesc="An open source remake of the classic arcade game Galaga"
+arch=('i686' 'x86_64')
+url="http://rumsey.org/xgal.html"
+license=('GPL')
+depends=('libxmu' 'libxpm')
+install=$pkgname.install
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ $pkgname.patch
+ $pkgname.png
+ $pkgname.desktop)
+md5sums=('f37c3377b245d2d53b33eb489966bf28'
+ '6fef2b9aec46c0c4fe5055401c408ef7'
+ '3168c3fec9bd8345946ac93c6b9d7b32'
+ 'e8fbde4e6049202a087ebc7daf0f0170')
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ /usr/bin/cp -f /usr/share/automake-1.14/config.guess .
+ /usr/bin/cp -f /usr/share/automake-1.14/config.sub .
+
+ patch -Np2 -b -z .orig -i ../$pkgname.patch
+}
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ LDFLAGS='' ./configure \
+ --mandir=/usr/share/man \
+ --prefix=/usr/share/$pkgname \
+ --exec-prefix=/usr/bin \
+ --with-xpm-lib=/usr/lib
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ make DESTDIR="$pkgdir" \
+ mandir=/usr/share/man \
+ prefix=/usr/share/$pkgname \
+ exec_prefix=/usr/bin \
+ scoredir=/var/lib/$pkgname \
+ install
+
+ install -Dm644 "$srcdir"/$pkgname.png "$pkgdir"/usr/share/pixmaps/$pkgname.png
+ install -Dm644 "$srcdir"/$pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+ install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README
+}
+md5sums=('f37c3377b245d2d53b33eb489966bf28'
+ 'f96b73645d1ebbb12d8b3de5d4ec94fc'
+ '3168c3fec9bd8345946ac93c6b9d7b32'
+ 'e8fbde4e6049202a087ebc7daf0f0170')
diff --git a/xgalaga.desktop b/xgalaga.desktop
new file mode 100644
index 000000000000..c691b1150232
--- /dev/null
+++ b/xgalaga.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=XGalaga
+Comment=An open source remake of the classic arcade game Galaga
+Exec=xgalaga
+Icon=xgalaga
+Terminal=false
+Categories=Game;ArcadeGame;
diff --git a/xgalaga.install b/xgalaga.install
new file mode 100644
index 000000000000..abb81619e145
--- /dev/null
+++ b/xgalaga.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo "You need to be in the 'games' group to use the scores file"
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/xgalaga.patch b/xgalaga.patch
new file mode 100644
index 000000000000..8f1187becdb5
--- /dev/null
+++ b/xgalaga.patch
@@ -0,0 +1,72 @@
+diff -up src/xgalaga-2.1.1.0/defs.h.orig src/xgalaga-2.1.1.0/defs.h
+--- src/xgalaga-2.1.1.0/defs.h.orig 2008-03-05 14:58:16.000000000 -0700
++++ src/xgalaga-2.1.1.0/defs.h 2014-05-17 03:42:38.000000000 -0600
+@@ -3,6 +3,7 @@
+ /* Area for setting flags to enable changes by Bryce and Neelix */
+
+ /*#define ORIGINAL_XGALAGA */
++#define IM_A_BIG_FAT_CHEATER
+ /*#define IM_A_BIG_FAT_CHEATER*/
+
+ #ifndef ORIGINAL_XGALAGA
+@@ -15,9 +16,15 @@
+ # define NO_PRIZE_WHILE_DEAD
+ #endif
+
++#ifdef ORIGINAL_XGALAGA
+ #define MAXTORPS 10
+ #define MINTORPS 3
+ #define TORPSPEED 12
++#else
++#define MAXTORPS 16
++#define MINTORPS 3
++#define TORPSPEED 16
++#endif
+
+ #define ETORPSPEED 8
+
+diff -up src/xgalaga-2.1.1.0/main.c.orig src/xgalaga-2.1.1.0/main.c
+--- src/xgalaga-2.1.1.0/main.c.orig 2008-03-05 14:58:16.000000000 -0700
++++ src/xgalaga-2.1.1.0/main.c 2014-05-17 03:43:25.000000000 -0600
+@@ -1046,9 +1046,13 @@ int mx, my, but;
+ break;
+ case 't':
+ case 256+'t': //372:
+- maxtorps++;
+- if(maxtorps > MAXTORPS)
+- maxtorps = MINTORPS;
++ if (maxtorps < MAXTORPS)
++ maxtorps++;
++ break;
++ case 'z':
++ case 256+'z':
++ if (movespeed < MAXSPEED)
++ movespeed++;
+ break;
+ #endif /* IM_A_BIG_FAT_CHEATER */
+ case '\r'+256:
+diff -up src/xgalaga-2.1.1.0/Makefile.in.orig src/xgalaga-2.1.1.0/Makefile.in
+--- src/xgalaga-2.1.1.0/Makefile.in.orig 2008-03-05 14:58:16.000000000 -0700
++++ src/xgalaga-2.1.1.0/Makefile.in 2014-05-17 03:42:38.000000000 -0600
+@@ -15,8 +15,7 @@ exec_prefix = @exec_prefix@
+ bindir = $(exec_prefix)
+ libdir = $(prefix)/lib
+ infodir = $(prefix)/info
+-#mandir = @mandir@
+-mandir = /usr/share/man
++mandir = @mandir@
+ creditsfile = @CREDITSFILE@
+ distversion = 2.1.1.0
+
+@@ -65,8 +64,9 @@ install: all
+ for i in levels/*.xgl; do $(INSTALL) $$i $(DESTDIR)$(prefix)/$$i ; done
+ for i in sounds/*.raw; do $(INSTALL) $$i $(DESTDIR)$(prefix)/$$i ; done
+ $(INSTALL) CREDITS $(DESTDIR)$(creditsfile)
+- $(INSTALL) xgalaga.6x.gz $(mandir)/man6/xgalaga.6x.gz
+- chmod 644 $(mandir)/man6/xgalaga.6x.gz
++ ./mkinstalldirs $(DESTDIR)$(mandir)/man6
++ $(INSTALL) xgalaga.6x.gz $(DESTDIR)$(mandir)/man6/xgalaga.6x.gz
++ chmod 644 $(DESTDIR)$(mandir)/man6/xgalaga.6x.gz
+ # touch $(prefix)/scores
+ # chmod 666 $(prefix)/scores
+ # chown ${GAMEOWN}:${GAMEGRP} $(prefix)/scores
diff --git a/xgalaga.png b/xgalaga.png
new file mode 100644
index 000000000000..722a729bc79c
--- /dev/null
+++ b/xgalaga.png
Binary files differ