summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames P. Harvey2016-10-30 00:16:12 -0400
committerJames P. Harvey2016-10-30 00:16:12 -0400
commit852cf4b451c45d4a7305f2fa31d560ba74d55bd3 (patch)
treee5ee5e8e62312bd725b3fb6236a86f9b552b1b02
parentd6c890e4cb0f38bec096d6fade55aa186eaae486 (diff)
downloadaur-852cf4b451c45d4a7305f2fa31d560ba74d55bd3.tar.gz
Bumped pkgver. Updated maintainer's default arch theme. New symbols are more intuitive (to me anyway.) Staged files are pending, so ellipsis. Changed files represented by delta symbol. Untracked files represented by the exists symbol. Stashed files represented by a question mark, since their future is somewhat unknown. Also noted .install file for how to change a ~/.gitconfig to make 'git status' colors match the Default_Arch theme.
-rw-r--r--.SRCINFO8
-rw-r--r--Default_Arch.bgptheme9
-rw-r--r--PKGBUILD6
-rw-r--r--bash-git-prompt.install12
4 files changed, 25 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 725b8938b65e..92a6bb5f31fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Aug 18 00:57:05 UTC 2016
+# Sun Oct 30 04:15:43 UTC 2016
pkgbase = bash-git-prompt-git
pkgdesc = Informative git prompt for bash and fish (git version)
- pkgver = 2.5.1.r484.33c19b2
+ pkgver = 2.6.1.r506.9af8824
pkgrel = 1
url = https://github.com/magicmonty/bash-git-prompt
install = bash-git-prompt.install
@@ -17,8 +17,8 @@ pkgbase = bash-git-prompt-git
source = bash-git-prompt.install
source = Default_Arch.bgptheme
md5sums = SKIP
- md5sums = db6f83999124b7fa660310a8d6624f70
- md5sums = 879555792d1b4c0ddef7cd81b0a3e35c
+ md5sums = 990d3a7ef8a21b83f0d1e90d9ef1a5b7
+ md5sums = af064330b3a579ec6efd2e018e6829df
pkgname = bash-git-prompt-git
diff --git a/Default_Arch.bgptheme b/Default_Arch.bgptheme
index cafb7f846a1e..cbd8861f9ba2 100644
--- a/Default_Arch.bgptheme
+++ b/Default_Arch.bgptheme
@@ -4,9 +4,12 @@
override_git_prompt_colors() {
GIT_PROMPT_THEME_NAME="Default Arch"
- GIT_PROMPT_CONFLICTS="${Red}✖"
- GIT_PROMPT_CHANGED="${Blue}✚"
- GIT_PROMPT_STASHED="${BoldBlue}⚑"
+ GIT_PROMPT_SEPARATOR=" "
+ GIT_PROMPT_STAGED="${Green}…"
+ GIT_PROMPT_CONFLICTS="${Yellow}✘"
+ GIT_PROMPT_CHANGED="${Red}Δ"
+ GIT_PROMPT_UNTRACKED="${Cyan}∃"
+ GIT_PROMPT_STASHED="${BoldBlack}?"
GIT_PROMPT_SYMBOLS_AHEAD="↑"
GIT_PROMPT_SYMBOLS_BEHIND="↓"
GIT_PROMPT_END_USER=" \n${White}[\u@\h] ${Time12a}${ResetColor} $ "
diff --git a/PKGBUILD b/PKGBUILD
index 3b7ed25cca7c..a70031dc1c91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=bash-git-prompt-git
_pkgname=bash-git-prompt
-pkgver=2.5.1.r484.33c19b2
+pkgver=2.6.1.r506.9af8824
pkgrel=1
pkgdesc="Informative git prompt for bash and fish (git version)"
arch=('any')
@@ -19,8 +19,8 @@ source=("git+https://github.com/magicmonty/${_pkgname}"
'bash-git-prompt.install'
'Default_Arch.bgptheme')
md5sums=('SKIP'
- 'db6f83999124b7fa660310a8d6624f70'
- '879555792d1b4c0ddef7cd81b0a3e35c')
+ '990d3a7ef8a21b83f0d1e90d9ef1a5b7'
+ 'af064330b3a579ec6efd2e018e6829df')
install='bash-git-prompt.install'
pkgver() {
diff --git a/bash-git-prompt.install b/bash-git-prompt.install
index ef7e4ffecdf1..33c1e85df7cc 100644
--- a/bash-git-prompt.install
+++ b/bash-git-prompt.install
@@ -13,6 +13,18 @@ post_install() {
GIT_PROMPT_THEME=Default_Arch
source /usr/lib/bash-git-prompt/gitprompt.sh
fi
+
+ NOTE: To have the colors shown by 'git status' match the Default_Arch theme,
+ add the following to your ~/.gitconfig:
+
+ [color "status"]
+ branch = magenta
+ untracked = cyan
+ unmerged = yellow
+
+ And if you want boilerplate to be less prominent, also:
+
+ header = bold black
"
}