summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Dejonckheere2016-07-29 16:04:59 +0200
committerFlorian Dejonckheere2016-07-29 16:04:59 +0200
commit856ce9792ab81c7cc681d43c91aeb25668fab52b (patch)
tree86372d32218ef254cfbe1a1e4fc5740bcf175bb9
parent7ea9c2b83b9ae9ad53602bec9641126b8661a29b (diff)
downloadaur-856ce9792ab81c7cc681d43c91aeb25668fab52b.tar.gz
Update optdepends
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD47
2 files changed, 33 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68c5e6bb77ab..aa0bfb36d941 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,25 @@
# Generated by mksrcinfo v8
-# Wed Mar 16 22:07:56 UTC 2016
+# Fri Jul 29 14:04:49 UTC 2016
pkgbase = zsh-theme-powerlevel9k-git
pkgdesc = Powerlevel9k theme for zsh
pkgver = v0.3.1.r10.g2630526
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/bhilburn/powerlevel9k
install = zsh-theme-powerlevel9k.install
arch = any
license = custom
makedepends = git
depends = zsh
+ optdepends = powerline-fonts: patched fonts for powerline
optdepends = oh-my-zsh-git: oh-my-zsh integration
optdepends = prezto-git: Prezto integration
optdepends = antigen-git: Antigen integration
optdepends = zpm: ZPM integration
optdepends = zsh-zim-git: Zim integration
+ optdepends = awesome-terminal-fonts: icon package
+ optdepends = acpi: battery monitoring
+ optdepends = git: status of repository
+ optdepends = mercurial: status of repository
provides = zsh-theme-powerlevel9k
conflicts = zsh-theme-powerlevel9k
source = powerlevel9k::git+https://github.com/bhilburn/powerlevel9k.git
diff --git a/PKGBUILD b/PKGBUILD
index 4b7a0bc77fd3..777e7f5bbb09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,22 @@
_pkgname=powerlevel9k
pkgname=zsh-theme-${_pkgname}-git
pkgver=v0.3.1.r10.g2630526
-pkgrel=2
+pkgrel=3
pkgdesc='Powerlevel9k theme for zsh'
arch=('any')
url='https://github.com/bhilburn/powerlevel9k'
license=('custom')
depends=('zsh')
-optdepends=('oh-my-zsh-git: oh-my-zsh integration'
- 'prezto-git: Prezto integration'
- 'antigen-git: Antigen integration'
- 'zpm: ZPM integration'
- 'zsh-zim-git: Zim integration')
+optdepends=('powerline-fonts: patched fonts for powerline'
+ 'oh-my-zsh-git: oh-my-zsh integration'
+ 'prezto-git: Prezto integration'
+ 'antigen-git: Antigen integration'
+ 'zpm: ZPM integration'
+ 'zsh-zim-git: Zim integration'
+ 'awesome-terminal-fonts: icon package'
+ 'acpi: battery monitoring'
+ 'git: status of repository'
+ 'mercurial: status of repository')
source=("${_pkgname}::git+https://github.com/bhilburn/${_pkgname}.git")
sha256sums=('SKIP')
makedepends=('git')
@@ -24,27 +29,27 @@ install="zsh-theme-${_pkgname}.install"
pkgver()
{
- cd "${srcdir}/${_pkgname}"
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${srcdir}/${_pkgname}"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package()
{
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/${_pkgname}"
- # No license
- # Install Readme as License in case in the future some type of license is added
- install -D -m644 README.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # No license
+ # Install Readme as License in case in the future some type of license is added
+ install -D -m644 README.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- # Install Documentation
- install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ # Install Documentation
+ install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
- # Install the theme
- install -D -m644 powerlevel9k.zsh-theme "${pkgdir}/usr/share/zsh-theme-${_pkgname}/${_pkgname}.zsh-theme"
+ # Install the theme
+ install -D -m644 powerlevel9k.zsh-theme "${pkgdir}/usr/share/zsh-theme-${_pkgname}/${_pkgname}.zsh-theme"
- # Install the utilities
- for FILE in functions/*.zsh; do
- install -D -m644 "${FILE}" "${pkgdir}/usr/share/zsh-theme-${_pkgname}/functions/$(basename ${FILE})"
- done
+ # Install the utilities
+ for FILE in functions/*.zsh; do
+ install -D -m644 "${FILE}" "${pkgdir}/usr/share/zsh-theme-${_pkgname}/functions/$(basename ${FILE})"
+ done
}