summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaizhao Zhang2022-02-18 13:57:17 +0000
committerKaizhao Zhang2022-02-18 13:58:19 +0000
commit85729c94541985d70816d681dfeee386a4dae125 (patch)
tree7cf2f220aef8280f10e06ab2ce9945ebed08382d
parentd98239fcbd61e4440edffb3f8e52c57f33f183c7 (diff)
downloadaur-85729c94541985d70816d681dfeee386a4dae125.tar.gz
Updated to version 98
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c558fddf2860..7bfc3e412477 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = zigmod
pkgdesc = A package manager for the Zig programming language
- pkgver = 90
+ pkgver = 98
pkgrel = 1
url = https://github.com/nektro/zigmod
arch = x86_64
license = MIT
makedepends = git
makedepends = zig
- source = zigmod-90.tar.gz::https://github.com/nektro/zigmod/archive/refs/tags/v90.tar.gz
+ source = zigmod-98.tar.gz::https://github.com/nektro/zigmod/archive/refs/tags/v98.tar.gz
source = https://github.com/yaml/libyaml/releases/download/0.2.5/yaml-0.2.5.tar.gz
- sha256sums = ace4625c2d95799f8caca84340f47dab3b5c9dca99c19d81b7c5887a0335fef1
+ sha256sums = d9695e3a83b56445aef14f3771329d173a599ced2a94dbc0c485ca7cf97611e1
sha256sums = c642ae9b75fee120b2d96c712538bd2cf283228d2337df2cf2988e3c02678ef4
pkgname = zigmod
diff --git a/PKGBUILD b/PKGBUILD
index b3f72d580630..277825f47335 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
libyaml_version=0.2.5
pkgname=zigmod
-pkgver=90
+pkgver=98
pkgrel=1
pkgdesc="A package manager for the Zig programming language"
url="https://github.com/nektro/zigmod"
@@ -15,7 +15,7 @@ source=(
"https://github.com/yaml/libyaml/releases/download/${libyaml_version}/yaml-${libyaml_version}.tar.gz"
)
sha256sums=(
- 'ace4625c2d95799f8caca84340f47dab3b5c9dca99c19d81b7c5887a0335fef1'
+ 'd9695e3a83b56445aef14f3771329d173a599ced2a94dbc0c485ca7cf97611e1'
'c642ae9b75fee120b2d96c712538bd2cf283228d2337df2cf2988e3c02678ef4'
)
@@ -24,7 +24,12 @@ prepare() {
rm -r libs/yaml
ln -s "${srcdir}/yaml-${libyaml_version}" libs/yaml
zig build -Dbootstrap
- ./zig-out/bin/zigmod fetch
+ # See https://github.com/nektro/zigmod/issues/57#issuecomment-1028442152
+ # > if you use `zigmod ci` instead of `zigmod fetch`
+ # > It will pull in a working version of the dependencies that `zig build` will succeed for
+ # and https://nektro.github.io/zigmod/commands/ci.html
+ #./zig-out/bin/zigmod fetch
+ ./zig-out/bin/zigmod ci
}
build() {