summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-06-09 16:27:09 -0600
committerMark Wagie2020-06-09 16:27:09 -0600
commit857e6d0148b260819134539b5a09202852d09911 (patch)
tree1bf9fb2616550868627579a79dbed7a0f3af073b
downloadaur-857e6d0148b260819134539b5a09202852d09911.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
-rw-r--r--sndcpy.sh4
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a1020cba91d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = sndcpy-bin
+ pkgdesc = Android audio forwarding (scrcpy, but for audio)
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/rom1v/sndcpy
+ arch = x86_64
+ license = MIT
+ depends = bash
+ depends = vlc
+ provides = sndcpy
+ conflicts = sndcpy
+ source = https://github.com/rom1v/sndcpy/releases/download/v1.0/sndcpy-v1.0.zip
+ source = https://github.com/rom1v/sndcpy/raw/v1.0/LICENSE
+ source = sndcpy.sh
+ sha256sums = 4495f752fc192535cd5208ace4d35d2ba644beb9aabb0e288ae339861ad6782b
+ sha256sums = 6b6d5219c4732200fdf483c5a9bde69867a1386b6278c176ce3598c32132e66d
+ sha256sums = 51eb4996dd266cd8e5e362d388982d250a285218642737c4464291de0808203e
+
+pkgname = sndcpy-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa1929b66ef7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=sndcpy-bin
+pkgver=1.0
+pkgrel=1
+pkgdesc="Android audio forwarding (scrcpy, but for audio)"
+arch=('x86_64')
+url="https://github.com/rom1v/sndcpy"
+license=('MIT')
+depends=('bash' 'vlc')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=("$url/releases/download/v$pkgver/${pkgname%-bin}-v$pkgver.zip"
+ "$url/raw/v$pkgver/LICENSE"
+ "${pkgname%-bin}.sh")
+sha256sums=('4495f752fc192535cd5208ace4d35d2ba644beb9aabb0e288ae339861ad6782b'
+ '6b6d5219c4732200fdf483c5a9bde69867a1386b6278c176ce3598c32132e66d'
+ '51eb4996dd266cd8e5e362d388982d250a285218642737c4464291de0808203e')
+
+package() {
+ install -Dm755 "${pkgname%-bin}" -t "$pkgdir/opt/${pkgname%-bin}"
+ install -Dm644 "${pkgname%-bin}.apk" -t "$pkgdir/opt/${pkgname%-bin}"
+ install -Dm755 "${pkgname%-bin}.sh" "$pkgdir/usr/bin/${pkgname%-bin}"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-bin}"
+}
diff --git a/sndcpy.sh b/sndcpy.sh
new file mode 100644
index 000000000000..2cb2d13c5c38
--- /dev/null
+++ b/sndcpy.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd /opt/sndcpy
+./sndcpy