summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoeny Ang2015-07-07 16:51:38 +0800
committerJoeny Ang2015-07-07 16:51:38 +0800
commit85b1523212701143eb8501376e1e823bd0e28353 (patch)
tree320fb5fc019f8e30978eac2f26e4a5720245331d
parent5f52b2b4afff37341a3eca602cbe0d92f9041273 (diff)
downloadaur-85b1523212701143eb8501376e1e823bd0e28353.tar.gz
PKGBUILD fixes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87f24fbfff70..4f740eb876fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ideviceinstaller-git
pkgdesc = Manage Applications of an iPhone or iPod Touch
- pkgver = 20150707
+ pkgver = 1.1.0.r11.g9677564
pkgrel = 1
url = http://cgit.sukimashita.com/ideviceinstaller.git/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index f116639a6ae5..ce0bc9f93798 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,6 @@
# Contributor: Matías Hernández <msdark(at)archlinux(dot)cl>
# Contributor: Hugo Ideler <hugoideler(at)dse(dot)nl>
#
-# fixes.patch (biloky):
# 2010.09.23 - some Info.plist does not contain a CFBundleName, use
# CFBundleDisplayName instead
# 2011.08.07 - fix gcc4.6 werror=sign-compare error (2012.03.21 fixed upstream)
@@ -16,10 +15,11 @@
# 2013.08.03 - use -Wno-error=unused-result in CFLAGS to ignore unused
# results warnings
# 2015.07.07 - removed -Werror to ignore compile warnings (Hugo Ideler)
+# - PKGBUILD fixes and updated git versioning
pkgname=ideviceinstaller-git
_gitname=ideviceinstaller
-pkgver=20150707
+pkgver=1.1.0.r11.g9677564
pkgrel=1
pkgdesc="Manage Applications of an iPhone or iPod Touch"
arch=('i686' 'x86_64')
@@ -29,31 +29,29 @@ groups=('system')
depends=('libimobiledevice' 'usbmuxd' 'libzip')
makedepends=('git' 'automake')
provides=('ideviceinstaller')
-source=('git://git.sukimashita.com/ideviceinstaller.git')
+source=("git://git.sukimashita.com/${_gitname}.git")
md5sums=('SKIP')
pkgver() {
- cd ${_gitname}
+ cd ${srcdir}/${_gitname}
# Use the tag of the last commit
- # git describe --always | sed 's|-|.|g'
+ git describe --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
# Use current date
- date +%Y%m%d
+ #date +%Y%m%d
}
build() {
- cd ${_gitname}
+ cd ${srcdir}/${_gitname}
-# unset CPPFLAGS
-# sed -i "/AS_COMPILER_FLAGS(/s/-Werror/-Werror -Wno-error=unused-result/" configure.ac
sed -i "/AS_COMPILER_FLAGS(/s/-Werror//" configure.ac
./autogen.sh --prefix=/usr
make
}
package() {
- cd ${_gitname}
+ cd ${srcdir}/${_gitname}
make DESTDIR=${pkgdir} install
}