summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolay Korotkiy2019-12-20 11:55:18 +0300
committerNikolay Korotkiy2019-12-20 11:55:18 +0300
commit85c25677719d28fdce6466b90dbd7c6c261ce79f (patch)
treeb2639a7ee8c8fa76a6f5e91d7d8e6719e61779e5
parentcad87bfe31b3ce7d249b769430d49fa4e5f0b087 (diff)
downloadaur-85c25677719d28fdce6466b90dbd7c6c261ce79f.tar.gz
Fix .qm generation
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index add1aba4cb5e..de202a4473fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by makepkg 5.2.1
-# Sun Dec 15 21:45:38 UTC 2019
+# Fri Dec 20 08:52:28 UTC 2019
pkgbase = gpxsee-git
pkgdesc = GPS log file viewer and analyzer
pkgver = 7.18.r14.ga986293
diff --git a/PKGBUILD b/PKGBUILD
index 3af46d8c46ca..c9cca06833a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -58,10 +58,9 @@ wl_update() {
}
prepare() {
- cd ${_pkgname}-${_branch}
+ cd ${_pkgname}-${_branch}/lang
if [ "`curl ${_wl_hz}`" = "ok" ]; then
- cd lang
rename nb nb_NO *_nb.ts
wl_update Translations ${_pkgname,,}_
rename nb_NO nb *_nb_NO.ts
@@ -73,7 +72,9 @@ build() {
sed -i "s/\(VERSION = \).*/\1${pkgver}/" gpxsee.pro
- qmake CONFIG+=lrelease PREFIX=/usr gpxsee.pro
+ find lang -name "*.ts" -exec sh -c 'touch ${0//.ts/.qm}' {} \;
+ qmake CONFIG+=lrelease LRELEASE_DIR=lang PREFIX=/usr gpxsee.pro
+ rm -f lang/*.qm
make
}