summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2021-04-24 19:49:23 +0200
committerBlair Bonnett2021-04-24 19:49:23 +0200
commit85ecb95256b78c68d7c5e6061ecf6d524fdb2e32 (patch)
treefc4f8ba32627151beabae94e3849cf9b79950f35
parentec9cddb265d7ef49cb407c2483f5efdcddf525ce (diff)
downloadaur-85ecb95256b78c68d7c5e6061ecf6d524fdb2e32.tar.gz
Upgrade to 0.19.0.
* Switch to PyPI tarball as setuptools-scm cannot find correct version number in GitHub tarball. N.B., the '.post1' release is the same as 0.19.0 but with some additional premade Cython files in the tarball. * Use new proj6 package as Cartopy does not yet support v8 of proj which was recently pushed to community.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
-rw-r--r--use-proj6.patch24
3 files changed, 55 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89a53a0d2f50..fd7b0b4fb5db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = python-cartopy
- pkgdesc = A cartographic python library with matplotlib support for visualisation
- pkgver = 0.18.0
+ pkgdesc = A cartographic Python library with Matplotlib support for visualisation
+ pkgver = 0.19.0
pkgrel = 1
url = https://scitools.org.uk/cartopy/docs/latest/
arch = x86_64
license = LGPL3
checkdepends = python-pytest
- checkdepends = python-filelock
+ checkdepends = python-flufl-lock
makedepends = python-setuptools
makedepends = cython
+ makedepends = python-setuptools-scm
depends = python-numpy
depends = python-six
depends = python-shapely
depends = python-pyshp
- depends = proj
+ depends = proj6
depends = geos
depends = python-matplotlib
depends = python-pillow
@@ -22,10 +23,10 @@ pkgbase = python-cartopy
optdepends = python-gdal: for use with SRTM data
optdepends = python-pyepsg: interface to https://epsg.io
optdepends = python-owslib: access OGC clients
- source = python-cartopy-0.18.0.tar.gz::https://github.com/SciTools/cartopy/archive/v0.18.0.tar.gz
- md5sums = 792c63511641c843759c5b774f2a8b33
- sha1sums = e1eb5b99f8d504ad75e99a788566fcf14da97171
- sha256sums = 493ced4698361ffabec1a213d2b711dc836117242c304f3b93f5406182fd8bc2
+ source = cartopy-v0.19.0.tar.gz::https://files.pythonhosted.org/packages/source/c/cartopy/Cartopy-0.19.0.post1.tar.gz
+ source = use-proj6.patch
+ sha256sums = 4b8b4773a98ed7009fe17d9b6ec87ac3ac62b7d14634d7768c190eadc647d576
+ sha256sums = f0367e38237739fe4c4700353eeae34f892a102a16ff43012b4758fcba564e9b
pkgname = python-cartopy
diff --git a/PKGBUILD b/PKGBUILD
index 8eec04218acd..7713f443c1ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,41 @@
# Contributor: Rich Li <rich@dranek.com>
pkgname=python-cartopy
-pkgver=0.18.0
+pkgver=0.19.0
pkgrel=1
-pkgdesc="A cartographic python library with matplotlib support for visualisation"
+pkgdesc="A cartographic Python library with Matplotlib support for visualisation"
url="https://scitools.org.uk/cartopy/docs/latest/"
-depends=('python-numpy' 'python-six' 'python-shapely' 'python-pyshp' 'proj'
+depends=('python-numpy' 'python-six' 'python-shapely' 'python-pyshp' 'proj6'
'geos' 'python-matplotlib' 'python-pillow' 'python-scipy')
optdepends=('python-fiona: faster shapefile reading'
'python-gdal: for use with SRTM data'
'python-pyepsg: interface to https://epsg.io'
'python-owslib: access OGC clients')
-makedepends=('python-setuptools' 'cython')
-checkdepends=('python-pytest' 'python-filelock')
+makedepends=('python-setuptools' 'cython' 'python-setuptools-scm')
+checkdepends=('python-pytest' 'python-flufl-lock')
license=('LGPL3')
arch=('x86_64')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/SciTools/cartopy/archive/v${pkgver}.tar.gz")
-md5sums=('792c63511641c843759c5b774f2a8b33')
-sha1sums=('e1eb5b99f8d504ad75e99a788566fcf14da97171')
-sha256sums=('493ced4698361ffabec1a213d2b711dc836117242c304f3b93f5406182fd8bc2')
+source=(
+ "cartopy-v$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/c/cartopy/Cartopy-$pkgver.post1.tar.gz"
+ 'use-proj6.patch'
+)
+sha256sums=(
+ '4b8b4773a98ed7009fe17d9b6ec87ac3ac62b7d14634d7768c190eadc647d576'
+ 'f0367e38237739fe4c4700353eeae34f892a102a16ff43012b4758fcba564e9b'
+)
+
+prepare() {
+ cd "$srcdir/Cartopy-${pkgver}.post1"
+ patch -p0 -i "$srcdir/use-proj6.patch"
+}
build() {
- cd "$srcdir/cartopy-${pkgver}"
- python setup.py build
+ cd "$srcdir/Cartopy-${pkgver}.post1"
+ FORCE_CYTHON=1 python setup.py build
}
check() {
- cd "$srcdir/cartopy-${pkgver}"
+ cd "$srcdir/Cartopy-${pkgver}.post1"
# The deselected tests fail an image comparison due to small changes in the
# size and position of text labels.
@@ -39,6 +48,6 @@ check() {
}
package() {
- cd "$srcdir/cartopy-${pkgver}"
+ cd "$srcdir/Cartopy-${pkgver}.post1"
python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1 --skip-build
}
diff --git a/use-proj6.patch b/use-proj6.patch
new file mode 100644
index 000000000000..000a243a529f
--- /dev/null
+++ b/use-proj6.patch
@@ -0,0 +1,24 @@
+--- setup.py
++++ setup.py
+
+@@ -143,5 +143,5 @@
+ # Proj
+ def find_proj_version_by_program(conda=None):
+- proj = find_executable('proj')
++ proj = find_executable('proj6')
+ if proj is None:
+ print(
+
+--- setup.py
++++ setup.py
+
+@@ -288,6 +288,9 @@
+ extra_extension_args["define_macros"].append(
+ ('CYTHON_TRACE_NOGIL', '1')
+ )
+
++proj_includes = ["/usr/include/proj6"]
++proj_libraries = ["proj6"]
++
+ extensions = [
+ Extension(