summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjörn Bidar2018-04-21 02:48:05 +0200
committerBjörn Bidar2018-04-21 02:48:05 +0200
commit860cf005c8eab9f43a804655311ec776fb631630 (patch)
treed6aeafe372ef1cbf644ec99732b7b89e1dcf7d66
parent9a0a410c9d2116b863f0428169f1280c25244632 (diff)
downloadaur-860cf005c8eab9f43a804655311ec776fb631630.tar.gz
upkg
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD13
-rw-r--r--kernel-4.16.patch33
3 files changed, 54 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 470c3a4c9d00..34ef1af7b2c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Mon Apr 2 03:42:07 UTC 2018
+# Sat Apr 21 00:47:36 UTC 2018
pkgbase = nvidia-pf
pkgdesc = NVIDIA drivers for linux-pf.
- pkgver = 390.42
+ pkgver = 390.48
pkgrel = 1
url = http://www.nvidia.com/
arch = i686
arch = x86_64
license = custom
- makedepends = linux-pf-headers>=4.15
- makedepends = linux-pf-headers<4.16
- depends = linux-pf>=4.15
- depends = linux-pf<4.16
- depends = nvidia-utils=390.42
+ makedepends = linux-pf-headers>=4.16
+ makedepends = linux-pf-headers<4.17
+ depends = linux-pf>=4.16
+ depends = linux-pf<4.17
+ depends = nvidia-utils=390.48
conflicts = nvidia-96xx
conflicts = nvidia-173xx
conflicts = nvidia-pf-core2
@@ -24,10 +24,12 @@ pkgbase = nvidia-pf
conflicts = nvidia-pf-pm
conflicts = nvidia-pf-k7
options = !strip
- source_i686 = http://us.download.nvidia.com/XFree86/Linux-x86/390.42/NVIDIA-Linux-x86-390.42.run
- md5sums_i686 = 453c6fb7f892eb53bf32011fc0da770d
- source_x86_64 = http://us.download.nvidia.com/XFree86/Linux-x86_64/390.42/NVIDIA-Linux-x86_64-390.42-no-compat32.run
- md5sums_x86_64 = 2b2e4c8b4174b542774d82c66ba69e91
+ source = kernel-4.16.patch
+ md5sums = 84f1f2ecdccf377fc86323f8ad7b7469
+ source_i686 = http://us.download.nvidia.com/XFree86/Linux-x86/390.48/NVIDIA-Linux-x86-390.48.run
+ md5sums_i686 = 754bbdc3eb6f3873cca49ae807964c0e
+ source_x86_64 = http://us.download.nvidia.com/XFree86/Linux-x86_64/390.48/NVIDIA-Linux-x86_64-390.48-no-compat32.run
+ md5sums_x86_64 = 8ed67fc67710b6cfd9c9273054e2117a
pkgname = nvidia-pf
diff --git a/PKGBUILD b/PKGBUILD
index e7aced796d7d..6e4c8f909786 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer : Bjoern Bidar - theodorstormgrade@gmail.com
pkgname=nvidia-pf
-pkgver=390.42
+pkgver=390.48
pkgrel=1
-_goodkver=4.15
-_badkver=4.16
+_goodkver=4.16
+_badkver=4.17
_modver=${_goodkver}-pf
_extramodules=extramodules-$_modver
_kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
@@ -23,8 +23,10 @@ license=('custom')
options=(!strip)
source_i686=("http://us.download.nvidia.com/XFree86/Linux-x86/${pkgver}/NVIDIA-Linux-x86-${pkgver}.run")
source_x86_64=("http://us.download.nvidia.com/XFree86/Linux-x86_64/${pkgver}/NVIDIA-Linux-x86_64-${pkgver}-no-compat32.run")
-md5sums_i686=('453c6fb7f892eb53bf32011fc0da770d')
-md5sums_x86_64=('2b2e4c8b4174b542774d82c66ba69e91')
+source+=('kernel-4.16.patch')
+md5sums=('84f1f2ecdccf377fc86323f8ad7b7469')
+md5sums_i686=('754bbdc3eb6f3873cca49ae807964c0e')
+md5sums_x86_64=('8ed67fc67710b6cfd9c9273054e2117a')
@@ -38,6 +40,7 @@ prepare()
sh "${_pkg}.run" --extract-only
cd "${_pkg}"
# patches here
+ patch -Np1 -i "$srcdir"/kernel-4.16.patch
}
build() {
diff --git a/kernel-4.16.patch b/kernel-4.16.patch
new file mode 100644
index 000000000000..67172815ff69
--- /dev/null
+++ b/kernel-4.16.patch
@@ -0,0 +1,33 @@
+diff --git a/kernel/common/inc/nv-linux.h b/kernel/common/inc/nv-linux.h
+index 10fc418..22ef968 100644
+--- a/kernel/common/inc/nv-linux.h
++++ b/kernel/common/inc/nv-linux.h
+@@ -175,7 +175,11 @@ static inline uid_t __kuid_val(kuid_t uid)
+
+ #if defined(NV_VM_INSERT_PAGE_PRESENT)
+ #include <linux/pagemap.h>
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 16, 0)
+ #include <linux/dma-mapping.h>
++#else
++#include <linux/dma-direct.h>
++#endif
+ #endif
+
+ #if defined(CONFIG_SWIOTLB) && defined(NVCPU_AARCH64)
+diff --git a/kernel/conftest.sh b/kernel/conftest.sh
+index b23dbb4..42dc576 100755
+--- a/kernel/conftest.sh
++++ b/kernel/conftest.sh
+@@ -1906,7 +1906,12 @@ compile_test() {
+ # Determine if the phys_to_dma function is present.
+ #
+ CODE="
++ #include <linux/version.h>
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 16, 0)
+ #include <linux/dma-mapping.h>
++#else
++ #include <linux/dma-direct.h>
++#endif
+ void conftest_phys_to_dma(void) {
+ phys_to_dma();
+ }"