summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKrzysztof AS (3ED)2020-11-27 15:55:32 +0100
committerKrzysztof AS (3ED)2020-11-27 15:55:32 +0100
commit86157695756b9a7bd285e9707b76887e1f8826d5 (patch)
treed48777f7ab5e06852e5aaa4770bb8261f96bc901
downloadaur-86157695756b9a7bd285e9707b76887e1f8826d5.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD34
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82435c0f04de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = perl-parse-pmfile
+ pkgdesc = parses .pm file as PAUSE does
+ pkgver = 0.42
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Parse-PMFile/
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-json-pp
+ source = http://search.cpan.org/CPAN/authors/id/I/IS/ISHIGAKI/Parse-PMFile-0.42.tar.gz
+ sha256sums = e7f6c70932b86eb4a2426569e33d2b651b52a24e5d0c0dcb3849d045b52c736c
+
+pkgname = perl-parse-pmfile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db46b559cbdb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Mantainer: 3ED <krzysztof1987 at gmail dot com>
+#
+pkgname=perl-parse-pmfile
+_lastauthor=I/IS/ISHIGAKI
+_pkgname=Parse-PMFile
+pkgver=0.42
+pkgrel=1
+pkgdesc='parses .pm file as PAUSE does'
+arch=('any')
+license=('PerlArtistic' 'GPL')
+depends=(perl-json-pp)
+url="http://search.cpan.org/dist/${_pkgname}/"
+source=(http://search.cpan.org/CPAN/authors/id/${_lastauthor}/${_pkgname}-${pkgver}.tar.gz)
+sha256sums=('e7f6c70932b86eb4a2426569e33d2b651b52a24e5d0c0dcb3849d045b52c736c')
+
+build() {
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ perl Makefile.PL
+ make
+}
+check() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make test
+}
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make install
+}
+