summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-03-17 01:39:31 +0300
committerCaleb Maclennan2023-03-17 01:39:31 +0300
commit863b9cc5b53c1415feb2d7dd813e31a4bf5a657a (patch)
treec0c42d4dbbf8e296a84c294070efaf98f1728a28
parent2c43e158941fdc5378afd0fe9a110499c3c8836b (diff)
downloadaur-863b9cc5b53c1415feb2d7dd813e31a4bf5a657a.tar.gz
upgpkg: python-plum 0.8.5-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e164eb3aca8a..ca69fd9372a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-plum
pkgdesc = Pack/Unpack Memory
pkgver = 0.8.5
- pkgrel = 1
+ pkgrel = 2
url = https://plum-py.readthedocs.io/en/latest/
arch = any
license = MIT
makedepends = python-build
makedepends = python-installer
- makedepends = python-setuptools
makedepends = python-wheel
+ makedepends = python-setuptools
depends = python
source = https://gitlab.com/dangass/plum/-/archive/0.8.5/plum-0.8.5.tar.bz2
sha256sums = 41016eed6cdbe1429afc21654cd05f935fc13ae8eb465981f6c3b1e92c57319e
diff --git a/PKGBUILD b/PKGBUILD
index c866067da462..95cf96a4f103 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,23 @@
_pyname=plum
pkgname=python-${_pyname,,}
pkgver=0.8.5
-pkgrel=1
+pkgrel=2
pkgdesc='Pack/Unpack Memory'
arch=(any)
url="https://$_pyname-py.readthedocs.io/en/latest/"
license=(MIT)
depends=(python)
-makedepends=(python-{build,installer}
- python-setuptools
- python-wheel)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
_archive="$_pyname-$pkgver"
source=("https://gitlab.com/dangass/$_pyname/-/archive/$pkgver/$_archive.tar.bz2")
sha256sums=('41016eed6cdbe1429afc21654cd05f935fc13ae8eb465981f6c3b1e92c57319e')
+prepare() {
+ cd "$_archive"
+ sed -i -e '/python_requires/d' setup.cfg
+}
+
build() {
cd "$_archive"
python -m build -wn