summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJanne Veteläinen2024-03-07 08:59:01 +0200
committerJanne Veteläinen2024-03-07 08:59:01 +0200
commit8648d711a3834d99e9a1662b92b6b94606f26066 (patch)
tree2622fc6b87c52472ce621345e2b2a6d379e4db1f
parent2ccd42222dc3ddc6a9c2ace5b5cb0382279d50ab (diff)
downloadaur-8648d711a3834d99e9a1662b92b6b94606f26066.tar.gz
Build more components of the ACE release, update license declaration
-rw-r--r--.SRCINFO33
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD108
-rw-r--r--license.txt83
4 files changed, 118 insertions, 107 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbeb39feb23c..0be6ca63c392 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,33 @@
pkgbase = ace
pkgdesc = Framework that provides many components and patterns for developing high-performance, distributed real-time and embedded systems.
pkgver = 7.1.3
- pkgrel = 1
+ pkgrel = 2
url = https://www.dre.vanderbilt.edu/~schmidt/ACE.html
- arch = i686
arch = x86_64
- license = custom
- conflicts = libace
- options = !libtool
- source = https://github.com/DOCGroup/ACE_TAO/releases/download/ACE%2BTAO-7_1_3/ACE-7.1.3.tar.gz
- sha256sums = 4cb82d8daf83f3abe50ac460b4fac9a8da2512f08d8efb4d327dcacd0b3929b3
+ license = LicenseRef-DOC
+ makedepends = perl
+ depends = gcc-libs
+ depends = glibc
+ depends = openssl
+ depends = xerces-c
+ provides = libACE.so
+ provides = libACEXML.so
+ provides = libACEXML_Parser.so
+ provides = libACEXML_XML_Svc_Conf_Parser.so
+ provides = libACE_Compression.so
+ provides = libACE_ETCL.so
+ provides = libACE_ETCL_Parser.so
+ provides = libACE_HTBP.so
+ provides = libACE_INet.so
+ provides = libACE_INet_SSL.so
+ provides = libACE_Monitor_Control.so
+ provides = libACE_RLECompression.so
+ provides = libACE_RMCast.so
+ provides = libACE_SSL.so
+ provides = libACE_TMCast.so
+ provides = libACE_XML_Utils.so
+ provides = libKokyu.so
+ source = https://github.com/DOCGroup/ACE_TAO/releases/download/ACE%2BTAO-7_1_3/ACE-src-7.1.3.tar.gz
+ sha256sums = 105a2705dddb3c93e486028f63a33ec0f3f6dbcd63cdd166f34f5d5da35ab5ac
pkgname = ace
diff --git a/.gitignore b/.gitignore
index deed26c01ec5..0f146cf509cf 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
pkg/
src/
*.tar.gz
+*.tar.bz2
diff --git a/PKGBUILD b/PKGBUILD
index e580a5c276d3..d488a4c3dfe3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,28 +11,102 @@
pkgname=ace
_pkgver=7_1_3
pkgver=7.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Framework that provides many components and patterns for developing high-performance, distributed real-time and embedded systems."
+arch=('x86_64')
url="https://www.dre.vanderbilt.edu/~schmidt/ACE.html"
-license=('custom')
-arch=('i686' 'x86_64')
-depends=()
-options=(!libtool)
-conflicts=('libace')
-source=("https://github.com/DOCGroup/ACE_TAO/releases/download/ACE%2BTAO-${_pkgver}/ACE-${pkgver}.tar.gz")
-sha256sums=('4cb82d8daf83f3abe50ac460b4fac9a8da2512f08d8efb4d327dcacd0b3929b3')
+license=('LicenseRef-DOC')
+depends=('gcc-libs' 'glibc' 'openssl' 'xerces-c')
+makedepends=('perl')
+provides=(
+ 'libACE.so'
+ 'libACEXML.so'
+ 'libACEXML_Parser.so'
+ 'libACEXML_XML_Svc_Conf_Parser.so'
+ 'libACE_Compression.so'
+ 'libACE_ETCL.so'
+ 'libACE_ETCL_Parser.so'
+ 'libACE_HTBP.so'
+ 'libACE_INet.so'
+ 'libACE_INet_SSL.so'
+ 'libACE_Monitor_Control.so'
+ 'libACE_RLECompression.so'
+ 'libACE_RMCast.so'
+ 'libACE_SSL.so'
+ 'libACE_TMCast.so'
+ 'libACE_XML_Utils.so'
+ 'libKokyu.so'
+)
+
+source=("https://github.com/DOCGroup/ACE_TAO/releases/download/ACE%2BTAO-${_pkgver}/ACE-src-${pkgver}.tar.gz")
+sha256sums=('105a2705dddb3c93e486028f63a33ec0f3f6dbcd63cdd166f34f5d5da35ab5ac')
+
+prepare() {
+ export ACE_ROOT="$srcdir/ACE_wrappers"
+ cd "$ACE_ROOT"
+
+ # Built a select subset of components in the ACE release
+ # Inspired by Debian
+ cat <<-EOF > "$ACE_ROOT/ACE.mwc"
+ workspace {
+ exclude {
+ apps/gperf/tests
+ apps/Gateway
+ apps/JAWS
+ apps/JAWS2
+ apps/JAWS3
+ apps/drwho
+ apps/mkcsregdb
+ apps/soreduce
+
+ ACEXML/tests
+ Kokyu/tests
+ ACEXML/examples
+ netsvcs/clients
+ protocols/examples
+
+ ASNMP
+ MPC
+ examples
+ performance-tests
+ websvcs
+ }
+ }
+ EOF
+}
build() {
- export ACE_ROOT=$srcdir/ACE_wrappers
- cd $ACE_ROOT
- echo '#include "ace/config-linux.h"' > ace/config.h
- echo 'INSTALL_PREFIX = /usr
- include $(ACE_ROOT)/include/makeinclude/platform_linux.GNU' > include/makeinclude/platform_macros.GNU
- cd ace
- make
+ export ACE_ROOT="$srcdir/ACE_wrappers"
+ cd "$ACE_ROOT"
+
+ cat <<-EOF > "$ACE_ROOT/ace/config.h"
+ #include "ace/config-linux.h"
+ EOF
+
+ cat <<-EOF > "$ACE_ROOT/include/makeinclude/platform_macros.GNU"
+ INSTALL_PREFIX = /usr
+ ipv6 = 1
+ ssl = 1
+ xerces3 = 1
+ include \$(ACE_ROOT)/include/makeinclude/platform_linux.GNU
+ EOF
+
+ cat <<-EOF > "$ACE_ROOT/bin/MakeProjectCreator/config/default.features"
+ ipv6 = 1
+ ssl = 1
+ xerces3 = 1
+ EOF
+
+ "$ACE_ROOT/bin/mwc.pl" -type gnuace ACE.mwc
+ make
}
package() {
- cd $srcdir/ACE_wrappers/ace
- make DESTDIR="$pkgdir/" install
+ export ACE_ROOT="$srcdir/ACE_wrappers"
+ cd "$ACE_ROOT"
+ make DESTDIR="$pkgdir/" install
+ rm -rf "$pkgdir/usr/share/ace/include"
+ rm -rf "$pkgdir/usr/share/ace/bin"
+ rm "$pkgdir/usr/share/ace/ace-devel.sh"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
diff --git a/license.txt b/license.txt
deleted file mode 100644
index f4d029f1ef6d..000000000000
--- a/license.txt
+++ /dev/null
@@ -1,83 +0,0 @@
-Copyright and Licensing Information for ACE(TM), TAO(TM), CIAO(TM), and
-CoSMIC(TM)
-ACE(TM), TAO(TM), CIAO(TM), and CoSMIC(TM) (henceforth referred to as
-"DOC software") are copyrighted by Douglas C. Schmidt and his research
-group at Washington University, University of California, Irvine, and
-Vanderbilt University, Copyright (c) 1993-2006, all rights reserved.
-Since DOC software is open-source, freely available software, you are
-free to use, modify, copy, and distribute--perpetually and
-irrevocably--the DOC software source code and object code produced from
-the source, as well as copy and distribute modified versions of this
-software. You must, however, include this copyright statement along with
-any code built using DOC software that you release. No copyright
-statement needs to be provided if you just ship binary executables of
-your software products.
-
-You can use DOC software in commercial and/or binary software releases
-and are under no obligation to redistribute any of your source code that
-is built using DOC software. Note, however, that you may not do anything
-to the DOC software code, such as copyrighting it yourself or claiming
-authorship of the DOC software code, that will prevent DOC software from
-being distributed freely using an open-source development model. You
-needn't inform anyone that you're using DOC software in your software,
-though we encourage you to let us know so we can promote your project in
-the DOC software success stories.
-
-The ACE, TAO, CIAO, and CoSMIC web sites are maintained by the DOC Group
-at the Institute for Software Integrated Systems (ISIS) and the Center
-for Distributed Object Computing of Washington University, St. Louis for
-the development of open-source software as part of the open-source
-software community. By submitting comments, suggestions, code, code
-snippets, techniques (including that of usage) and algorithms
-(collectively ``Submissions''), submitters acknowledge that they have
-the right to do so, that any such Submissions are given freely and
-unreservedly, and that they waive any claims to copyright or ownership.
-In addition, submitters acknowledge that any such Submission might
-become part of the copyright maintained on the overall body of code that
-comprises the DOC software. By making a Submission, submitter agree to
-these terms. Moreover, submitters acknowledge that the incorporation or
-modification of such Submissions is entirely at the discretion of the
-moderators of the open-source DOC software projects or their designees.
-
-Submissions are provided by the submitter ``as is'' with no warranties
-whatsoever, including any warranty of merchantability, noninfringement
-of third party intellectual property, or fitness for any particular
-purpose. In no event shall the submitter be liable for any direct,
-indirect, special, exemplary, punitive, or consequential damages,
-including without limitation, lost profits, even if advised of the
-possibility of such damages. Likewise, DOC software is provided as is
-with no warranties of any kind, including the warranties of design,
-merchantability, and fitness for a particular purpose, noninfringement,
-or arising from a course of dealing, usage or trade practice. Washington
-University, UC Irvine, Vanderbilt University, their employees, and
-students shall have no liability with respect to the infringement of
-copyrights, trade secrets or any patents by DOC software or any part
-thereof. Moreover, in no event will Washington University, UC Irvine, or
-Vanderbilt University, their employees, or students be liable for any
-lost revenue or profits or other special, indirect and consequential
-damages.
-
-DOC software is provided with no support and without any obligation on
-the part of Washington University, UC Irvine, Vanderbilt University,
-their employees, or students to assist in its use, correction,
-modification, or enhancement. A number of companies around the world
-provide commercial support for DOC software, however.
-
-DOC software is Y2K-compliant, as long as the underlying OS platform is
-Y2K-compliant. Likewise, DOC software is compliant with the new US
-daylight savings rule passed by Congress as "The Energy Policy Act of
-2005," which established new daylight savings times (DST) rules for the
-United States that expand DST as of March 2007. Since DOC software
-obtains time/date and calendaring information from operating systems
-users will not be affected by the new DST rules as long as they upgrade
-their operating systems accordingly.
-
-The names ACE(TM), TAO(TM), CIAO(TM), CoSMIC(TM), Washington University,
-UC Irvine, and Vanderbilt University, may not be used to endorse or
-promote products or services derived from this source without express
-written permission from Washington University, UC Irvine, or Vanderbilt
-University. Further, products or services derived from this source may
-not be called ACE(TM), TAO(TM), CIAO(TM), or CoSMIC(TM) nor may the name
-Washington University, UC Irvine, or Vanderbilt University appear in
-their names, without express written permission from Washington
-University, UC Irvine, and Vanderbilt University.