summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2018-11-07 05:58:54 -0700
committerAinola2018-11-07 05:58:54 -0700
commit865822e0e492cc354285b5e4154ca7685f69cd0a (patch)
tree9c436fd1d62efe20e193ba79885abe28788ab481
parentcd92e697d18e784de7cc370abefb9bce94545baa (diff)
downloadaur-865822e0e492cc354285b5e4154ca7685f69cd0a.tar.gz
add tests, depends
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eaa4ae0bf295..1b4938da3567 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sun Sep 9 22:18:55 UTC 2018
pkgbase = python-oath
pkgdesc = Python implementation of HOTP, TOTP and OCRA algorithms from OATH.
pkgver = 1.4.0
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/bdauvergne/python-oath
arch = any
license = BSD
@@ -13,6 +11,8 @@ pkgbase = python-oath
sha256sums = 3e485d0fc4a6c077cb75841cba6512c1ab1b11d766969a24b199586e04e7c58f
pkgname = python-oath
+ depends = python
pkgname = python2-oath
+ depends = python2
diff --git a/PKGBUILD b/PKGBUILD
index deafc2a71e5a..c9b36eb87c08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=python-oath
pkgname=('python-oath' 'python2-oath')
pkgver=1.4.0
-pkgrel=6
+pkgrel=7
pkgdesc="Python implementation of HOTP, TOTP and OCRA algorithms from OATH."
arch=('any')
url="https://github.com/bdauvergne/python-oath"
@@ -21,7 +21,13 @@ build() {
cd "../python-oath-$pkgver-py2" && python2 setup.py build
}
+check() {
+ cd "python-oath-$pkgver" && python setup.py test
+ cd "../python-oath-$pkgver-py2" && python2 setup.py test
+}
+
package_python-oath() {
+ depends=('python')
cd "python-oath-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"
@@ -29,6 +35,7 @@ package_python-oath() {
}
package_python2-oath() {
+ depends=('python2')
cd "python-oath-$pkgver-py2"
python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"