summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSibren Vasse2018-12-23 12:15:00 +0100
committerSibren Vasse2018-12-23 12:17:20 +0100
commit866809404c134d7e64248d2e68d9f28c9498abf6 (patch)
treef79096b92810f408b830fccdf8db7ce9902c4d18
downloadaur-866809404c134d7e64248d2e68d9f28c9498abf6.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD20
3 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b1d90c7a320
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = seriesmeta-bin
+ pkgdesc = Update the series metadata on a Kobo ereader
+ pkgver = 2.3.1
+ pkgrel = 1
+ url = https://geek1011.github.io/kepubify
+ arch = x86_64
+ license = MIT
+ source = seriesmeta-2.3.1::https://github.com/geek1011/kepubify/releases/download/v2.3.1/seriesmeta-linux-64bit
+ source = LICENSE
+ sha256sums = ea2bed5262d63402c9f8541441ae3da2c605ec7a04ebfd0bcdc49bf5f8b154e2
+ sha256sums = ebe9fd8caa3794012773f26556c2f40c19677d6f4142367ec5a1594c5bb793ad
+
+pkgname = seriesmeta-bin
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..2cb71040575e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+MIT License
+
+Copyright (c) 2018 Patrick G
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8aaca8a162d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Sibren Vasse <arch@sibrenvasse.nl>
+
+pkgname=seriesmeta-bin
+_pkgname=seriesmeta
+pkgver=2.3.1
+pkgrel=1
+pkgdesc="Update the series metadata on a Kobo ereader"
+arch=('x86_64')
+url="https://geek1011.github.io/kepubify"
+license=('MIT')
+source=(${_pkgname}-${pkgver}::https://github.com/geek1011/kepubify/releases/download/v${pkgver}/${_pkgname}-linux-64bit
+ LICENSE)
+sha256sums=('ea2bed5262d63402c9f8541441ae3da2c605ec7a04ebfd0bcdc49bf5f8b154e2'
+ 'ebe9fd8caa3794012773f26556c2f40c19677d6f4142367ec5a1594c5bb793ad')
+
+package() {
+ cd "${srcdir}/"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 "${_pkgname}-${pkgver}" "${pkgdir}"/usr/bin/${_pkgname}
+}