summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Bachmann2019-10-26 21:28:06 +0200
committerTobias Bachmann2019-10-26 21:28:06 +0200
commit868450a4c53d573b8400937e0bf040c4a6e1f883 (patch)
tree103b2366f156fd13287429f0b6e973f68f1dfc12
parent0bf93c6240beb1916cee1a19573671aae83784bd (diff)
downloadaur-868450a4c53d573b8400937e0bf040c4a6e1f883.tar.gz
Fix Doxygen error
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b117932a58f5..204a482647cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scantools
pkgdesc = scantools is a library and a matching set of command line applications for graphics manipulation, written with a view towards the handling of scanned documents and generation of high-quality PDF files.
pkgver = 0.6.4
- pkgrel = 2
+ pkgrel = 3
url = https://cplx.vm.uni-freiburg.de/scantools/
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index bee1f26d32f3..1522f7035b19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
pkgname=scantools
pkgver=0.6.4
-pkgrel=2
+pkgrel=3
pkgdesc="scantools is a library and a matching set of command line applications for graphics manipulation, written with a view towards the handling of scanned documents and generation of high-quality PDF files."
arch=('x86_64')
url="https://cplx.vm.uni-freiburg.de/scantools/"
@@ -12,11 +12,12 @@ source=("https://gitlab.com/kebekus/scantools/-/archive/${pkgver}/${pkgname}-${p
sha256sums=('154b9c4da5f4d08bdaac5bf740f07fcb20e19028fd0c429d85636cbba7ed4071')
build() {
- cd ${pkgname}-${pkgver}
- mkdir build
- cd build
- cmake -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib ../src
- make -j $(nproc)
+ cd ${pkgname}-${pkgver}
+ echo "WARN_AS_ERROR = NO" >> src/libscantools/Doxyfile.in # Workaround for Doxygen error
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib ../src
+ make -j $(nproc)
}
package() {