summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Lawrence2015-07-04 14:25:43 -0400
committerScott Lawrence2015-07-04 14:25:43 -0400
commit86a1b6ec1fcd0c6fc9ea7f307686554ad559e33f (patch)
treeb7f4b84accfb7b965fb1c2932718b428459f6cfd
downloadaur-86a1b6ec1fcd0c6fc9ea7f307686554ad559e33f.tar.gz
aur4 import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD47
-rw-r--r--pommed-light.install14
-rw-r--r--pommed.service10
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6ada60a20d6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = pommed-light
+ pkgdesc = Handles the hotkeys of Apple MacBook (Pro) laptops - lightweight edition
+ pkgver = 1.47lw
+ pkgrel = 1
+ url = https://github.com/bytbox/pommed-light
+ install = pommed-light.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = pkgconfig
+ depends = alsa-lib
+ depends = confuse
+ depends = audiofile
+ depends = pciutils
+ optdepends = eject: disc ejection support
+ conflicts = pommed
+ source = https://github.com/bytbox/pommed-light/archive/v1.47lw.tar.gz
+ source = pommed.service
+ md5sums = 36b21b215b17577c561439bc76fd00ef
+ md5sums = fd5be6c0aa9ac4a0b1b628a23361b4cf
+
+pkgname = pommed-light
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd678d396079
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Scott Lawrence <bytbox@gmail.com>
+
+# Forked from pommed. Previous header:
+# Maintainer: Corrado Primier <ilbardo gmail com>
+# Contributor: Other contributors existed but lost information
+# Contributor: dpevp <daniel.plaza.espi@gmail.com>
+# Contributor: jordi Cerdan (jcerdan) <jcerdan@tecob.com>
+
+pkgname=pommed-light
+pkgver=1.47lw
+pkgrel=1
+pkgdesc="Handles the hotkeys of Apple MacBook (Pro) laptops - lightweight edition"
+arch=('i686' 'x86_64')
+url="https://github.com/bytbox/pommed-light"
+license=('GPL2')
+install=$pkgname.install
+makedepends=('pkgconfig')
+depends=('alsa-lib' 'confuse' 'audiofile' 'pciutils')
+conflicts=('pommed')
+optdepends=('eject: disc ejection support')
+source=(https://github.com/bytbox/${pkgname}/archive/v${pkgver}.tar.gz pommed.service)
+dfname="${pkgname}-${pkgver}"
+md5sums=('36b21b215b17577c561439bc76fd00ef'
+ 'fd5be6c0aa9ac4a0b1b628a23361b4cf')
+
+build() {
+ cd ${srcdir}/${dfname}
+ make pommed
+}
+
+package() {
+ install -Dm755 ${srcdir}/${dfname}/pommed/pommed ${pkgdir}/usr/bin/pommed
+ install -Dm644 ${srcdir}/${dfname}/pommed.conf.mactel ${pkgdir}/etc/pommed.conf.mactel
+ install -Dm644 ${srcdir}/${dfname}/pommed.conf.pmac ${pkgdir}/etc/pommed.conf.pmac
+
+ # Man page
+ install -Dm644 ${srcdir}/${dfname}/pommed.1 ${pkgdir}/usr/share/man/man1/pommed.1
+
+ # Sounds
+ install -Dm644 ${srcdir}/${dfname}/pommed/data/goutte.wav ${pkgdir}/usr/share/pommed/goutte.wav
+ install -Dm644 ${srcdir}/${dfname}/pommed/data/click.wav ${pkgdir}/usr/share/pommed/click.wav
+
+ # Systemd
+ install -Dm644 ${srcdir}/pommed.service ${pkgdir}/usr/lib/systemd/system/pommed.service
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/pommed-light.install b/pommed-light.install
new file mode 100644
index 000000000000..a91d99c939a1
--- /dev/null
+++ b/pommed-light.install
@@ -0,0 +1,14 @@
+post_install() {
+cat << EOM
+
+==> There are two configuration files samples: /etc/pommed.conf.{pmac,mactel},
+==> use them as base for your /etc/pommmed.conf
+
+==> To start pommed at boot, run 'systemctl enable pommed'. To start it right
+==> now, run 'systemctl start pommed'.
+
+EOM
+}
+
+
+# vim:set ts=2 sw=2 et:
diff --git a/pommed.service b/pommed.service
new file mode 100644
index 000000000000..c7ee721de54a
--- /dev/null
+++ b/pommed.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Pommed Apple Hotkeys Daemon
+
+[Service]
+User=root
+ExecStart=/usr/bin/pommed -f
+
+[Install]
+WantedBy=multi-user.target
+