summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroweissbarth2017-04-22 15:49:10 +0200
committeroweissbarth2017-04-22 15:49:10 +0200
commit86a8fee24f84e158800d98fef951de06e7d1dce9 (patch)
tree2a04ecf4d47805cb654626426874f5ebcc7c262b
downloadaur-86a8fee24f84e158800d98fef951de06e7d1dce9.tar.gz
nanogit inital upload
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD41
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d00248d9cb0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nanogui-git
+ pkgdesc = NanoGUI is a minimalistic cross-platform widget library for OpenGL 3.x or higher.
+ pkgver = VERSION
+ pkgrel = 1
+ url = https://github.com/wjakob/nanogui
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ provides = nanogui
+ conflicts = nanogui
+ source = nanogui::git+https://github.com/wjakob/nanogui
+ md5sums = SKIP
+
+pkgname = nanogui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d49be1ab01c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Oliver Weissbarth <mail@oweissbarth.de>
+pkgname=nanogui-git
+pkgver=VERSION
+pkgrel=1
+pkgdesc="NanoGUI is a minimalistic cross-platform widget library for OpenGL 3.x or higher."
+arch=("x86_64")
+url="https://github.com/wjakob/nanogui"
+license=('BSD')
+groups=()
+depends=()
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+source=('nanogui::git+https://github.com/wjakob/nanogui')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+ install LICENSE.txt /usr/share/licenses/${pkgname%-git}/.
+}