summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2021-02-07 11:25:41 +0100
committerGianluca Boiano2021-02-07 11:25:41 +0100
commit86b3120025cfc73d0ea90f5855f079cf4e63bb16 (patch)
tree45c537e1f7cfa7e3923de82c3a37687cff2ef5e1
parente07bc7d88d62415de8d17d19a466b22f4b2e7a63 (diff)
downloadaur-86b3120025cfc73d0ea90f5855f079cf4e63bb16.tar.gz
idjc-git: update
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD74
2 files changed, 47 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90ae345c52bf..7e6748e85f96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = idjc-git
pkgdesc = Powerful client for individuals interested in streaming live radio shows
- pkgver = 931.9aa8e08
+ pkgver = 0.9.0.r8.332e11b
pkgrel = 1
url = http://idjc.sourceforge.net/
arch = i686
arch = x86_64
- license = GPL3
+ license = GPL2
makedepends = git
depends = desktop-file-utils
depends = ffmpeg
@@ -17,14 +17,16 @@ pkgbase = idjc-git
depends = libsamplerate
depends = libshout-idjc-git
depends = libsndfile
- depends = pygtk
- depends = python2
- depends = python2-dbus
- depends = python2-mutagen
+ depends = python
+ depends = python-dbus
+ depends = python-gobject
+ depends = python-mutagen
depends = speex
depends = twolame
depends = vorbis-tools
optdepends = mysql-python: Ampache and Prokyon 3 support
+ optdepends = python-irc: IRC notification support
+ provides = idjc
conflicts = idjc
source = idjc::git+https://git.code.sf.net/p/idjc/code
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 86c003cbc365..bbf27d7dc48b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,58 +2,62 @@
# Contributor: Tobias Luther <tobias [at] tonstrom [dot] de>
pkgname=idjc-git
-pkgver=931.9aa8e08
+pkgver=0.9.0.r8.332e11b
pkgrel=1
pkgdesc="Powerful client for individuals interested in streaming live radio shows"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url="http://idjc.sourceforge.net/"
depends=(
- 'desktop-file-utils'
- 'ffmpeg'
- 'flac'
- 'glib2'
- 'jack'
- 'lame'
- 'libmad'
- 'libsamplerate'
- 'libshout-idjc-git'
- 'libsndfile'
- 'pygtk'
- 'python2'
- 'python2-dbus'
- 'python2-mutagen'
- 'speex'
- 'twolame'
- 'vorbis-tools'
+ 'desktop-file-utils'
+ 'ffmpeg'
+ 'flac'
+ 'glib2'
+ 'jack'
+ 'lame'
+ 'libmad'
+ 'libsamplerate'
+ 'libshout-idjc-git'
+ 'libsndfile'
+ 'python'
+ 'python-dbus'
+ 'python-gobject'
+ 'python-mutagen'
+ 'speex'
+ 'twolame'
+ 'vorbis-tools'
)
makedepends=('git')
-optdepends=('mysql-python: Ampache and Prokyon 3 support')
-conflicts=('idjc')
+optdepends=('mysql-python: Ampache and Prokyon 3 support'
+ 'python-irc: IRC notification support')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
source=('idjc::git+https://git.code.sf.net/p/idjc/code')
-license=('GPL3')
+license=('GPL2')
build() {
- cd idjc
+ cd "${srcdir}/${pkgname%-git}"
+
./bootstrap
- export PYTHON=/usr/bin/python2
- ./configure \
- --prefix=/usr \
- --libexecdir=/usr/lib \
- --disable-static
+ ./configure \
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --disable-static
make
}
-package() {
- cd idjc
- make DESTDIR=$pkgdir install
- sed -i "s/Icon=\/usr\/share\/pixmaps\/${pkgname%%-git}.png/Icon=${pkgname%%-git}/g" $pkgdir/usr/share/applications/${pkgname%%-git}.desktop
+package() {
+ cd "${srcdir}/${pkgname%-git}"
+
+ make DESTDIR=${pkgdir} install
+
+ sed -i "s/Icon=\/usr\/share\/pixmaps\/${pkgname%%-git}.png/Icon=${pkgname%%-git}/g" \
+ ${pkgdir}/usr/share/applications/${pkgname%%-git}.desktop
}
pkgver() {
- cd idjc
- echo $(git rev-list --count master).$(git rev-parse --short master)
+ cd "${srcdir}/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
md5sums=('SKIP')
-