summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Lange2023-02-27 02:48:28 +0100
committerThomas Lange2023-02-27 02:48:28 +0100
commit86c522a7b311b2ab32c04e3812b935e741e6ca90 (patch)
treea74ae9a3d9265dfdf08e2fde3554537ac8b9b2b0
parent74eed3c9d69ed49ebe12bcfb7130828f29a73c40 (diff)
downloadaur-86c522a7b311b2ab32c04e3812b935e741e6ca90.tar.gz
Make Git submodules work again
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 35 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a96c2297b81f..87fccee46a4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -44,9 +44,21 @@ pkgbase = mumble-git
provides = mumble
conflicts = mumble
source = git+https://github.com/mumble-voip/mumble.git
- source = git+https://github.com/mumble-voip/celt-0.7.0.git
- source = git+https://github.com/mumble-voip/opus.git
- source = git+https://github.com/mumble-voip/speex.git
+ source = git+https://github.com/mumble-voip/minhook.git
+ source = git+https://github.com/mumble-voip/mach_override.git
+ source = git+https://github.com/mumble-voip/speexdsp.git
+ source = git+https://github.com/mumble-voip/rnnoise.git
+ source = git+https://github.com/Krzmbrzl/FindPythonInterpreter.git
+ source = git+https://github.com/wolfpld/tracy.git
+ source = git+https://github.com/ArthurSonzogni/nlohmann_json_cmake_fetchcontent
+ source = git+https://github.com/microsoft/GSL.git
+ source = git+https://github.com/rigtorp/SPSCQueue.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index eaa983aeb967..ad2a93edfa0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,10 +26,16 @@ optdepends=('speech-dispatcher: Text-to-Speech support'
provides=("$_pkgname")
conflicts=("$_pkgname")
source=('git+https://github.com/mumble-voip/mumble.git'
- 'git+https://github.com/mumble-voip/celt-0.7.0.git'
- 'git+https://github.com/mumble-voip/opus.git'
- 'git+https://github.com/mumble-voip/speex.git')
-sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
+ 'git+https://github.com/mumble-voip/minhook.git'
+ 'git+https://github.com/mumble-voip/mach_override.git'
+ 'git+https://github.com/mumble-voip/speexdsp.git'
+ 'git+https://github.com/mumble-voip/rnnoise.git'
+ 'git+https://github.com/Krzmbrzl/FindPythonInterpreter.git'
+ 'git+https://github.com/wolfpld/tracy.git'
+ 'git+https://github.com/ArthurSonzogni/nlohmann_json_cmake_fetchcontent'
+ 'git+https://github.com/microsoft/GSL.git'
+ 'git+https://github.com/rigtorp/SPSCQueue.git')
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$_pkgname"
@@ -38,12 +44,17 @@ pkgver() {
prepare() {
cd "$_pkgname"
-
git submodule init
- git config submodule.3rdparty/celt-0.7.0-src.url "$srcdir/celt"
- git config submodule.3rdparty/opus.url "$srcdir/opus"
- git config submodule.3rdparty/speex.url "$srcdir/speex"
- git submodule update
+ git config submodule.3rdparty/minhook.url "$srcdir/minhook"
+ git config submodule.3rdparty/mach-override-src.url "$srcdir/mach_override"
+ git config submodule.3rdparty/speexdsp.url "$srcdir/speexdsp"
+ git config submodule.3rdparty/rnnoise-src.url "$srcdir/rnnoise"
+ git config submodule.3rdparty/FindPythonInterpreter.url "$srcdir/FindPythonInterpreter"
+ git config submodule.3rdparty/tracy.url "$srcdir/tracy"
+ git config submodule.3rdparty/nlohmann_json.url "$srcdir/nlohmann_json_cmake_fetchcontent"
+ git config submodule.3rdparty/gsl.url "$srcdir/GSL"
+ git config submodule.3rdparty/SPSCQueue.url "$srcdir/SPSCQueue"
+ git -c protocol.file.allow=always submodule update
}
build() {