summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-01-27 20:42:02 -0800
committerxiota2024-01-27 20:42:33 -0800
commit870d1aab606c57efdc1b5262f0dbc8bbfbdcf219 (patch)
treeb5c1a0c9005de58830b172c43e0355fe9cd6265a
parentc8dcc8ff606ee8cee48e6ee06673c8956435c326 (diff)
downloadaur-870d1aab606c57efdc1b5262f0dbc8bbfbdcf219.tar.gz
115.7.0
-rw-r--r--.SRCINFO55
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD187
-rw-r--r--icecat-launcher.sh12
-rw-r--r--icecat-safe.desktop78
-rw-r--r--icecat.desktop78
-rw-r--r--icecat.install18
7 files changed, 162 insertions, 270 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 352aa298de30..4b4b317a589f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,50 +1,17 @@
pkgbase = icecat-bin
- pkgdesc = Binary build of the GNU version of the Mozilla Firefox browser
- pkgver = 60.7.0
- pkgrel = 2
- url = http://www.gnu.org/software/gnuzilla/
- arch = i686
+ pkgdesc = GNU version of the Firefox browser
+ pkgver = 115.7.0
+ pkgrel = 1
+ url = https://icecatbrowser.org
arch = x86_64
- license = GPL
- license = MPL
- license = LGPL
- depends = gtk2
- depends = mozilla-common
- depends = libxt
- depends = startup-notification
- depends = mime-types
- depends = dbus-glib
- depends = alsa-lib
- depends = desktop-file-utils
- depends = hicolor-icon-theme
- depends = libvpx
- depends = icu
- depends = libevent
- depends = nss
- depends = hunspell
- depends = sqlite
- depends = pango
- depends = freetype2
- depends = libxft
- depends = libx11
+ license = MPL-2.0
provides = icecat
conflicts = icecat
- replaces = icecat
- source = icecat.desktop
- source = icecat-safe.desktop
- source = icecat-launcher.sh
- validpgpkeys = 318C679D94F17700CC847DE646A70073E4E50D4E
- sha256sums = c44eab35f71dd3028a74632463710d674b2e8a0682e5e887535e3233a3b7bbb3
- sha256sums = 190577ad917bccfc89a9bcafbc331521f551b6f54e190bb6216eada48dcb1303
- sha256sums = b49fe5ba063002ad2cbf5e981b98d08e4157e20f5a4f00971a5f73eeca6ddbba
- source_i686 = https://ftp.gnu.org/gnu/gnuzilla/60.7.0/icecat-60.7.0.en-US.gnulinux-i686.tar.bz2
- source_i686 = https://ftp.gnu.org/gnu/gnuzilla/60.7.0/icecat-60.7.0.en-US.gnulinux-i686.tar.bz2.sig
- sha256sums_i686 = 8d3e3038ec1a1f5b871c5c54b97fb13bc42eb10f85ecd3b096529ed7d290f571
- sha256sums_i686 = SKIP
- source_x86_64 = https://ftp.gnu.org/gnu/gnuzilla/60.7.0/icecat-60.7.0.en-US.gnulinux-x86_64.tar.bz2
- source_x86_64 = https://ftp.gnu.org/gnu/gnuzilla/60.7.0/icecat-60.7.0.en-US.gnulinux-x86_64.tar.bz2.sig
- sha256sums_x86_64 = 4f0dffe7ae5d98a63bd44b2b0dbd39f93d60056391214e8565892ab1ade36a85
- sha256sums_x86_64 = SKIP
+ noextract = icecat-115.7.0.en-US.linux-x86_64.tar.bz2
+ source = https://icecatbrowser.org/assets/uploads/2024/01/icecat-115.7.0.en-US.linux-x86_64.tar.bz2
+ sha256sums = SKIP
pkgname = icecat-bin
-
+ depends = dbus-glib
+ depends = alsa-lib
+ depends = gtk3
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index fa0cad940f78..60cd4ef4e312 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,155 @@
+# Maintainer:
# Contributor: Figue <ffigue at gmail dot com>
-# Thank you to person that wrote this package in AUR3, I can't figure out who was.
-
-pkgname=icecat-bin
-_pkgname=icecat
-pkgver=60.7.0
-_pkgver=${pkgver}-gnu1
-pkgrel=2
-pkgdesc="Binary build of the GNU version of the Mozilla Firefox browser"
-arch=('i686' 'x86_64')
-url="http://www.gnu.org/software/gnuzilla/"
-license=('GPL' 'MPL' 'LGPL')
-depends=('gtk2' 'mozilla-common' 'libxt' 'startup-notification' 'mime-types'
- 'dbus-glib' 'alsa-lib' 'desktop-file-utils' 'hicolor-icon-theme'
- 'libvpx' 'icu' 'libevent' 'nss' 'hunspell' 'sqlite' 'pango' 'freetype2' 'libxft' 'libx11')
-makedepends=()
+
+## useful links
+# https://icecatbrowser.org/
+# https://www.gnu.org/software/gnuzilla/
+# https://git.savannah.gnu.org/cgit/gnuzilla.git
+# https://software.classictetris.net/icecat/
+
+## options
+: ${_build_bin:=true}
+
+[[ "${_build_bin::1}" == "t" ]] && _pkgtype+="-bin"
+
+## basic info
+_pkgname="icecat"
+pkgname="$_pkgname${_pkgtype:-}"
+pkgver=115.7.0
+pkgrel=1
+pkgdesc="GNU version of the Firefox browser"
+url="https://icecatbrowser.org"
+license=('MPL-2.0')
+arch=('x86_64')
+
provides=('icecat')
conflicts=('icecat')
-replaces=('icecat')
-source_x86_64=(https://ftp.gnu.org/gnu/gnuzilla/$pkgver/$_pkgname-$pkgver.en-US.gnulinux-x86_64.tar.bz2{,.sig})
-source_i686=(https://ftp.gnu.org/gnu/gnuzilla/$pkgver/$_pkgname-$pkgver.en-US.gnulinux-i686.tar.bz2{,.sig})
-source=($_pkgname.desktop
- $_pkgname-safe.desktop
- $_pkgname-launcher.sh)
-
-sha256sums=('c44eab35f71dd3028a74632463710d674b2e8a0682e5e887535e3233a3b7bbb3'
- '190577ad917bccfc89a9bcafbc331521f551b6f54e190bb6216eada48dcb1303'
- 'b49fe5ba063002ad2cbf5e981b98d08e4157e20f5a4f00971a5f73eeca6ddbba')
-sha256sums_i686=('8d3e3038ec1a1f5b871c5c54b97fb13bc42eb10f85ecd3b096529ed7d290f571'
- 'SKIP')
-sha256sums_x86_64=('4f0dffe7ae5d98a63bd44b2b0dbd39f93d60056391214e8565892ab1ade36a85'
- 'SKIP')
-
-validpgpkeys=(318C679D94F17700CC847DE646A70073E4E50D4E) # Ruben Rodriguez (GNU IceCat releases key) <ruben@gnu.org>
+
+_dl_url="https://icecatbrowser.org/assets/uploads/2024/01"
+_dl_file="icecat-$pkgver.en-US.linux-$CARCH.tar.bz2"
+
+noextract=("$_dl_file")
+
+source=("$_dl_url/$_dl_file")
+sha256sums=('SKIP')
+
+prepare() {
+ cat >icecat.desktop <<END
+[Desktop Entry]
+Version=1.0
+Name=IceCat
+GenericName=Web Browser
+Comment=Browse the World Wide Web
+Keywords=Internet;WWW;Browser;Web;Explorer
+Exec=icecat %u
+Icon=icecat
+Terminal=false
+X-MultipleArgs=false
+Type=Application
+MimeType=text/html;text/xml;application/xhtml+xml;x-scheme-handler/http;x-scheme-handler/https;application/x-xpinstall;
+StartupNotify=true
+StartupWMClass=icecat
+Categories=Network;WebBrowser;
+Actions=new-window;new-private-window;safe-mode;
+
+[Desktop Action new-window]
+Name=New Window
+Exec=icecat --new-window %u
+
+[Desktop Action new-private-window]
+Name=New Private Window
+Exec=icecat --private-window %u
+
+[Desktop Action safe-mode]
+Name=Safe Mode
+Exec=icecat -safe-mode %u
+END
+}
package() {
- install -d $pkgdir/usr/lib/$_pkgname
+ depends=(
+ 'dbus-glib'
+ 'alsa-lib'
+ 'gtk3'
+
+ ## implicit
+ #at-spi2-core
+ #cairo
+ #dbus
+ #fontconfig
+ #freetype2
+ #gdk-pixbuf2
+ #glib2
+ #harfbuzz
+ #libx11
+ #libxcb
+ #libxcomposite
+ #libxcursor
+ #libxdamage
+ #libxext
+ #libxfixes
+ #libxi
+ #libxrandr
+ #libxrender
+ #libxtst
+ #pango
+ #zlib
+ )
+
+ local _install_path="opt"
+
+ # app
+ install -dm755 "$pkgdir/$_install_path"
+ bsdtar -C "$pkgdir/$_install_path" -xf "$srcdir/$_dl_file"
+
+ # duplicate binary
+ ln -sf "$_pkgname" "$pkgdir/$_install_path/$_pkgname/$_pkgname-bin"
+
+ # symlink
+ install -dm755 "$pkgdir/usr/bin"
+ ln -sf "/$_install_path/$_pkgname/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+
+ # desktop file
+ install -Dm644 "$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+
+ # icon
+ install -Dm755 "$pkgdir/$_install_path/$_pkgname/browser/chrome/icons/default/default128.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
+
+ # fix permissions
+ chmod -R u+rwX,go+rX,go-w "$pkgdir/"
+
+ # disable auto-updates
+ local _policies_json="$pkgdir/$_install_path/$_pkgname/distribution/policies.json"
+ install -Dvm644 /dev/stdin "$_policies_json" <<END
+{
+ "policies": {
+ "DisableAppUpdate": true
+ }
+}
+END
+
+ # custom defaults
+ local vendorjs="$pkgdir/$_install_path/$_pkgname/browser/defaults/preferences/vendor.js"
+ install -Dvm644 /dev/stdin "$vendorjs" <<END
+// Use LANG environment variable to choose locale
+pref("intl.locale.requested", "");
+
+// Use system-provided dictionaries
+pref("spellchecker.dictionary_path", "/usr/share/hunspell");
+
+// Disable default browser checking.
+pref("browser.shell.checkDefaultBrowser", false);
+
+// Don't disable extensions in the application directory
+pref("extensions.autoDisableScopes", 11);
+
+// Enable JPEG XL images
+pref("image.jxl.enabled", true);
- cp -a $srcdir/$_pkgname/* $pkgdir/usr/lib/$_pkgname/
+// Prevent about:config warning
+pref("browser.aboutConfig.showWarning", false);
- install -d $pkgdir/usr/share/applications
- install -m644 $srcdir/$_pkgname.desktop $pkgdir/usr/share/applications
- install -m644 $srcdir/$_pkgname-safe.desktop $pkgdir/usr/share/applications
- install -d $pkgdir/usr/share/pixmaps
- install -m644 $srcdir/$_pkgname/browser/chrome/icons/default/default128.png $pkgdir/usr/share/pixmaps/$_pkgname.png
- install -d $pkgdir/usr/bin/
- install -m755 $srcdir/$_pkgname-launcher.sh $pkgdir/usr/bin/$_pkgname
+// Prevent telemetry notification
+pref("services.settings.main.search-telemetry-v2.last_check", $(date +%s));
+END
}
diff --git a/icecat-launcher.sh b/icecat-launcher.sh
deleted file mode 100644
index 838f5f416542..000000000000
--- a/icecat-launcher.sh
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/bin/bash
-
- [ "${ICECATDIR}" == "" ] && export ICECATDIR="/usr/lib/icecat"
- export LD_LIBRARY_PATH=${ICECATDIR}:${LD_LIBRARY_PATH}
- export MOZILLA_FIVE_HOME=${ICECATDIR}
- export MOZ_PLUGIN_PATH=${ICECATDIR}/plugins/
- export MOZ_DISABLE_GNOME=1
- [ "${GNOME_DESKTOP_SESSION_ID}" != "" ] && export MOZ_DISABLE_GNOME=0
- export PREVIOUSPATH=${PATH}
- export PATH=${ICECATDIR}:${PATH}
- cd ${ICECATDIR}
- ${ICECATDIR}/icecat $@
diff --git a/icecat-safe.desktop b/icecat-safe.desktop
deleted file mode 100644
index 87acc970c165..000000000000
--- a/icecat-safe.desktop
+++ /dev/null
@@ -1,78 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Exec=/usr/bin/icecat -safe-mode %u
-Icon=icecat
-Type=Application
-Terminal=false
-MultipleArgs=false
-Name=GNU IceCat - Safe Mode
-GenericName=Web Browser
-GenericName[af]=Web Blaaier
-GenericName[ar]=متصفح ويب
-GenericName[az]=Veb Səyyahı
-GenericName[bg]=Браузър
-GenericName[bn]=ওয়েব ব্রাউজার
-GenericName[br]=Furcher ar Gwiad
-GenericName[bs]=WWW Preglednik
-GenericName[ca]=Fullejador web
-GenericName[cs]=WWW prohlížeč
-GenericName[cy]=Porydd Gwe
-GenericName[da]=Browser
-GenericName[de]=Web-Browser
-GenericName[el]=Περιηγητής Ιστού
-GenericName[eo]=TTT-legilo
-GenericName[es]=Navegador web
-GenericName[et]=Veebilehitseja
-GenericName[eu]=Web arakatzailea
-GenericName[fa]=مرورگر وب
-GenericName[fi]=WWW-selain
-GenericName[fo]=Alnótsfar
-GenericName[fr]=Navigateur web
-GenericName[gl]=Navegador Web
-GenericName[he]=דפדפן אינטרנט
-GenericName[hi]=वेब ब्राउज़र
-GenericName[hr]=Web preglednik
-GenericName[hu]=Webböngésző
-GenericName[is]=Vafri
-GenericName[it]=Browser Web
-GenericName[ja]=ウェブブラウザ
-GenericName[ko]=웹 브라우저
-GenericName[lo]=ເວັບບຣາວເຊີ
-GenericName[lt]=Žiniatinklio naršyklė
-GenericName[lv]=Web Pārlūks
-GenericName[mk]=Прелистувач на Интернет
-GenericName[mn]=Веб-Хөтөч
-GenericName[nb]=Nettleser
-GenericName[nds]=Nettkieker
-GenericName[nl]=Webbrowser
-GenericName[nn]=Nettlesar
-GenericName[nso]=Seinyakisi sa Web
-GenericName[pa]=ਵੈਬ ਝਲਕਾਰਾ
-GenericName[pl]=Przeglądarka WWW
-GenericName[pt]=Navegador Web
-GenericName[pt_BR]=Navegador Web
-GenericName[ro]=Navigator de web
-GenericName[ru]=Веб-браузер
-GenericName[se]=Fierpmádatlogan
-GenericName[sk]=Webový prehliadač
-GenericName[sl]=Spletni brskalnik
-GenericName[sr]=Веб претраживач
-GenericName[sr@Latn]=Veb pretraživač
-GenericName[ss]=Ibrawuza yeWeb
-GenericName[sv]=Webbläsare
-GenericName[ta]=வலை உலாவி
-GenericName[tg]=Тафсиргари вэб
-GenericName[th]=เว็บบราวเซอร์
-GenericName[tr]=Web Tarayıcı
-GenericName[uk]=Навігатор Тенет
-GenericName[uz]=Веб-браузер
-GenericName[ven]=Buronza ya Webu
-GenericName[vi]=Trình duyệt Web
-GenericName[wa]=Betchteu waibe
-GenericName[xh]=Umkhangeli zincwadi we Web
-GenericName[zh_CN]=网页浏览器
-GenericName[zh_TW]=網頁瀏覽器
-GenericName[zu]=Umcingi we-Web
-MimeType=text/html
-StartupNotify=false
-Categories=Application;Network;
diff --git a/icecat.desktop b/icecat.desktop
deleted file mode 100644
index 8a7cad93d113..000000000000
--- a/icecat.desktop
+++ /dev/null
@@ -1,78 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Exec=/usr/bin/icecat %u
-Icon=icecat
-Type=Application
-Terminal=false
-MultipleArgs=false
-Name=GNU IceCat
-GenericName=Web Browser
-GenericName[af]=Web Blaaier
-GenericName[ar]=متصفح ويب
-GenericName[az]=Veb Səyyahı
-GenericName[bg]=Браузър
-GenericName[bn]=ওয়েব ব্রাউজার
-GenericName[br]=Furcher ar Gwiad
-GenericName[bs]=WWW Preglednik
-GenericName[ca]=Fullejador web
-GenericName[cs]=WWW prohlížeč
-GenericName[cy]=Porydd Gwe
-GenericName[da]=Browser
-GenericName[de]=Web-Browser
-GenericName[el]=Περιηγητής Ιστού
-GenericName[eo]=TTT-legilo
-GenericName[es]=Navegador web
-GenericName[et]=Veebilehitseja
-GenericName[eu]=Web arakatzailea
-GenericName[fa]=مرورگر وب
-GenericName[fi]=WWW-selain
-GenericName[fo]=Alnótsfar
-GenericName[fr]=Navigateur web
-GenericName[gl]=Navegador Web
-GenericName[he]=דפדפן אינטרנט
-GenericName[hi]=वेब ब्राउज़र
-GenericName[hr]=Web preglednik
-GenericName[hu]=Webböngésző
-GenericName[is]=Vafri
-GenericName[it]=Browser Web
-GenericName[ja]=ウェブブラウザ
-GenericName[ko]=웹 브라우저
-GenericName[lo]=ເວັບບຣາວເຊີ
-GenericName[lt]=Žiniatinklio naršyklė
-GenericName[lv]=Web Pārlūks
-GenericName[mk]=Прелистувач на Интернет
-GenericName[mn]=Веб-Хөтөч
-GenericName[nb]=Nettleser
-GenericName[nds]=Nettkieker
-GenericName[nl]=Webbrowser
-GenericName[nn]=Nettlesar
-GenericName[nso]=Seinyakisi sa Web
-GenericName[pa]=ਵੈਬ ਝਲਕਾਰਾ
-GenericName[pl]=Przeglądarka WWW
-GenericName[pt]=Navegador Web
-GenericName[pt_BR]=Navegador Web
-GenericName[ro]=Navigator de web
-GenericName[ru]=Веб-браузер
-GenericName[se]=Fierpmádatlogan
-GenericName[sk]=Webový prehliadač
-GenericName[sl]=Spletni brskalnik
-GenericName[sr]=Веб претраживач
-GenericName[sr@Latn]=Veb pretraživač
-GenericName[ss]=Ibrawuza yeWeb
-GenericName[sv]=Webbläsare
-GenericName[ta]=வலை உலாவி
-GenericName[tg]=Тафсиргари вэб
-GenericName[th]=เว็บบราวเซอร์
-GenericName[tr]=Web Tarayıcı
-GenericName[uk]=Навігатор Тенет
-GenericName[uz]=Веб-браузер
-GenericName[ven]=Buronza ya Webu
-GenericName[vi]=Trình duyệt Web
-GenericName[wa]=Betchteu waibe
-GenericName[xh]=Umkhangeli zincwadi we Web
-GenericName[zh_CN]=网页浏览器
-GenericName[zh_TW]=網頁瀏覽器
-GenericName[zu]=Umcingi we-Web
-MimeType=text/html
-StartupNotify=false
-Categories=Application;Network;
diff --git a/icecat.install b/icecat.install
deleted file mode 100644
index 7b344b320d66..000000000000
--- a/icecat.install
+++ /dev/null
@@ -1,18 +0,0 @@
-post_install () {
- update-desktop-database -q
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- update-desktop-database -q
-}
-
-post_remove() {
- update-desktop-database -q
-}
-
-#op=$1
-#shift
-
-#$op $*