summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2016-03-12 01:01:16 +0100
committeranthraxx2016-03-12 01:01:16 +0100
commit8719b62dd7e08139e0890e38afbb6310dc0997e7 (patch)
tree8897ee20e0a197e07451f7911f89ce5173dd4ada
parent1d95476ae3131cea804fe577ab2c742bd02afc14 (diff)
downloadaur-8719b62dd7e08139e0890e38afbb6310dc0997e7.tar.gz
upgpkg: scanmem-git 0.15.4.20.g063c588-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--drop-gtk-update-icon.patch16
3 files changed, 31 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3fe3ce5d95a..70036433f7b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sat Mar 12 00:01:16 UTC 2016
pkgbase = scanmem-git
pkgdesc = Memory scanner designed to isolate the address of an arbitrary variable in an executing process
- pkgver = 0.15.2.6.g5cf1f26
+ pkgver = 0.15.4.20.g063c588
pkgrel = 1
url = https://github.com/scanmem/scanmem
install = scanmem.install
@@ -15,7 +17,9 @@ pkgbase = scanmem-git
provides = scanmem
conflicts = scanmem
source = scanmem-git::git+https://github.com/scanmem/scanmem.git
+ source = drop-gtk-update-icon.patch
sha512sums = SKIP
+ sha512sums = 5df78e2dcdaf5c2bf355911f9851375ffeed819dd50bfdc47c5cb8096eaa9b7aa69b7852b937b782661e27d213d8543309dedd92ada38e225fd1375e3f12fe3c
pkgname = scanmem-git
diff --git a/PKGBUILD b/PKGBUILD
index cb9b40e4f590..1e37cf8e6072 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Allen Choong <allencch at hotmail dot com>
pkgname=scanmem-git
-pkgver=0.15.2.6.g5cf1f26
+pkgver=0.15.4.20.g063c588
pkgrel=1
pkgdesc="Memory scanner designed to isolate the address of an arbitrary variable in an executing process"
url="https://github.com/scanmem/scanmem"
@@ -13,14 +13,21 @@ conflicts=('scanmem')
depends=('pygtk' 'python-gobject' 'polkit')
makedepends=('git' 'intltool')
install=scanmem.install
-source=(${pkgname}::git+https://github.com/scanmem/scanmem.git)
-sha512sums=('SKIP')
+source=(${pkgname}::git+https://github.com/scanmem/scanmem.git
+ drop-gtk-update-icon.patch)
+sha512sums=('SKIP'
+ '5df78e2dcdaf5c2bf355911f9851375ffeed819dd50bfdc47c5cb8096eaa9b7aa69b7852b937b782661e27d213d8543309dedd92ada38e225fd1375e3f12fe3c')
pkgver() {
cd ${pkgname}
git describe --always|sed 's|-|.|g'|sed -r 's|v(.*)|\1|'
}
+prepare() {
+ cd ${pkgname}
+ patch -Rp1 < "${srcdir}/drop-gtk-update-icon.patch"
+}
+
build() {
cd ${pkgname}
./autogen.sh
diff --git a/drop-gtk-update-icon.patch b/drop-gtk-update-icon.patch
new file mode 100644
index 000000000000..b005f02a1e09
--- /dev/null
+++ b/drop-gtk-update-icon.patch
@@ -0,0 +1,16 @@
+ gui/icons/Makefile.am | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/gui/icons/Makefile.am b/gui/icons/Makefile.am
+index e67c987..678d43f 100644
+--- a/gui/icons/Makefile.am
++++ b/gui/icons/Makefile.am
+@@ -6,3 +6,8 @@ EXTRA_DIST = $(icons48_DATA) $(icons72_DATA) $(icons128_DATA)
+ icon48dir = $(datadir)/icons/hicolor/48x48/apps
+ icon72dir = $(datadir)/icons/hicolor/72x72/apps
+ icon128dir = $(datadir)/icons/hicolor/128x128/apps
++
++install-data-hook:
++ if [ -n "`which gtk-update-icon-cache`" ]; then \
++ gtk-update-icon-cache $(datadir)/icons/hicolor; \
++ fi