summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2023-12-21 13:45:07 +0100
committerCarl Smedstad2023-12-21 13:45:07 +0100
commit877dee1c32267641d62605027705d665374177e3 (patch)
tree962c06ccc3056a08d3a46141b98e1ebce65830c1
parent7cc9c2856a6209ddecc752e7ca365309709946f5 (diff)
downloadaur-877dee1c32267641d62605027705d665374177e3.tar.gz
Publish version 10.22.1-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
-rw-r--r--fix-lifecyclemgr-nil-error.patch15
-rw-r--r--remove-version-check.patch54
4 files changed, 8 insertions, 96 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4176d704851..0435f5f3e84a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = azcopy
pkgdesc = A command-line utility designed for copying data to/from Microsoft Azure
- pkgver = 10.22.0
- pkgrel = 2
+ pkgver = 10.22.1
+ pkgrel = 1
url = https://github.com/Azure/azure-storage-azcopy
arch = x86_64
arch = i686
@@ -12,11 +12,7 @@ pkgbase = azcopy
license = MIT
makedepends = go
depends = glibc
- source = azcopy-10.22.0.tar.gz::https://github.com/Azure/azure-storage-azcopy/archive/v10.22.0.tar.gz
- source = remove-version-check.patch
- source = fix-lifecyclemgr-nil-error.patch
- sha512sums = e066a949098ba03770691cf7686e28c1adfdb8dca36f09933a0c5c3cde9dbd24e7e41ac4bc95c0bb35f3e01d2c68de75628aebae173f0e8d676be683965fcebf
- sha512sums = d436770cf67213fd7118992d6c04a06e5604482b24213441296f2e18fe4653301652958019f7efeb460e54e3b673feb4cf5b1228d893ee39a81f55c9c0799e94
- sha512sums = 524a0f75c3a736623fdf344f8b1d406557ed34c3582958f1a3c3ca222931b3edc0f727acf04d73f877951163e62e1ca3441bf579afef491bdde037901273ff90
+ source = azcopy-10.22.1.tar.gz::https://github.com/Azure/azure-storage-azcopy/archive/v10.22.1.tar.gz
+ sha512sums = 139913d6c9e3591cce8cd05df5d97d8ace2f294716b34003f37b6beb3a8ff4d93f7e1ae9ddabd7dbec66e113a16df6fbc6046f8a340117cf6d53eae5e6fa0b77
pkgname = azcopy
diff --git a/PKGBUILD b/PKGBUILD
index 826ec823d036..ef5edcb54789 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,35 +5,20 @@
# Contributor: Jonas Heinrich <onny@project-insanity.org>
pkgname=azcopy
-pkgver=10.22.0
-pkgrel=2
+pkgver=10.22.1
+pkgrel=1
pkgdesc="A command-line utility designed for copying data to/from Microsoft Azure"
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/Azure/azure-storage-azcopy"
license=('MIT')
depends=('glibc')
makedepends=('go')
-source=(
- "${pkgname}-${pkgver}.tar.gz::$url/archive/v${pkgver}.tar.gz"
- "remove-version-check.patch"
- "fix-lifecyclemgr-nil-error.patch"
-)
-sha512sums=(
- 'e066a949098ba03770691cf7686e28c1adfdb8dca36f09933a0c5c3cde9dbd24e7e41ac4bc95c0bb35f3e01d2c68de75628aebae173f0e8d676be683965fcebf'
- 'd436770cf67213fd7118992d6c04a06e5604482b24213441296f2e18fe4653301652958019f7efeb460e54e3b673feb4cf5b1228d893ee39a81f55c9c0799e94'
- '524a0f75c3a736623fdf344f8b1d406557ed34c3582958f1a3c3ca222931b3edc0f727acf04d73f877951163e62e1ca3441bf579afef491bdde037901273ff90'
-)
+source=("${pkgname}-${pkgver}.tar.gz::$url/archive/v${pkgver}.tar.gz")
+sha512sums=('139913d6c9e3591cce8cd05df5d97d8ace2f294716b34003f37b6beb3a8ff4d93f7e1ae9ddabd7dbec66e113a16df6fbc6046f8a340117cf6d53eae5e6fa0b77')
prepare() {
cd "${srcdir}/azure-storage-azcopy-${pkgver}"
- # Due to the version check, each invocation takes ~8 seconds. See:
- # https://github.com/Azure/azure-storage-azcopy/issues/2482
- patch --forward --strip=1 --input="$srcdir/remove-version-check.patch"
-
- # Fix intermittent nil pointer dereference in common/lifecyleMgr.go:375.
- patch --forward --strip=1 --input="$srcdir/fix-lifecyclemgr-nil-error.patch"
-
# Avoid downloading Go dependencies in build() by doing it here instead
go mod download -x
}
diff --git a/fix-lifecyclemgr-nil-error.patch b/fix-lifecyclemgr-nil-error.patch
deleted file mode 100644
index 4d432c080479..000000000000
--- a/fix-lifecyclemgr-nil-error.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/common/lifecyleMgr.go b/common/lifecyleMgr.go
-index 57ba87d7..ed0a5f9e 100644
---- a/common/lifecyleMgr.go
-+++ b/common/lifecyleMgr.go
-@@ -372,7 +372,9 @@ func (lcm *lifecycleMgr) Exit(o OutputBuilder, applicationExitCode ExitCode) {
- exitCode: applicationExitCode,
- }
-
-- AzcopyCurrentJobLogger.CloseLog()
-+ if AzcopyCurrentJobLogger != nil {
-+ AzcopyCurrentJobLogger.CloseLog()
-+ }
- if applicationExitCode != EExitCode.NoExit() {
- // stall forever until the success message is printed and program exits
- lcm.SurrenderControl()
diff --git a/remove-version-check.patch b/remove-version-check.patch
deleted file mode 100644
index bdab0764a7e8..000000000000
--- a/remove-version-check.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-diff --git a/cmd/root.go b/cmd/root.go
-index 621c25e7..f3f8fa0d 100644
---- a/cmd/root.go
-+++ b/cmd/root.go
-@@ -54,7 +54,6 @@ var azcopyAwaitContinue bool
- var azcopyAwaitAllowOpenFiles bool
- var azcopyScanningLogger common.ILoggerResetable
- var azcopyCurrentJobID common.JobID
--var azcopySkipVersionCheck bool
- var retryStatusCodes string
-
- type jobLoggerInfo struct {
-@@ -161,15 +160,6 @@ var rootCmd = &cobra.Command{
- common.IncludeAfterFlagName, IncludeAfterDateFilter{}.FormatAsUTC(adjustedTime))
- jobsAdmin.JobsAdmin.LogToJobLog(startTimeMessage, common.LogInfo)
-
-- if !azcopySkipVersionCheck {
-- // spawn a routine to fetch and compare the local application's version against the latest version available
-- // if there's a newer version that can be used, then write the suggestion to stderr
-- // however if this takes too long the message won't get printed
-- // Note: this function is necessary for non-help, non-login commands, since they don't reach the corresponding
-- // beginDetectNewVersion call in Execute (below)
-- beginDetectNewVersion()
-- }
--
- if debugSkipFiles != "" {
- for _, v := range strings.Split(debugSkipFiles, ";") {
- if strings.HasPrefix(v, "/") {
-@@ -201,16 +191,6 @@ func Execute(logPathFolder, jobPlanFolder string, maxFileAndSocketHandles int, j
- if err := rootCmd.Execute(); err != nil {
- glcm.Error(err.Error())
- } else {
-- if !azcopySkipVersionCheck {
-- // our commands all control their own life explicitly with the lifecycle manager
-- // only commands that don't explicitly exit actually reach this point (e.g. help commands and login commands)
-- select {
-- case <-beginDetectNewVersion():
-- // noop
-- case <-time.After(time.Second * 8):
-- // don't wait too long
-- }
-- }
- glcm.Exit(nil, common.EExitCode.Success())
- }
- }
-@@ -227,8 +207,6 @@ func init() {
- rootCmd.PersistentFlags().StringVar(&cmdLineExtraSuffixesAAD, trustedSuffixesNameAAD, "", "Specifies additional domain suffixes where Azure Active Directory login tokens may be sent. The default is '"+
- trustedSuffixesAAD+"'. Any listed here are added to the default. For security, you should only put Microsoft Azure domains here. Separate multiple entries with semi-colons.")
-
-- rootCmd.PersistentFlags().BoolVar(&azcopySkipVersionCheck, "skip-version-check", false, "Do not perform the version check at startup. Intended for automation scenarios & airgapped use.")
--
- // Note: this is due to Windows not supporting signals properly
- rootCmd.PersistentFlags().BoolVar(&cancelFromStdin, "cancel-from-stdin", false, "Used by partner teams to send in `cancel` through stdin to stop a job.")
-