summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Wild2018-10-11 21:19:46 -0400
committerAllen Wild2018-10-11 21:19:46 -0400
commit87a955f58ef2a0b951f14bd3be530786323b674f (patch)
tree963eba8bd83be2f087b4c9e052d56bc7829e719b
parent36ae044da50764c527cbeae64036c487dc27d927 (diff)
downloadaur-87a955f58ef2a0b951f14bd3be530786323b674f.tar.gz
1.4.2-2: sync with [community]
-rw-r--r--.SRCINFO10
-rw-r--r--CMakeLists.inj13
-rw-r--r--PKGBUILD16
-rw-r--r--no-gtk2.patch9
-rw-r--r--tdesktop.patch29
5 files changed, 31 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b6f5f7db01c..4f977e3294a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = telegram-desktop-systemqt-notoemoji
pkgdesc = Official Telegram Desktop client (with noto emoji)
pkgver = 1.4.2
- pkgrel = 1
+ pkgrel = 2
url = https://desktop.telegram.org/
arch = x86_64
license = GPL3
@@ -24,8 +24,8 @@ pkgbase = telegram-desktop-systemqt-notoemoji
source = tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v1.4.2
source = libtgvoip::git+https://github.com/telegramdesktop/libtgvoip
source = variant::git+https://github.com/mapbox/variant
- source = GSL::git+https://github.com/Microsoft/GSL.git
source = Catch::git+https://github.com/philsquared/Catch
+ source = GSL::git+https://github.com/Microsoft/GSL.git
source = crl::git+https://github.com/telegramdesktop/crl.git
source = xxHash::git+https://github.com/Cyan4973/xxHash.git
source = https://s3.amazonaws.com/aur-telegram-desktop-notoemoji/noto-emoji-v1.tar.xz
@@ -45,9 +45,9 @@ pkgbase = telegram-desktop-systemqt-notoemoji
sha512sums = 376a4860e37b0f60892f362e954f976a563c632579167003b4aacbb24b6fea6aabb4e6952baf6d1a546b961936935cc49cf0e0ce9570320245b6bb326cb149e5
sha512sums = fa7042f370ae4e2e14d083395743cdee25bfedc39ab5273b5d1ab12fb074757cf76dab065f2abcb44cad018920e711142fbf24a2b9cd30f517c5a5b46d6a6182
sha512sums = b87414ceaae19185a8a5749cea1f6d9f3fc3c69b8dd729e3db8790cde00b987c3c827cd30baf0eac579d1884e34aa2f37bb90778c3c0bc9ca211d75a82891b9d
- sha512sums = 95f6fe5e39a8c376280be93c93d92511c2bc5d6172e85059aa2e7e5adce86aa47003c97230f7cfa4076f2189dc0364da2d789d1f02b70824792cc082cfab0175
- sha512sums = aab565816649f0157ff69636fd92ed434f30bd72554fc86db3151855de04e67b2d9ff8ff9735ed50f05510ea16dee79e134c9b26652e89522b4ffa8dddf09bcf
- sha512sums = c05351aa9f6503daa6ef8b01adb73c7e71fd01377d833f47f826e184d78dd79628ce7c686ae23a40b7468adcd5af0af9ebce4783113957b6126892aca83c7712
+ sha512sums = b20674f61ff6378749d1f59a6a0da194d33ccc786bd783f6ed62027924a3a8a8d27c9763bf376480432d6536896b0c7eeb8c495c5b8cefff7cf5fe84da50947e
+ sha512sums = 47c0d1e00401d7899b2ce710c06ceac6caffddbe1a4c85bc407918b43051cba292f6e6131cc0f390a66520e92f0ffa3761f8d973a25986dfe21c54f113062c33
+ sha512sums = 7a37e0ca582145a56a411585aec0bc94889dc18a80cc038d2efa237e19eebf8b67d56825e068be88f7566b08316ce068d7f20c25729caa33d0e9d6c370325025
sha512sums = d60694dc701aa985b0e82a12c9732b945082470441c687b33167a94f94efcf253baf43bb7280ec160ba338485ee5c62de138e4804cae05f27cc5cf4298166d39
pkgname = telegram-desktop-systemqt-notoemoji
diff --git a/CMakeLists.inj b/CMakeLists.inj
index df938511ae1c..20b2688ba775 100644
--- a/CMakeLists.inj
+++ b/CMakeLists.inj
@@ -1,5 +1,4 @@
-# ------------- debian/CMakeLists.inj begin -------------
-# The text will be putted into the appropriate CMakeLists by debian/rules script
+# The text will be put into the appropriate CMakeLists by the PKGBUILD
# Avoid rpath compiler parameter
set_target_properties(Telegram PROPERTIES SKIP_BUILD_RPATH TRUE)
@@ -8,10 +7,12 @@ set_target_properties(Telegram PROPERTIES SKIP_BUILD_RPATH TRUE)
# Telegram/Patches/gyp.diff file will be changed in future, please check these
# lines.
include(../../Telegram/gyp/PrecompiledHeader.cmake)
-add_precompiled_header(Telegram ../../Telegram/SourceFiles/stdafx.h)
-add_precompiled_header(lib_base ../../Telegram/SourceFiles/base/base_pch.h)
-add_precompiled_header(lib_export ../../Telegram/SourceFiles/export/export_pch.h)
+add_precompiled_header(Telegram ../../Telegram/SourceFiles/stdafx.h)
+add_precompiled_header(lib_base ../../Telegram/SourceFiles/base/base_pch.h)
+add_precompiled_header(lib_export ../../Telegram/SourceFiles/export/export_pch.h)
add_precompiled_header(lib_storage ../../Telegram/SourceFiles/storage/storage_pch.h)
+# You can discover new PCHs using this link:
+# https://github.com/telegramdesktop/tdesktop/search?q=pch_header&unscoped_q=pch_header
+
# vim: ft=cmake
-# -------------- debian/CMakeLists.inj end --------------
diff --git a/PKGBUILD b/PKGBUILD
index e0ccc6369c5c..cbb7da7c41c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=telegram-desktop-systemqt-notoemoji
pkgver=1.4.2
-pkgrel=1
+pkgrel=2
pkgdesc='Official Telegram Desktop client (with noto emoji)'
arch=('x86_64')
url="https://desktop.telegram.org/"
@@ -23,8 +23,8 @@ source=(
"tdesktop::git+https://github.com/telegramdesktop/tdesktop.git#tag=v$pkgver"
"libtgvoip::git+https://github.com/telegramdesktop/libtgvoip"
"variant::git+https://github.com/mapbox/variant"
- "GSL::git+https://github.com/Microsoft/GSL.git"
"Catch::git+https://github.com/philsquared/Catch"
+ "GSL::git+https://github.com/Microsoft/GSL.git"
"crl::git+https://github.com/telegramdesktop/crl.git"
"xxHash::git+https://github.com/Cyan4973/xxHash.git"
"https://s3.amazonaws.com/aur-telegram-desktop-notoemoji/noto-emoji-${_emojiver}.tar.xz"
@@ -45,17 +45,17 @@ sha512sums=('SKIP'
'376a4860e37b0f60892f362e954f976a563c632579167003b4aacbb24b6fea6aabb4e6952baf6d1a546b961936935cc49cf0e0ce9570320245b6bb326cb149e5'
'fa7042f370ae4e2e14d083395743cdee25bfedc39ab5273b5d1ab12fb074757cf76dab065f2abcb44cad018920e711142fbf24a2b9cd30f517c5a5b46d6a6182'
'b87414ceaae19185a8a5749cea1f6d9f3fc3c69b8dd729e3db8790cde00b987c3c827cd30baf0eac579d1884e34aa2f37bb90778c3c0bc9ca211d75a82891b9d'
- '95f6fe5e39a8c376280be93c93d92511c2bc5d6172e85059aa2e7e5adce86aa47003c97230f7cfa4076f2189dc0364da2d789d1f02b70824792cc082cfab0175'
- 'aab565816649f0157ff69636fd92ed434f30bd72554fc86db3151855de04e67b2d9ff8ff9735ed50f05510ea16dee79e134c9b26652e89522b4ffa8dddf09bcf'
- 'c05351aa9f6503daa6ef8b01adb73c7e71fd01377d833f47f826e184d78dd79628ce7c686ae23a40b7468adcd5af0af9ebce4783113957b6126892aca83c7712'
+ 'b20674f61ff6378749d1f59a6a0da194d33ccc786bd783f6ed62027924a3a8a8d27c9763bf376480432d6536896b0c7eeb8c495c5b8cefff7cf5fe84da50947e'
+ '47c0d1e00401d7899b2ce710c06ceac6caffddbe1a4c85bc407918b43051cba292f6e6131cc0f390a66520e92f0ffa3761f8d973a25986dfe21c54f113062c33'
+ '7a37e0ca582145a56a411585aec0bc94889dc18a80cc038d2efa237e19eebf8b67d56825e068be88f7566b08316ce068d7f20c25729caa33d0e9d6c370325025'
'd60694dc701aa985b0e82a12c9732b945082470441c687b33167a94f94efcf253baf43bb7280ec160ba338485ee5c62de138e4804cae05f27cc5cf4298166d39')
prepare() {
cd "$srcdir/tdesktop"
git submodule init
- git config submodule.Telegram/ThirdParty/GSL.url "$srcdir/GSL"
- git config submodule.Telegram/ThirdParty/variant.url "$srcdir/variant"
git config submodule.Telegram/ThirdParty/libtgvoip.url "$srcdir/libtgvoip"
+ git config submodule.Telegram/ThirdParty/variant.url "$srcdir/variant"
+ git config submodule.Telegram/ThirdParty/GSL.url "$srcdir/GSL"
git config submodule.Telegram/ThirdParty/Catch.url "$srcdir/Catch"
git config submodule.Telegram/ThirdParty/crl.url "$srcdir/crl"
git config submodule.Telegram/ThirdParty/xxHash.url "$srcdir/xxHash"
@@ -79,7 +79,7 @@ prepare() {
build() {
cd "$srcdir/tdesktop"
export LANG=en_US.UTF-8
- export GYP_DEFINES="TDESKTOP_DISABLE_CRASH_REPORTS,TDESKTOP_DISABLE_AUTOUPDATE,TDESKTOP_DISABLE_REGISTER_CUSTOM_SCHEME,TDESKTOP_DISABLE_UNITY_INTEGRATION"
+ export GYP_DEFINES="TDESKTOP_DISABLE_CRASH_REPORTS,TDESKTOP_DISABLE_AUTOUPDATE,TDESKTOP_DISABLE_REGISTER_CUSTOM_SCHEME"
export EXTRA_FLAGS="-Winvalid-pch"
export CPPFLAGS="$CPPFLAGS $EXTRA_FLAGS"
export CXXFLAGS="$CXXFLAGS $EXTRA_FLAGS"
diff --git a/no-gtk2.patch b/no-gtk2.patch
index c510ef8b1c0d..f2384e322dc0 100644
--- a/no-gtk2.patch
+++ b/no-gtk2.patch
@@ -1,8 +1,7 @@
-diff --git a/Telegram/SourceFiles/platform/linux/linux_libs.cpp b/Telegram/SourceFiles/platform/linux/linux_libs.cpp
-index b2d12a838..77c6abf7d 100644
---- a/Telegram/SourceFiles/platform/linux/linux_libs.cpp
-+++ b/Telegram/SourceFiles/platform/linux/linux_libs.cpp
-@@ -240,24 +240,12 @@ void start() {
+diff -Naur tdesktop-1.2.6.orig/Telegram/SourceFiles/platform/linux/linux_libs.cpp tdesktop-1.2.6/Telegram/SourceFiles/platform/linux/linux_libs.cpp
+--- tdesktop-1.2.6.orig/Telegram/SourceFiles/platform/linux/linux_libs.cpp 2017-12-30 11:13:48.000000000 +0100
++++ tdesktop-1.2.6/Telegram/SourceFiles/platform/linux/linux_libs.cpp 2018-01-17 11:41:49.593275952 +0100
+@@ -253,24 +253,12 @@
indicatorLoaded = setupAppIndicator(lib_indicator);
}
}
diff --git a/tdesktop.patch b/tdesktop.patch
index 34d4c6fab59d..e3d0d44aea1f 100644
--- a/tdesktop.patch
+++ b/tdesktop.patch
@@ -242,7 +242,7 @@ index a0e1e0489..223113081 100644
IMPLICIT_DEPENDS CXX "${_pch_header}"
COMMENT "Precompiling header ${_name} for ${_target} (C++)")
diff --git a/Telegram/gyp/Telegram.gyp b/Telegram/gyp/Telegram.gyp
-index 1cab5ae29..cc794d341 100644
+index 1cab5ae29..465e8276a 100644
--- a/Telegram/gyp/Telegram.gyp
+++ b/Telegram/gyp/Telegram.gyp
@@ -75,7 +75,6 @@
@@ -261,7 +261,7 @@ index 1cab5ae29..cc794d341 100644
'AL_ALEXT_PROTOTYPES',
'TGVOIP_USE_CXX11_LIB',
'XXH_INLINE_ALL',
-@@ -94,15 +92,7 @@
+@@ -94,16 +92,8 @@
'include_dirs': [
'<(src_loc)',
'<(SHARED_INTERMEDIATE_DIR)',
@@ -274,10 +274,11 @@ index 1cab5ae29..cc794d341 100644
- '<(libs_loc)/range-v3/include',
- '<(minizip_loc)',
- '<(sp_media_key_tap_loc)',
-+ '/usr/include/minizip',
'<(emoji_suggestions_loc)',
++ '/usr/include/minizip',
'<(submodules_loc)/GSL/include',
'<(submodules_loc)/variant/include',
+ '<(submodules_loc)/crl/src',
diff --git a/Telegram/gyp/qt.gypi b/Telegram/gyp/qt.gypi
index 0b783ec21..3f917765a 100644
--- a/Telegram/gyp/qt.gypi
@@ -435,7 +436,7 @@ index f5624a82b..1129a95c5 100644
'-no-compress',
'<(RULE_INPUT_PATH)',
diff --git a/Telegram/gyp/settings_linux.gypi b/Telegram/gyp/settings_linux.gypi
-index 17219fa2c..b00fd50ea 100644
+index 17219fa2c..6853b5c3e 100644
--- a/Telegram/gyp/settings_linux.gypi
+++ b/Telegram/gyp/settings_linux.gypi
@@ -11,7 +11,6 @@
@@ -446,15 +447,6 @@ index 17219fa2c..b00fd50ea 100644
'-W',
'-fPIC',
'-Wno-unused-variable',
-@@ -43,7 +42,7 @@
- 'sources': [ '__Wrong_Official_Build_Target_<(official_build_target)_' ],
- }],
- ],
-- }], [ '"<!(uname -p)" == "x86_64"', {
-+ }], [ '"<!(uname -m)" == "x86_64"', {
- # 32 bit version can't be linked with debug info or LTO,
- # virtual memory exhausted :(
- 'cflags_c': [ '-g' ],
@@ -60,7 +59,6 @@
],
'defines': [
@@ -464,7 +456,7 @@ index 17219fa2c..b00fd50ea 100644
],
'cflags_c': [
diff --git a/Telegram/gyp/telegram_linux.gypi b/Telegram/gyp/telegram_linux.gypi
-index 80259c687..5f33ff961 100644
+index 80259c687..b5e3c18a2 100644
--- a/Telegram/gyp/telegram_linux.gypi
+++ b/Telegram/gyp/telegram_linux.gypi
@@ -23,10 +23,11 @@
@@ -524,14 +516,7 @@ index 80259c687..5f33ff961 100644
# '<!(pkg-config 2> /dev/null --libs <@(pkgconfig_libs))',
],
'cflags_cc': [
-@@ -90,16 +83,14 @@
- },
- },
- 'conditions': [
-- [ '"<!(uname -p)" != "x86_64"', {
-+ [ '"<!(uname -m)" != "x86_64"', {
- 'ldflags': [
- '-Wl,-wrap,__divmoddi4',
+@@ -96,10 +89,8 @@
],
}], ['not_need_gtk!="True"', {
'cflags_cc': [