summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Witschel2020-01-03 21:33:19 +0100
committerJonas Witschel2020-01-03 21:33:19 +0100
commit87c417727fa29df891cd38deb1accfa222c697bd (patch)
tree1633468d0e79886e30952f16a3812bdc9bcbabcb
parent262cdfdd638a95c68e54e9685ba1475cb1979d0f (diff)
downloadaur-87c417727fa29df891cd38deb1accfa222c697bd.tar.gz
upgpkg: tpm2-tss-git 2.0.0.r454.c41705d5-1
- Configure directories for new FAPI library. - sysusers.d configuration is now provided by upstream.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4824ee717de1..98bc1cac00f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tpm2-tss-git
pkgdesc = Implementation of the TCG Trusted Platform Module 2.0 Software Stack (TSS2)
- pkgver = 2.0.0.r409.76641c1e
+ pkgver = 2.0.0.r454.c41705d5
pkgrel = 1
url = https://github.com/tpm2-software/tpm2-tss
arch = x86_64
@@ -16,6 +16,9 @@ pkgbase = tpm2-tss-git
depends = openssl
provides = tpm2-tss
conflicts = tpm2-tss
+ backup = etc/tpm2-tss/fapi-config.json
+ backup = etc/tpm2-tss/fapi-profiles/P_ECCP256SHA256.json
+ backup = etc/tpm2-tss/fapi-profiles/P_RSA2048SHA256.json
source = git+https://github.com/tpm2-software/tpm2-tss.git
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 92b0b0204bd0..22d72cf3f3be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jonas Witschel <diabonas@archlinux.org>
# Contributor: Hexchain Tong <i at hexchain dot org>
pkgname=tpm2-tss-git
-pkgver=2.0.0.r409.76641c1e
+pkgver=2.0.0.r454.c41705d5
pkgrel=1
pkgdesc='Implementation of the TCG Trusted Platform Module 2.0 Software Stack (TSS2)'
arch=('x86_64')
@@ -13,6 +13,9 @@ checkdepends=('cmocka' # for unit test suite
'ibm-sw-tpm2' 'iproute2' 'procps-ng' 'uthash') # for integration test suite
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
+backup=('etc/tpm2-tss/fapi-config.json'
+ 'etc/tpm2-tss/fapi-profiles/P_ECCP256SHA256.json'
+ 'etc/tpm2-tss/fapi-profiles/P_RSA2048SHA256.json')
source=("git+$url.git")
sha512sums=('SKIP')
@@ -28,8 +31,10 @@ prepare() {
build() {
cd "${pkgname%-git}"
- (( CHECKFUNC )) && _opts=('--enable-unit' '--enable-integration')
- ./configure --prefix=/usr --with-udevrulesprefix=60- "${_opts[@]}"
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --with-runstatedir=/run --with-sysusersdir=/usr/lib/sysusers.d \
+ --with-tmpfilesdir=/usr/lib/tmpfiles.d --with-udevrulesprefix=60- \
+ $( ((CHECKFUNC)) && echo --enable-unit --enable-integration)
make
}
@@ -42,5 +47,4 @@ package() {
cd "${pkgname%-git}"
make DESTDIR="$pkgdir" install
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
- echo 'u tss - "tss user for tpm2"' | install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
}