summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2024-02-19 14:04:36 +0100
committerNicola Murino2024-02-19 14:04:36 +0100
commit87c8b4c3148090538a3e07eb1096ee4679f44ab1 (patch)
treedd7036899e386c25126592702b03d2499391a3c1
parent62075fdfd797c61efa0a558dfb9a6f3607ca310e (diff)
downloadaur-87c8b4c3148090538a3e07eb1096ee4679f44ab1.tar.gz
8.6.0
-rw-r--r--.SRCINFO8
-rw-r--r--0003-libpsl-static-libs.patch22
-rw-r--r--PKGBUILD8
3 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9075d3324479..80a9c8d090a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-curl
pkgdesc = An URL retrival utility and library (mingw-w64)
- pkgver = 8.5.0
+ pkgver = 8.6.0
pkgrel = 1
url = https://curl.haxx.se
arch = any
@@ -18,13 +18,13 @@ pkgbase = mingw-w64-curl
options = staticlibs
options = !strip
options = !buildflags
- source = https://curl.haxx.se/download/curl-8.5.0.tar.bz2
+ source = https://curl.haxx.se/download/curl-8.6.0.tar.xz
source = 0002-nghttp2-static.patch
source = 0003-libpsl-static-libs.patch
source = 0004-more-static-fixes.patch
- sha256sums = ce4b6a6655431147624aaf582632a36fe1ade262d5fab385c60f78942dd8d87b
+ sha256sums = 3ccd55d91af9516539df80625f818c734dc6f2ecf9bada33c76765e99121db15
sha256sums = 3ee9c75a3046f86f91290c143170179230c9adc6eabfbb79eb26f708a165b719
- sha256sums = 7492d019036b5bec251bfbc3c0b40e5f16d3dd6b2515068835e087a6c21f19ad
+ sha256sums = 79aa3b1d1a6d943341d9c7f9ce69b46a5f454bf9fedaf5530b0cbcefa65fa31e
sha256sums = 590eb65e90e756eaad993d52a101f29091ada2c742c5a607684e88fc5c560d54
pkgname = mingw-w64-curl
diff --git a/0003-libpsl-static-libs.patch b/0003-libpsl-static-libs.patch
index ce33b87eedb5..71e7efd5e115 100644
--- a/0003-libpsl-static-libs.patch
+++ b/0003-libpsl-static-libs.patch
@@ -1,16 +1,14 @@
---- curl-7.64.1.orig/configure.ac 2019-03-29 18:14:22.692813700 -0400
-+++ curl-7.64.1/configure.ac 2019-03-29 18:52:44.514352300 -0400
-@@ -2747,14 +2747,30 @@
- with_libpsl=$withval,
+--- curl-8.6.0/configure.ac.orig 2024-01-31 08:31:51.163839600 +0100
++++ curl-8.6.0/configure.ac 2024-01-31 08:33:39.021970100 +0100
+@@ -2059,12 +2059,30 @@
with_libpsl=yes)
+ curl_psl_msg="no (libpsl disabled)"
if test $with_libpsl != "no"; then
- AC_SEARCH_LIBS(psl_builtin, psl,
- [curl_psl_msg="enabled";
- AC_DEFINE([USE_LIBPSL], [1], [PSL support enabled])
- ],
-- [curl_psl_msg="no (libpsl not found)";
-- AC_MSG_WARN([libpsl was not found])
-- ]
+- [AC_MSG_ERROR([libpsl was not found]) ]
- )
+ CURL_CHECK_PKGCONFIG(libpsl)
+ if test "$PKGCONFIG" != "no" ; then
@@ -27,12 +25,12 @@
+ else
+ dnl no nghttp2 pkg-config found, deal with it
+ AC_SEARCH_LIBS(psl_builtin, psl,
-+ [curl_psl_msg="enabled";
-+ AC_DEFINE([USE_LIBPSL], [1], [PSL support enabled])
-+ ],
++ [curl_psl_msg="yes";
++ AC_DEFINE([USE_LIBPSL], [1], [PSL support enabled])
++ ],
+ [curl_psl_msg="no (libpsl not found)";
-+ AC_MSG_WARN([libpsl was not found])
-+ ]
++ AC_MSG_WARN([libpsl was not found])
++ ]
+ )
+ fi
+
diff --git a/PKGBUILD b/PKGBUILD
index b457a02db353..a202ed726e53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: ant32 <antreimer at gmail dot com>
pkgname=mingw-w64-curl
-pkgver=8.5.0
+pkgver=8.6.0
pkgrel=1
pkgdesc="An URL retrival utility and library (mingw-w64)"
arch=('any')
@@ -20,13 +20,13 @@ depends=('mingw-w64-crt'
'mingw-w64-zlib')
makedepends=('mingw-w64-configure')
options=('staticlibs' '!strip' '!buildflags')
-source=("${url}/download/curl-${pkgver}.tar.bz2"
+source=("${url}/download/curl-${pkgver}.tar.xz"
"0002-nghttp2-static.patch"
"0003-libpsl-static-libs.patch"
"0004-more-static-fixes.patch")
-sha256sums=('ce4b6a6655431147624aaf582632a36fe1ade262d5fab385c60f78942dd8d87b'
+sha256sums=('3ccd55d91af9516539df80625f818c734dc6f2ecf9bada33c76765e99121db15'
'3ee9c75a3046f86f91290c143170179230c9adc6eabfbb79eb26f708a165b719'
- '7492d019036b5bec251bfbc3c0b40e5f16d3dd6b2515068835e087a6c21f19ad'
+ '79aa3b1d1a6d943341d9c7f9ce69b46a5f454bf9fedaf5530b0cbcefa65fa31e'
'590eb65e90e756eaad993d52a101f29091ada2c742c5a607684e88fc5c560d54')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"