summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhalosghost2015-09-30 17:38:02 -0500
committerhalosghost2015-09-30 17:38:02 -0500
commit87cfe2580c6bb9c49c76d2c302705b0192ffa0d3 (patch)
tree9c111d3b83bc47fa4b8fb9eeb48ebbab94d4e3d3
parentbbeafde5c05fcadc76525ad3bd16c7e4b42d8207 (diff)
downloadaur-87cfe2580c6bb9c49c76d2c302705b0192ffa0d3.tar.gz
Update for version 1.14
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a12e96756a5..2ff3d33e6e6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = heavything
pkgdesc = A General purpose x64 Asm library for 2ton products
- pkgver = 1.13
+ pkgver = 1.14
pkgrel = 1
url = https://2ton.com.au/HeavyThing
arch = x86_64
license = GPL3
makedepends = fasm
- source = https://2ton.com.au/HeavyThing-1.13.tar.gz
- sha256sums = 95e46bcaef8a90257ae2d81330700d72da0bb633c4ff38fbfeaded30c4f106c6
+ source = https://2ton.com.au/HeavyThing-1.14.tar.gz
+ sha256sums = 2a22cc7e04b4cf8a9550fab685145964474f72dbac32a97a9eb3d0090deff745
pkgname = rwasa
pkgdesc = a full featured web server that eclipses nginx
diff --git a/PKGBUILD b/PKGBUILD
index e95165a5d799..8806b0724bd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Maintainer: polyzen <polycitizen at gmail dot com>
pkgbase=heavything
pkgname=('rwasa' 'webslap' 'hnwatch' 'dhtool' 'sshtalk' 'toplip')
-pkgver=1.13
+pkgver=1.14
pkgrel=1
pkgdesc='A General purpose x64 Asm library for 2ton products'
arch=('x86_64')
@@ -11,13 +11,11 @@ makedepends=('fasm')
url='https://2ton.com.au/HeavyThing'
license=('GPL3')
source=("https://2ton.com.au/HeavyThing-$pkgver.tar.gz")
-sha256sums=('95e46bcaef8a90257ae2d81330700d72da0bb633c4ff38fbfeaded30c4f106c6')
+sha256sums=('2a22cc7e04b4cf8a9550fab685145964474f72dbac32a97a9eb3d0090deff745')
build () {
cd "HeavyThing-$pkgver"
- for i in rwasa webslap hnwatch dhtool sshtalk toplip; do
- (cd "$i"; fasm -m 262144 "$i.asm" && ld -o "$i" "$i.o")
- done
+ ./assemble_all.sh
}
package_rwasa () {