summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2023-02-13 10:40:52 +0100
committerMartin Diehl2023-02-13 10:41:21 +0100
commit881046d79461abe013a9ab82a19a9f1442b207f9 (patch)
treef8a69d38db9fcbe4ebf8f61fb0416b22bcf87f66
parent517e0421dbb4bdc97af6479321981df3cff48c2a (diff)
downloadaur-881046d79461abe013a9ab82a19a9f1442b207f9.tar.gz
small improvements
thanks to jedbrown and nauaneed
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5eb744b638ca..0d5626e56905 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = scotch
pkgdesc = Software package and libraries for graph, mesh and hypergraph partitioning, static mapping, and sparse matrix block ordering. This is the all-inclusive version (MPI/serial/esmumps).
pkgver = 7.0.3
- pkgrel = 1
+ pkgrel = 2
url = https//gitlab.inria.fr/scotch/scotch
arch = i686
arch = x86_64
license = custom:CeCILL-C
makedepends = gcc-fortran
makedepends = cmake
+ makedepends = flex
+ makedepends = bison
depends = zlib
depends = openmpi
depends = bzip2
diff --git a/PKGBUILD b/PKGBUILD
index 00eade9bb3de..8544c3858f8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
# Contributor: Samuel Williams <samuel.williams@oriontransfer.co.nz>
pkgname=scotch
pkgver=7.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="Software package and libraries for graph, mesh and hypergraph partitioning, static mapping, and sparse matrix block ordering. This is the all-inclusive version (MPI/serial/esmumps)."
url="https//gitlab.inria.fr/scotch/scotch"
license=("custom:CeCILL-C")
depends=('zlib' 'openmpi' 'bzip2')
-makedepends=('gcc-fortran' 'cmake')
+makedepends=('gcc-fortran' 'cmake' 'flex' 'bison')
provides=('ptscotch' 'ptscotch-openmpi' 'scotch_esmumps' 'scotch_ptesmumps')
conflicts=('ptscotch-openmpi' 'scotch_esmumps' 'scotch_esmumps5')
arch=('i686' 'x86_64')
@@ -33,7 +33,7 @@ build() {
}
check() {
- if [ -z $(ldconfig -p | grep libcuda.so.1) ]; then
+ if [ -z "$(ldconfig -p | grep libcuda.so.1)" ]; then
export _libcuda=0
fi
cmake --build build --parallel --target test