summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-07-22 16:10:04 +0000
committerDaniel Bermond2018-07-22 16:20:50 +0000
commit883b7cdf28285667897624fa5bbe7c9c84c1d2cb (patch)
treed3e6e785cb581b9de20abfd0731f19f27b8822e8
parentfee8f4d75558e51fd5ed3ec1267029060a49fa02 (diff)
downloadaur-883b7cdf28285667897624fa5bbe7c9c84c1d2cb.tar.gz
Various changes
Changes: - add more Debian patches - remove .install file (icon cache update is handled by pacman hooks) - remove POTFILES.skip file - remove $screenshot variable - remove makedepends - simplified depends - fix license (it is GPL3 and later) - remove license installation (GPL3 is a common license supplied by Arch and should not be installed) - remove installation of undesired doc files - switch checksum method from md5sum to sha256sum - use DESTDIR in make install - cosmetic changes
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD69
-rw-r--r--POTFILES.skip3
-rw-r--r--pdfchain-fix-crash-on-startup.patch (renamed from fix_crash_on_startup.patch)0
-rw-r--r--pdfchain-fix-desktop-file.patch18
-rw-r--r--pdfchain-fix-spelling.patch43
-rw-r--r--pdfchain.install12
7 files changed, 111 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 099b68a08518..32aaeb004aba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,23 @@
-# Generated by mksrcinfo v8
-# Tue Oct 24 22:05:34 UTC 2017
pkgbase = pdfchain
- pkgdesc = PDF Chain is a Graphical User Interface for the PDF Tool Kit
+ pkgdesc = A graphical user interface for the PDF toolkit
pkgver = 0.4.4.2
- pkgrel = 2
+ pkgrel = 3
url = http://pdfchain.sourceforge.net/
- install = pdfchain.install
arch = i686
arch = x86_64
- license = GPL
- makedepends = intltool
- makedepends = atkmm
- makedepends = glibmm
- depends = pdftk
+ license = GPL3
+ depends = gcc-libs
depends = gtkmm3
- depends = fontconfig
- depends = libpng
+ depends = pdftk
+ options = !emptydirs
source = http://sourceforge.net/projects/pdfchain/files/pdfchain-0.4.4.2/pdfchain-0.4.4.2.tar.gz
- source = POTFILES.skip
- source = fix_crash_on_startup.patch
- md5sums = 8b20a3d46ea4caa174dbe12ca6bc39be
- md5sums = b16ca527af3a13ec163c86927555f125
- md5sums = fc4b04d450b89c06e60e03c573857098
+ source = pdfchain-fix-crash-on-startup.patch
+ source = pdfchain-fix-desktop-file.patch
+ source = pdfchain-fix-spelling.patch
+ sha256sums = 1eee0f93dbe8c9cef9f9fe4ec0a10e0a45ca8cde67cd6ceffa2ce6c843752f3d
+ sha256sums = fa46f0fefc1bd0b9b224d07c45c620fab5266805309dcd634daa778e75de1b80
+ sha256sums = c51cc32abd3c26602818445bb266bea50c44e7792ee07569412713ecd82e0b9d
+ sha256sums = 7629af76a6f15b7a5c558699edd3379a936d4b9317411c9841604e83cfac85f6
pkgname = pdfchain
diff --git a/PKGBUILD b/PKGBUILD
index d2b40846a869..9f8605e04842 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer : Marcos Heredia <chelqo@gmail.com>
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Contributor: Marcos Heredia <chelqo@gmail.com>
# Contributor: yury <polek_yury@ukr.net>
# Contributor: Carlos Maddela <e7appew@gmail.com> (Ubuntu)
# Contributor: Carlo Bertelli <carlo.bertelli@gmail.com>
@@ -6,44 +7,48 @@
pkgname=pdfchain
pkgver=0.4.4.2
-pkgrel=2
-pkgdesc="PDF Chain is a Graphical User Interface for the PDF Tool Kit"
-url="http://pdfchain.sourceforge.net/"
-screenshot="http://pdfchain.sourceforge.net/images/screenshots/${pkgver}/pdfchain_-_title.png"
-license=("GPL")
-install=pdfchain.install
+pkgrel=3
+pkgdesc='A graphical user interface for the PDF toolkit'
arch=('i686' 'x86_64')
-depends=('pdftk' 'gtkmm3' 'fontconfig' 'libpng')
-makedepends=('intltool' 'atkmm' 'glibmm')
-source=("http://sourceforge.net/projects/pdfchain/files/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz"
- "POTFILES.skip"
- "fix_crash_on_startup.patch")
-md5sums=('8b20a3d46ea4caa174dbe12ca6bc39be'
- 'b16ca527af3a13ec163c86927555f125'
- 'fc4b04d450b89c06e60e03c573857098')
+url='http://pdfchain.sourceforge.net/'
+license=('GPL3')
+depends=(
+ # official repositories:
+ 'gcc-libs' 'gtkmm3'
+ # AUR:
+ 'pdftk'
+)
+options=('!emptydirs')
+source=("http://sourceforge.net/projects/${pkgname}/files/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ 'pdfchain-fix-crash-on-startup.patch'
+ 'pdfchain-fix-desktop-file.patch'
+ 'pdfchain-fix-spelling.patch')
+sha256sums=('1eee0f93dbe8c9cef9f9fe4ec0a10e0a45ca8cde67cd6ceffa2ce6c843752f3d'
+ 'fa46f0fefc1bd0b9b224d07c45c620fab5266805309dcd634daa778e75de1b80'
+ 'c51cc32abd3c26602818445bb266bea50c44e7792ee07569412713ecd82e0b9d'
+ '7629af76a6f15b7a5c558699edd3379a936d4b9317411c9841604e83cfac85f6')
prepare() {
- cd $srcdir/$pkgname-$pkgver
- patch -p1 < ../fix_crash_on_startup.patch
+ cd "${pkgname}-${pkgver}"
+
+ patch -Np1 -i "${srcdir}/pdfchain-fix-crash-on-startup.patch"
+ patch -Np1 -i "${srcdir}/pdfchain-fix-desktop-file.patch"
+ patch -Np1 -i "${srcdir}/pdfchain-fix-spelling.patch"
}
build() {
- cd $srcdir/$pkgname-$pkgver
- cp $startdir/POTFILES.skip po/
- ./configure --prefix=/usr
- make || return 1
+ cd "${pkgname}-${pkgver}"
+
+ ./configure --prefix='/usr'
+
+ make
}
package() {
- cd $srcdir/$pkgname-$pkgver
- make prefix=$pkgdir/usr install
-
- install -dpm755 "$pkgdir/usr/share/licenses/$pkgname/"
- install -Dpm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/"
-
- install -dpm755 "$pkgdir/usr/share/doc/$pkgname/"
- install -Dpm644 AUTHORS ChangeLog INSTALL README "$pkgdir/usr/share/doc/$pkgname/"
- cd $pkgdir/usr/share/doc/$pkgname/ ; rm COPYING NEWS
-
- echo "Comment[es]=Interface grafica para el PDF Toolkit (pdftk)" >>$pkgdir/usr/share/applications/pdfchain.desktop
+ cd "${pkgname}-${pkgver}"
+
+ make DESTDIR="$pkgdir" install
+
+ # remove undesired doc files
+ rm "${pkgdir}/usr/share/doc/${pkgname}/"{AUTHORS,ChangeLog,COPYING,INSTALL,NEWS,README}
}
diff --git a/POTFILES.skip b/POTFILES.skip
deleted file mode 100644
index 9c8bf4097b03..000000000000
--- a/POTFILES.skip
+++ /dev/null
@@ -1,3 +0,0 @@
-src/window_main_permission.cc
-src/window_main_tool.cc
-
diff --git a/fix_crash_on_startup.patch b/pdfchain-fix-crash-on-startup.patch
index e2232f7ecf81..e2232f7ecf81 100644
--- a/fix_crash_on_startup.patch
+++ b/pdfchain-fix-crash-on-startup.patch
diff --git a/pdfchain-fix-desktop-file.patch b/pdfchain-fix-desktop-file.patch
new file mode 100644
index 000000000000..c94c96eba586
--- /dev/null
+++ b/pdfchain-fix-desktop-file.patch
@@ -0,0 +1,18 @@
+Description: Change the desktop file to current standards.
+Author: Johann Felix Soden <johfel@debian.org>
+--- a/application/pdfchain.desktop
++++ b/application/pdfchain.desktop
+@@ -1,5 +1,4 @@
+ [Desktop Entry]
+-Encoding=UTF-8
+ Name=PDF Chain
+ GenericName=pdfchain
+ Comment=A graphical user interface for the PDF Toolkit (PDFtk)
+@@ -10,6 +9,7 @@
+ Categories=Office;
+ MimeType=application/pdf;
+ Terminal=false
++Keywords=pdf,splitting,concatenating,form,converting,user-interface
+ Comment[de]=Eine grafische Benutzerschnittstelle für das PDF Toolkit (PDFtk)
+ #Comment[en]=
+ Comment[es]=Interfaz del usuario grafica para el PDF Toolkit (PDFtk)
diff --git a/pdfchain-fix-spelling.patch b/pdfchain-fix-spelling.patch
new file mode 100644
index 000000000000..6944a13e04d4
--- /dev/null
+++ b/pdfchain-fix-spelling.patch
@@ -0,0 +1,43 @@
+Description: Fix various spelling errors found by lintian
+Author: Johann Felix Soden <johfel@debian.org>
+--- a/src/window_main_burst.cc
++++ b/src/window_main_burst.cc
+@@ -85,7 +85,7 @@
+ mLabel_Pattern.set_tooltip_text( _("Prepare the pattern for the output PDF file names") );
+ mLabel_Extended.set_tooltip_text( _("Extended options to format the pattern") );
+ mLabel_SourceFile.set_tooltip_text( _("The source PDF file. "
+- "Every single page of this document will be saved in a seperate PDF file") );
++ "Every single page of this document will be saved in a separate PDF file") );
+ mLabel_Prefix.set_tooltip_text( _("Prefix part of the file name pattern") );
+ mLabel_Base.set_tooltip_text( _("Numbering base for the file counter part") );
+ mLabel_Digits.set_tooltip_text( _("Number of digits for the file counter part") );
+--- a/src/window_main_permission.cc
++++ b/src/window_main_permission.cc
+@@ -54,7 +54,7 @@
+ _("Protects the restrictions "
+ "\nMax. 32 signs (Latin-1)") );
+ mLabel_Encryption.set_tooltip_text(
+- _("If an encryption strength is given but no passwords are suplied, then the "
++ _("If an encryption strength is given but no passwords are supplied, then the "
+ "owner and user passwords remain empty, which means that the resulting "
+ "PDF may be opened and its security parameters altered by anybody.") );
+ mLabel_Allow.set_tooltip_text(
+@@ -64,12 +64,12 @@
+
+ mCButton_Printing.set_tooltip_text( _("Top quality printing") );
+ mCButton_DegradedPrinting.set_tooltip_text( _("Lower quality printing") );
+- mCButton_CopyContents.set_tooltip_text( _("Allows to copy contents\n(also allows screenreaders)") );
+- mCButton_Screenreaders.set_tooltip_text( _("Allows to read contents with screenreaders") );
+- mCButton_ModifyContents.set_tooltip_text( _("Allows to modify contents\n(also allows assembly)") );
+- mCButton_Assembly.set_tooltip_text( _("Allows to assemble contents") );
+- mCButton_ModifyAnnotations.set_tooltip_text( _("Allows to modify annotations\n(also allows to fill in)") );
+- mCButton_FillIn.set_tooltip_text( _("Allows to fill in annotations") );
++ mCButton_CopyContents.set_tooltip_text( _("Allows one to copy contents\n(also allows screenreaders)") );
++ mCButton_Screenreaders.set_tooltip_text( _("Allows one to read contents with screenreaders") );
++ mCButton_ModifyContents.set_tooltip_text( _("Allows one to modify contents\n(also allows assembly)") );
++ mCButton_Assembly.set_tooltip_text( _("Allows one to assemble contents") );
++ mCButton_ModifyAnnotations.set_tooltip_text( _("Allows one to modify annotations\n(also allows one to fill in)") );
++ mCButton_FillIn.set_tooltip_text( _("Allows one to fill in annotations") );
+
+ mRButton_EncryptNone.set_tooltip_text( _("Don't encrypt output document") );
+ mRButton_Encrypt40Bit.set_tooltip_text( _("Encrypt output document with RC4 40-bit cypher (PDF 1.1 - 1.3)") );
diff --git a/pdfchain.install b/pdfchain.install
deleted file mode 100644
index 9feb12b42294..000000000000
--- a/pdfchain.install
+++ /dev/null
@@ -1,12 +0,0 @@
-post_install() {
- gtk-update-icon-cache -t -f usr/share/icons/hicolor
-}
-
-post_upgrade() {
- post_install
-}
-
-
-post_remove() {
- post_install
-}