summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoe Baldino2022-06-24 06:06:57 +0000
committerJoe Baldino2022-06-24 06:10:46 +0000
commit8858193802e0c7cf884282d706391ddec165fdc1 (patch)
treef23f6fb370c89b45a7c7bc4f83ced28d817cebc6
parentfffde5f077fb2c08e63cbcebf393dc080230f79e (diff)
downloadaur-8858193802e0c7cf884282d706391ddec165fdc1.tar.gz
New maintainer, refresh PKGBUILD
Tweaked the license since MIT is one of a handful of special license cases, so custom: is redundant. In pkgver() explicitly set abbrev so that others (like me) who have a global default != 7 don't get nipped. TODO: namcap emits RELRO warnings, so we need to fix the upstream Makefile. Signed-off-by: Joe Baldino <pedanticdm@gmx.us>
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5cb67d72870..4518ddc75f5b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = 2048term-git
pkgdesc = Console version of the game "2048"
- pkgver = 20190609.8453a88
- pkgrel = 2
+ pkgver = 20220613.bf22f86
+ pkgrel = 1
url = https://github.com/alewmoose/2048-in-terminal.git
arch = i686
arch = x86_64
arch = armv7h
- license = custom:MIT
+ license = MIT
makedepends = git
depends = ncurses
provides = 2048term
conflicts = 2048term
source = 2048term::git+https://github.com/alewmoose/2048-in-terminal.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = 2048term-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 7ec02f3546cd..03192a3f88d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
-#Maintainer: Frederic Bezies <fredbezies at gmail dot com>
-#Contributor: Aleksandr Grehov <alewmosse@gmail.com>
+# Maintainer: Joe Baldino <pedanticdm@gmx.us>
+# Contributor: Frederic Bezies <fredbezies at gmail dot com>
+# Contributor: Aleksandr Grehov <alewmosse@gmail.com>
_pkgname='2048term'
pkgname="${_pkgname}-git"
-pkgver=20190609.8453a88
-pkgrel=2
+pkgver=20220613.bf22f86
+pkgrel=1
pkgdesc='Console version of the game "2048"'
url='https://github.com/alewmoose/2048-in-terminal.git'
arch=('i686' 'x86_64' 'armv7h')
-license=('custom:MIT')
+license=('MIT')
depends=('ncurses')
makedepends=('git')
source=("${_pkgname}::git+https://github.com/alewmoose/2048-in-terminal.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
pkgver() {
cd "${srcdir}/${_pkgname}"
- git log -1 --format='%cd.%h' --date=short | tr -d -
+ git log -1 --format='%cd.%h' --date=short --abbrev=7 | tr -d -
}
build() {