summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWinston Astrachan2020-07-24 12:30:24 -0400
committerWinston Astrachan2020-07-24 12:30:24 -0400
commit8864ba2c78e7bba00c5799c4162453942f1f93c0 (patch)
tree1d90d78562c157629dbf8583d004659077396344
parent9e6ae02573b61c699398ea6163f21539eae678e4 (diff)
downloadaur-8864ba2c78e7bba00c5799c4162453942f1f93c0.tar.gz
upgpkg: git-secret 0.3.2-2
refactor: adopt and refactor git-secret pkgbuild
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore3
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD70
4 files changed, 39 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb574d2bfef4..00b434fc325a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = git-secret
pkgdesc = A bash-tool to store your private data inside a git repository
pkgver = 0.3.2
- pkgrel = 1
- url = https://github.com/sobolevn/git-secret
+ pkgrel = 2
+ url = https://github.com/sobolevn/git-secret/
arch = any
- license = GPL
- makedepends = git
+ license = MIT
makedepends = ruby-ronn
depends = git
depends = gnupg
+ source = LICENSE
+ source = git-secret-0.3.2::https://github.com/sobolevn/git-secret/archive/v0.3.2.tar.gz
+ sha256sums = 6d4b9636df66066960e535a499484a7b334f1b362547be5314349d66fe588b05
+ sha256sums = 07b32b096e5ff5b4818096b1858c1f69df4684bb0f256e620514cf88f44ded85
pkgname = git-secret
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 56b2341f759a..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,3 +0,0 @@
-pkg
-src
-git-secret*
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..6d833c960217
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+MIT License
+
+Copyright (c) 2016 Nikita Sobolev
+
+Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 378d8563aa02..4c9e1bba1f9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,33 @@
-# Maintainer: ibrahim Tunali<ibrahimtunali@gmail.com>
+# Maintainer: Winston Astrachan <winston dot astrachan at gmail dot com>
+# Contributor: Ibrahim Tunali <ibrahimtunali at gmail dot com>
+
pkgname=git-secret
pkgver=0.3.2
-pkgrel=1
-pkgdesc="A bash-tool to store your private data inside a git repository"
+pkgrel=2
+pkgdesc='A bash-tool to store your private data inside a git repository'
arch=('any')
-url="https://github.com/sobolevn/git-secret"
-license=('GPL')
-groups=()
+url='https://github.com/sobolevn/git-secret/'
+license=('MIT')
depends=('git' 'gnupg')
-makedepends=('git' 'ruby-ronn')
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-source=()
-noextract=()
-md5sums=()
-
-_gitroot=https://github.com/sobolevn/git-secret.git
-_gitname=git-secret
+makedepends=('ruby-ronn')
+source=('LICENSE'
+ "git-secret-${pkgver}::https://github.com/sobolevn/git-secret/archive/v${pkgver}.tar.gz"
+)
+sha256sums=('6d4b9636df66066960e535a499484a7b334f1b362547be5314349d66fe588b05'
+ '07b32b096e5ff5b4818096b1858c1f69df4684bb0f256e620514cf88f44ded85'
+)
build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin && git checkout "v$pkgver"
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname" -b "v$pkgver"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
-
- #
- # BUILD HERE
- #
- make build
- make build-man
+ cd "$srcdir/git-secret-${pkgver}"
+ make clean build build-man
}
package() {
- cd "$srcdir/$_gitname-build"
- install -D -m644 man/man1/*.1 -t $pkgdir/usr/share/man/man1/
- install -D -m644 man/man7/*.7 -t $pkgdir/usr/share/man/man7/
- install -D -m755 git-secret -t $pkgdir/usr/bin/
-}
+ cd "$srcdir"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-# vim:set ts=2 sw=2 et:
+ cd "git-secret-${pkgver}"
+ install -Dm755 git-secret "$pkgdir/usr/bin/git-secret"
+ install -Dm644 man/man1/*.1 -t "$pkgdir/usr/share/man/man1/"
+ install -Dm644 man/man7/*.7 -t "$pkgdir/usr/share/man/man7/"
+}