summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkafin2018-01-20 14:39:04 +0100
committerkafin2018-01-20 14:39:04 +0100
commit886c025d2c84639c6d331d1443da2913b5fb1078 (patch)
tree3f43cf5198a60fcf5ca5e7823d34c09144299c15
downloadaur-886c025d2c84639c6d331d1443da2913b5fb1078.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
-rw-r--r--decred-dcr.svg31
-rw-r--r--decrediton.desktop10
5 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76205c561212
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = decrediton
+ pkgdesc = Decrediton is a cross-platform GUI for decred written in node.js using Electron.
+ pkgver = 1.1.3
+ pkgrel = 1
+ url = https://decred.org/
+ arch = x86_64
+ license = ISC
+ source = https://github.com/decred/decred-binaries/releases/download/v1.1.3/decrediton-v1.1.3.tar.gz
+ source = decred-dcr.svg
+ source = decrediton.desktop
+ sha256sums = d5b4e8ab3844866bd16959666eae3dfdc46e9452f3aca03c20ae2e2f259a38de
+ sha256sums = a5d4ca6879438bbf02999dbf84f4fb3b0088fbac385f6cbc9722baf1baa7c8aa
+ sha256sums = b2693919cdd9557676f1c3f6e5ed167080d8ce52cab7fca385796aa9bd4baab5
+
+pkgname = decrediton
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..470c58c1719b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.gz
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ab9e8ef8d7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Kafin <kevinliteon01@hotmail.com>
+
+pkgname=decrediton
+pkgver=1.1.3
+_pkgver="v${pkgver}"
+pkgrel=1
+pkgdesc="Decrediton is a cross-platform GUI for decred written in node.js using Electron."
+arch=('x86_64')
+url="https://decred.org/"
+license=('ISC')
+source=("https://github.com/decred/decred-binaries/releases/download/${_pkgver}/${pkgname}-${_pkgver}.tar.gz"
+ "decred-dcr.svg"
+ "${pkgname}.desktop")
+sha256sums=('d5b4e8ab3844866bd16959666eae3dfdc46e9452f3aca03c20ae2e2f259a38de'
+ 'a5d4ca6879438bbf02999dbf84f4fb3b0088fbac385f6cbc9722baf1baa7c8aa'
+ 'b2693919cdd9557676f1c3f6e5ed167080d8ce52cab7fca385796aa9bd4baab5')
+
+package() {
+ # Install the main files.
+ install -d "${pkgdir}/opt/${pkgname}"
+ cp -a "${srcdir}/${pkgname}-${pkgver}/." "${pkgdir}/opt/${pkgname}"
+
+ # Exec bit
+ chmod 755 "${pkgdir}/opt/${pkgname}/${pkgname}"
+
+ # Desktop Entry
+ install -d "${pkgdir}/usr/share/applications"
+ install "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications"
+
+ # Main binary
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+
+ # Create symbolic link to the icon
+ install -d "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 $srcdir/decred-dcr.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/$pkgname.svg
+}
diff --git a/decred-dcr.svg b/decred-dcr.svg
new file mode 100644
index 000000000000..c6e13dc87475
--- /dev/null
+++ b/decred-dcr.svg
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!-- Generator: Adobe Illustrator 21.0.0, SVG Export Plug-In . SVG Version: 6.00 Build 0) -->
+<svg version="1.1" id="Laag_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
+ viewBox="0 0 102.6 79.1" style="enable-background:new 0 0 102.6 79.1;" xml:space="preserve">
+<style type="text/css">
+ .st0{fill:url(#_Pad__1_);}
+ .st1{fill:#4971FA;}
+ .st2{fill:url(#_Pad_3_1_);}
+</style>
+<title>dcr</title>
+<g id="Laag_3">
+ <g id="Layer_1-2">
+
+ <linearGradient id="_Pad__1_" gradientUnits="userSpaceOnUse" x1="-7558.0513" y1="912.3351" x2="-7500.7217" y2="912.3351" gradientTransform="matrix(1 0 0 1 7603.2002 -872.83)">
+ <stop offset="0" style="stop-color:#62D0C9"/>
+ <stop offset="1" style="stop-color:#7DE2AC"/>
+ </linearGradient>
+ <path id="_Pad_" class="st0" d="M45.1,49.1h25.3c9.4,0,17.1-7.6,17.1-17.1S79.9,15,70.5,15h-8.1L45.1,0h25.3
+ c17.7-0.1,32.1,14.2,32.1,31.9c0.1,13.1-7.9,24.9-20.1,29.8l20,17.3H79.6L45.1,49.1z"/>
+ <path id="_Pad_2" class="st1" d="M57.5,30H32.2c-9.4,0-17.1,7.6-17.1,17.1s7.6,17.1,17.1,17.1h8.1l17.2,15H32.2
+ C14.5,79.2,0.1,64.9,0,47.3c-0.1-13.2,7.9-25,20.1-29.9L0.1,0H23L57.5,30z"/>
+
+ <linearGradient id="_Pad_3_1_" gradientUnits="userSpaceOnUse" x1="-7603.021" y1="912.3806" x2="-7545.6909" y2="912.3806" gradientTransform="matrix(1 0 0 1 7603.2002 -872.83)">
+ <stop offset="0" style="stop-color:#3268FB"/>
+ <stop offset="1" style="stop-color:#4795FA"/>
+ </linearGradient>
+ <path id="_Pad_3" class="st2" d="M57.5,30H32.2c-9.4,0-17.1,7.6-17.1,17.1s7.6,17.1,17.1,17.1h8.1l17.2,15H32.2
+ C14.5,79.2,0.1,64.9,0,47.3c-0.1-13.2,7.9-25,20.1-29.9L0.1,0H23L57.5,30z"/>
+ </g>
+</g>
+</svg>
diff --git a/decrediton.desktop b/decrediton.desktop
new file mode 100644
index 000000000000..b1785b6632dd
--- /dev/null
+++ b/decrediton.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Decrediton
+Exec=decrediton %f
+Icon=decrediton
+Comment=Decrediton is a cross-platform GUI for decred written in node.js using Electron.
+Categories=Utility;
+Terminal=false
+StartupNotify=true \ No newline at end of file