summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPedroHLC2019-05-31 09:35:05 -0300
committerPedroHLC2019-05-31 09:35:05 -0300
commit886e7bb3a2ac3395ccf4305ad07f913b38a157f3 (patch)
treea60e3415966d1f30094750e36f2994caede6fccf
downloadaur-886e7bb3a2ac3395ccf4305ad07f913b38a157f3.tar.gz
Init
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31132894676d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = wlcs
+ pkgdesc = Canonical's protocol-conformance-verifying test suite for Wayland compositor implementations.
+ pkgver = 1.0.0
+ pkgrel = 0
+ url = https://github.com/MirServer/wlcs
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = boost
+ makedepends = gmock
+ makedepends = wayland-protocols
+ depends = gtest
+ depends = boost-libs
+ depends = wayland
+ source = https://github.com/MirServer/wlcs/releases/download/v1.0.0/wlcs-1.0.0.tar.xz
+ sha256sums = 8d88e029c5bac25d2995e916d5cc145006347f3541e5c1e1dc7c8f17ade8e1d4
+
+pkgname = wlcs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c6331f892c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=wlcs
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="Canonical's protocol-conformance-verifying test suite for Wayland compositor implementations."
+url='https://github.com/MirServer/wlcs'
+arch=(x86_64 i686)
+license=(GPL)
+depends=(gtest boost-libs wayland)
+makedepends=(git cmake boost gmock wayland-protocols)
+optdepends=()
+source=("https://github.com/MirServer/wlcs/releases/download/v${pkgver}/wlcs-${pkgver}.tar.xz")
+sha256sums=('8d88e029c5bac25d2995e916d5cc145006347f3541e5c1e1dc7c8f17ade8e1d4')
+
+BUILD_DIR=build
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ mkdir -p "${BUILD_DIR}"
+ cd "${BUILD_DIR}"
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -DCMAKE_INSTALL_LIBDIR="lib/" ..
+ cmake --build ./
+}
+
+package() {
+ cd "${pkgname}-${pkgver}/${BUILD_DIR}"
+ make DESTDIR="${pkgdir}/" install
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file